summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2020-11-22 18:57:53 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2020-11-22 19:00:24 +0200
commit811fff30b782a18f80c85e8d1edf10fcec392445 (patch)
treed95928158c19ca7b230c67780f313e97b6d182d0 /app-office
parentdev-python/ifaddr: bump to 0.1.7, add tests and Python 3.9 support (diff)
downloadgentoo-811fff30b782a18f80c85e8d1edf10fcec392445.tar.gz
gentoo-811fff30b782a18f80c85e8d1edf10fcec392445.tar.bz2
gentoo-811fff30b782a18f80c85e8d1edf10fcec392445.zip
app-office/libreoffice: Add useflag custom-cflags
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libreoffice/libreoffice-7.0.3.1.ebuild9
-rw-r--r--app-office/libreoffice/libreoffice-7.0.9999.ebuild9
-rw-r--r--app-office/libreoffice/libreoffice-9999.ebuild11
3 files changed, 25 insertions, 4 deletions
diff --git a/app-office/libreoffice/libreoffice-7.0.3.1.ebuild b/app-office/libreoffice/libreoffice-7.0.3.1.ebuild
index 0ead70200993..a83494ecc5e4 100644
--- a/app-office/libreoffice/libreoffice-7.0.3.1.ebuild
+++ b/app-office/libreoffice/libreoffice-7.0.3.1.ebuild
@@ -405,7 +405,6 @@ src_configure() {
NM=llvm-nm
RANLIB=llvm-ranlib
LDFLAGS+=" -fuse-ld=lld"
- strip-unsupported-flags
else
# Force gcc
einfo "Enforcing the use of gcc due to USE=-clang ..."
@@ -414,8 +413,16 @@ src_configure() {
CXX=${CHOST}-g++
NM=gcc-nm
RANLIB=gcc-ranlib
+ fi
+
+ if use custom-cflags ; then
+ elog "USE=custom-cflags has been selected. You are on your own to make sure that"
+ elog "the build succeeds. Good luck!"
strip-unsupported-flags
+ else
+ strip-flags
fi
+
export CLANG_CC=${CC}
export CLANG_CXX=${CXX}
diff --git a/app-office/libreoffice/libreoffice-7.0.9999.ebuild b/app-office/libreoffice/libreoffice-7.0.9999.ebuild
index c04d5929a505..1423e832b11b 100644
--- a/app-office/libreoffice/libreoffice-7.0.9999.ebuild
+++ b/app-office/libreoffice/libreoffice-7.0.9999.ebuild
@@ -401,7 +401,6 @@ src_configure() {
NM=llvm-nm
RANLIB=llvm-ranlib
LDFLAGS+=" -fuse-ld=lld"
- strip-unsupported-flags
else
# Force gcc
einfo "Enforcing the use of gcc due to USE=-clang ..."
@@ -410,8 +409,16 @@ src_configure() {
CXX=${CHOST}-g++
NM=gcc-nm
RANLIB=gcc-ranlib
+ fi
+
+ if use custom-cflags ; then
+ elog "USE=custom-cflags has been selected. You are on your own to make sure that"
+ elog "the build succeeds. Good luck!"
strip-unsupported-flags
+ else
+ strip-flags
fi
+
export CLANG_CC=${CC}
export CLANG_CXX=${CXX}
diff --git a/app-office/libreoffice/libreoffice-9999.ebuild b/app-office/libreoffice/libreoffice-9999.ebuild
index 816e95d62a10..cc2390bea4c0 100644
--- a/app-office/libreoffice/libreoffice-9999.ebuild
+++ b/app-office/libreoffice/libreoffice-9999.ebuild
@@ -82,7 +82,7 @@ unset ADDONS_SRC
# Extensions that need extra work:
LO_EXTS="nlpsolver scripting-beanshell scripting-javascript wiki-publisher"
-IUSE="accessibility base bluetooth +branding clang coinmp +cups +dbus debug eds firebird
+IUSE="accessibility base bluetooth +branding clang coinmp +cups custom-cflags +dbus debug eds firebird
googledrive gstreamer +gtk kde ldap +mariadb odk pdfimport postgres test vulkan
$(printf 'libreoffice_extensions_%s ' ${LO_EXTS})"
@@ -401,7 +401,6 @@ src_configure() {
NM=llvm-nm
RANLIB=llvm-ranlib
LDFLAGS+=" -fuse-ld=lld"
- strip-unsupported-flags
else
# Force gcc
einfo "Enforcing the use of gcc due to USE=-clang ..."
@@ -410,8 +409,16 @@ src_configure() {
CXX=${CHOST}-g++
NM=gcc-nm
RANLIB=gcc-ranlib
+ fi
+
+ if use custom-cflags ; then
+ elog "USE=custom-cflags has been selected. You are on your own to make sure that"
+ elog "the build succeeds. Good luck!"
strip-unsupported-flags
+ else
+ strip-flags
fi
+
export LO_CLANG_CC=${CC}
export LO_CLANG_CXX=${CXX}