summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2018-02-05 14:03:44 +0700
committerAndrey Grozin <grozin@gentoo.org>2018-02-05 14:03:44 +0700
commit59872b32e9d93504b9fcb5c4f690eb6fa6e6adbc (patch)
treef6dfa3909a1541d76beac06c63d5d51203c6025e /app-office/impressive/impressive-0.12.0.ebuild
parentapp-office/geierlein: Remove old (diff)
downloadgentoo-59872b32e9d93504b9fcb5c4f690eb6fa6e6adbc.tar.gz
gentoo-59872b32e9d93504b9fcb5c4f690eb6fa6e6adbc.tar.bz2
gentoo-59872b32e9d93504b9fcb5c4f690eb6fa6e6adbc.zip
app-office/impressive: bump to 0.12.0
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-office/impressive/impressive-0.12.0.ebuild')
-rw-r--r--app-office/impressive/impressive-0.12.0.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/app-office/impressive/impressive-0.12.0.ebuild b/app-office/impressive/impressive-0.12.0.ebuild
new file mode 100644
index 000000000000..6f865b6ac5e2
--- /dev/null
+++ b/app-office/impressive/impressive-0.12.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-r1
+
+MY_PN="Impressive"
+
+DESCRIPTION="Stylish way of giving presentations with Python"
+HOMEPAGE="http://impressive.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}/${PV%b}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${PYTHON_DEPS}
+ dev-python/pygame[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ x11-apps/xrandr
+ app-text/mupdf
+ || ( media-fonts/dejavu media-fonts/corefonts )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DOCS=(
+ changelog.txt
+ demo.pdf
+)
+HTML_DOCS=(
+ impressive.html
+)
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_install() {
+ default
+ python_foreach_impl python_doscript ${PN}.py
+ doman impressive.1
+}
+
+pkg_postinst() {
+ elog "The experience with ${PN} can be enhanced by folowing packages:"
+ optfeature "starting web or e-mail hyperlinks from PDF documents" x11-misc/xdg-utils
+ optfeature "sound and video playback" media-video/ffmpeg
+ optfeature "sound and video playback" media-video/mplayer
+ optfeature "sound and video playback" media-video/mplayer2
+ optfeature "extraction of PDF page titles" app-text/pdftk
+}