summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-mobilephone/dfu-util
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-mobilephone/dfu-util')
-rw-r--r--app-mobilephone/dfu-util/Manifest1
-rw-r--r--app-mobilephone/dfu-util/dfu-util-0.7.ebuild39
-rw-r--r--app-mobilephone/dfu-util/dfu-util-9999.ebuild38
-rw-r--r--app-mobilephone/dfu-util/metadata.xml5
4 files changed, 83 insertions, 0 deletions
diff --git a/app-mobilephone/dfu-util/Manifest b/app-mobilephone/dfu-util/Manifest
new file mode 100644
index 000000000000..e979d4f68838
--- /dev/null
+++ b/app-mobilephone/dfu-util/Manifest
@@ -0,0 +1 @@
+DIST dfu-util-0.7.tar.gz 125356 SHA256 f52a2a5489fbf9f3204a6ada05e0b47ee322e19d81c712e0c58a332d80ec3eab SHA512 df5227655d2d39e8c0323e87a97e38e86481b12ef91528045e8a5a2009a3fe3b6f09acfed8612756c3895253075dbe958aeaf1c9c50c2266efeb22b88d3842e2 WHIRLPOOL 9c74edd96e8f85dd86e0c8a5862a1277cd74b0821b73823f1ecc86e046fdc5cc6ac5fa45cd67de6a65d73ad935b58d0c4109362c2650ac233e18d6727e0ac944
diff --git a/app-mobilephone/dfu-util/dfu-util-0.7.ebuild b/app-mobilephone/dfu-util/dfu-util-0.7.ebuild
new file mode 100644
index 000000000000..f1c6fbc2c598
--- /dev/null
+++ b/app-mobilephone/dfu-util/dfu-util-0.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.openezx.org/dfu-util.git"
+ inherit autotools git-2
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ SRC_URI="http://dfu-util.gnumonks.org/releases/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="implements the Host (PC) side of the USB DFU (Device Firmware Upgrade) protocol"
+HOMEPAGE="http://wiki.openmoko.org/wiki/Dfu-util"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="virtual/libusb:1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ if [[ ${PV} == "9999" ]] ; then
+ git-2_src_prepare
+ eautoreconf
+ fi
+ sed -i '/^bin_PROGRAMS/s:dfu-util_static[^ ]*::' src/Makefile.in
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ChangeLog README TODO
+}
diff --git a/app-mobilephone/dfu-util/dfu-util-9999.ebuild b/app-mobilephone/dfu-util/dfu-util-9999.ebuild
new file mode 100644
index 000000000000..50df59c681f6
--- /dev/null
+++ b/app-mobilephone/dfu-util/dfu-util-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.openezx.org/dfu-util.git"
+ inherit autotools git-2
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ SRC_URI="http://dfu-util.gnumonks.org/releases/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="implements the Host (PC) side of the USB DFU (Device Firmware Upgrade) protocol"
+HOMEPAGE="http://wiki.openmoko.org/wiki/Dfu-util"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="virtual/libusb:1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ if [[ ${PV} == "9999" ]] ; then
+ eautoreconf
+ fi
+ sed -i '/^bin_PROGRAMS/s:dfu-util_static[^ ]*::' src/Makefile.in
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ChangeLog README TODO
+}
diff --git a/app-mobilephone/dfu-util/metadata.xml b/app-mobilephone/dfu-util/metadata.xml
new file mode 100644
index 000000000000..2347f6c7e44b
--- /dev/null
+++ b/app-mobilephone/dfu-util/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version = '1.0' encoding = 'UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+</pkgmetadata>