summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2023-02-26 22:06:47 +0100
committerLouis Sautier <sbraz@gentoo.org>2023-03-04 14:09:23 +0100
commitd96cea38608ec84bf77bf27b77266af08a9017b7 (patch)
treea0ef97d47cd2310d1c56a16bd81a5210f1a44bf3 /app-misc
parentdev-java/byte-buddy: add 1.14.0 (diff)
downloadgentoo-d96cea38608ec84bf77bf27b77266af08a9017b7.tar.gz
gentoo-d96cea38608ec84bf77bf27b77266af08a9017b7.tar.bz2
gentoo-d96cea38608ec84bf77bf27b77266af08a9017b7.zip
app-misc/rmlint: fix dependencies and startup with USE=gui
This fixes two things: * Some dependencies were missing, I added them by checking all imports from "gi.repository" and calls to "gi.require_version". The list should be exhaustive. Only dev-libs/gobject-introspection itself was skipped as it is implied by the introspection USE flag. * The GUI could start with the wrong Python version because it simply called "python3". By making it call ${EPYTHON} instead, we force it to use the correct version. Closes: https://bugs.gentoo.org/828111 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/rmlint/rmlint-2.10.1-r2.ebuild (renamed from app-misc/rmlint/rmlint-2.10.1-r1.ebuild)10
1 files changed, 9 insertions, 1 deletions
diff --git a/app-misc/rmlint/rmlint-2.10.1-r1.ebuild b/app-misc/rmlint/rmlint-2.10.1-r2.ebuild
index 0bb48648fcc8..4d755cc14da3 100644
--- a/app-misc/rmlint/rmlint-2.10.1-r1.ebuild
+++ b/app-misc/rmlint/rmlint-2.10.1-r2.ebuild
@@ -27,7 +27,12 @@ RDEPEND="
${DEPEND}
gui? (
${PYTHON_DEPS}
- x11-libs/gtksourceview:3.0
+ gnome-base/librsvg:2[introspection]
+ sys-auth/polkit[introspection]
+ x11-libs/gdk-pixbuf[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/gtksourceview:3.0[introspection]
+ x11-libs/pango[introspection]
$(python_gen_cond_dep '
dev-python/colorlog[${PYTHON_USEDEP}]
dev-python/pygobject:3[${PYTHON_USEDEP}]
@@ -76,6 +81,9 @@ PATCHES=(
src_prepare() {
default
+ # Force the GUI to run with the correct PYTHON_SINGLE_TARGET
+ sed -i "/const char \*commands/s/python3/${EPYTHON}/" \
+ lib/cmdline.c || die
if use test && use x86; then
# Skip part of a test until this is fixed:
# https://github.com/sahib/rmlint/issues/522