summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2024-03-29 10:43:06 +0000
committerMarek Szuba <marecki@gentoo.org>2024-03-29 10:43:06 +0000
commit3407c4c5a8cda3b6cc842bac456ae3978adb482c (patch)
tree1d75fe6810043f82738c3f86b0d117a6449ee3f4 /app-misc
parentdev-util/bugbite-cli: mark ~arm64 (diff)
downloadgentoo-3407c4c5a8cda3b6cc842bac456ae3978adb482c.tar.gz
gentoo-3407c4c5a8cda3b6cc842bac456ae3978adb482c.tar.bz2
gentoo-3407c4c5a8cda3b6cc842bac456ae3978adb482c.zip
app-misc/gramps: add 5.2.1
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/gramps/Manifest1
-rw-r--r--app-misc/gramps/files/gramps-5.2.1-test_locale.patch30
-rw-r--r--app-misc/gramps/gramps-5.2.1.ebuild85
3 files changed, 116 insertions, 0 deletions
diff --git a/app-misc/gramps/Manifest b/app-misc/gramps/Manifest
index e03b8f571b65..0fb1ade4a359 100644
--- a/app-misc/gramps/Manifest
+++ b/app-misc/gramps/Manifest
@@ -1 +1,2 @@
DIST gramps-5.1.6.tar.gz 17429153 BLAKE2B fe94d80ff209e1f27ec1cfa533e916514336c1d367435e0a9da4b8309efbc9c047302a67ec24e28237eaead67ff63e76bd1384ac1e3df10e08ae98aca126566b SHA512 419bbfa54ca3bf33e71fd579c84a56eebe4afc78ccd50c23b2d62869684709ccbf373e8da0e65835d9fc21a29d2d144597d6cf8c425e14c91574535d4b1ab64d
+DIST gramps-5.2.1.tar.gz 21059645 BLAKE2B 0fda7a637abe4f7f8019d113cc62b353f4e3628274e614cf8778b4c8303f68951ccb5ca7356faf7bce58ee399da1aa33f70ac482d995c60c9103eed9bae3b490 SHA512 ac7b9bd1bccf1094ccf91d3fec5cf1ed7327911d314c05b544c15aaf7681c0b5acd4088411200e23a70bcd965297107ea5deaf5c200b6b144b24d16e085c613e
diff --git a/app-misc/gramps/files/gramps-5.2.1-test_locale.patch b/app-misc/gramps/files/gramps-5.2.1-test_locale.patch
new file mode 100644
index 000000000000..e1e0b7997075
--- /dev/null
+++ b/app-misc/gramps/files/gramps-5.2.1-test_locale.patch
@@ -0,0 +1,30 @@
+GEDCOM-import tests explicitly set the locale to en_US.UTF8 because they
+assume a US date and time format. That locale is not guaranteed to be
+present and checking that in ebuild is a hassle, therefore use C.UTF8
+instead - it's similar enough.
+
+--- a/data/tests/imp_sample.gramps
++++ b/data/tests/imp_sample.gramps
+@@ -1719,7 +1719,7 @@
+ </style>
+ </note>
+ <note handle="_000000fa000000fa" change="1695230065" id="N0037" type="General">
+- <text>Objects referenced by this note were missing in a file imported on 12/25/1999 12:00:00 AM.</text>
++ <text>Objects referenced by this note were missing in a file imported on 12/25/99 00:00:00.</text>
+ </note>
+ </notes>
+ </database>
+--- a/gramps/plugins/test/imports_test.py
++++ b/gramps/plugins/test/imports_test.py
+@@ -54,10 +54,7 @@
+ # ------------------------------------------------------------------
+
+ # These tests assume a US date and time format.
+-try:
+- locale.setlocale(locale.LC_ALL, "en_US.utf8")
+-except locale.Error: # seems to fail on Windows system for some reason
+- locale.setlocale(locale.LC_ALL, "English_United States")
++locale.setlocale(locale.LC_ALL, "C.utf8")
+
+
+ def mock_time(*args):
diff --git a/app-misc/gramps/gramps-5.2.1.ebuild b/app-misc/gramps/gramps-5.2.1.ebuild
new file mode 100644
index 000000000000..302a27877ada
--- /dev/null
+++ b/app-misc/gramps/gramps-5.2.1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 2001-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="Community genealogy program aiming to be both intuitive and feature-complete"
+HOMEPAGE="https://gramps-project.org/"
+SRC_URI="https://github.com/gramps-project/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="exif geo postscript +rcs +reports spell test"
+
+# Many tests fail unless the deprecated BerkeleyDB back-end is enabled.
+RESTRICT="test"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.12:3[cairo,${PYTHON_USEDEP}]
+ dev-python/pyicu[${PYTHON_USEDEP}]
+ exif? ( >=media-libs/gexiv2-0.5[${PYTHON_USEDEP},introspection] )
+ ')
+ gnome-base/librsvg:2
+ >x11-libs/gtk+-3.14.8:3[introspection]
+ x11-libs/pango[introspection]
+ x11-misc/xdg-utils
+ geo? ( >=sci-geosciences/osm-gps-map-1.1.0 )
+ spell? ( app-text/gtkspell:3[introspection] )
+ rcs? ( dev-vcs/rcs )
+ reports? ( media-gfx/graphviz[postscript?] )
+"
+BDEPEND="test? (
+ $(python_gen_cond_dep '
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ ')
+)"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.2.1-test_locale.patch
+)
+
+DISTUTILS_ARGS=(
+ --no-compress-manpages
+)
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # Install documentation to the proper location. This can't be done
+ # easily with a patch because we substitute in the ${PF} variable,
+ # and that changes with every revision.
+ sed -i -e "s:share/doc/gramps:share/doc/${PF}:g" setup.py || die
+
+ default
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ # setup.py option --resourcepath appears to have problems at the moment
+ echo -n "/usr/share" > "${ED}"$(python_get_sitedir)/${PN}/gen/utils/resource-path || die
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}