summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-09-24 14:22:10 +1000
committerMatt Jolly <kangie@gentoo.org>2024-09-24 16:30:36 +1000
commit1b42829fad40bfe9e72e2eead8a8f5840b5f03f4 (patch)
treea99acc8fa38398c5a1506deed4cafa77f87c2700 /app-misc
parentapp-arch/zchunk: add 1.5.1 (diff)
downloadgentoo-1b42829fad40bfe9e72e2eead8a8f5840b5f03f4.tar.gz
gentoo-1b42829fad40bfe9e72e2eead8a8f5840b5f03f4.tar.bz2
gentoo-1b42829fad40bfe9e72e2eead8a8f5840b5f03f4.zip
app-misc/elasticsearch: add 8.15.1
Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/elasticsearch/Manifest1
-rw-r--r--app-misc/elasticsearch/elasticsearch-8.15.1.ebuild109
2 files changed, 110 insertions, 0 deletions
diff --git a/app-misc/elasticsearch/Manifest b/app-misc/elasticsearch/Manifest
index 0198bda8a776..8d7e0eb780b9 100644
--- a/app-misc/elasticsearch/Manifest
+++ b/app-misc/elasticsearch/Manifest
@@ -1,2 +1,3 @@
DIST elasticsearch-7.17.16-no-jdk-linux-x86_64.tar.gz 168795535 BLAKE2B 642ae6f07db953e7fa783dcd63c6dcebab61e85ea600bede09e9596bf9dee2d71c43e5c28b80bd4c091d792ed3a95d10cc75ffb1074ad4b3cfceb081ed25027f SHA512 3755373f5068a08e4619b4e922bc2d3d97d41791dbf5aa84564574fc84abee9c567b16095cf0e11d48910627e3c183ff1193bf2d5ade59891bea2b3f994aa7df
DIST elasticsearch-8.14.3-linux-x86_64.tar.gz 588481989 BLAKE2B 6c85d0ff9a7920a085adcf594d649bddbac1289a30607500e26c410c22c36ff61c389576c77079bcaf0af4ef035bfbf60b1742e694d499c99f7a93b82129a850 SHA512 5c9df84b225e4a80d6f86d84e4f9afaa23fd51c0f62827d085957447057361db3c3adc485eaec18f6c98615739babf2e5c7c4cc2a7a6351c79f384150c293391
+DIST elasticsearch-8.15.1-linux-x86_64.tar.gz 605974468 BLAKE2B 8fc2476cd2629cf8bcd9c2183763aba1880f76357809f661da9c3df6538bdf7bc21e897356cb4e35084ef1333120539e494893177fffe0aaa1e7ea4cc3f52fcd SHA512 3eced0f59446f60170b7ab3372f58bbda713e2166bb936ef0f74a027e579565b469d3f8888715638e6dfc3e98f88e1b73f7de8a6fc37be236ade4a099f9cc808
diff --git a/app-misc/elasticsearch/elasticsearch-8.15.1.ebuild b/app-misc/elasticsearch/elasticsearch-8.15.1.ebuild
new file mode 100644
index 000000000000..f024f4b1ce68
--- /dev/null
+++ b/app-misc/elasticsearch/elasticsearch-8.15.1.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd tmpfiles
+
+DESCRIPTION="Free and Open, Distributed, RESTful Search Engine"
+HOMEPAGE="https://www.elastic.co/elasticsearch/"
+SRC_URI="https://artifacts.elastic.co/downloads/${PN}/${P}-linux-x86_64.tar.gz"
+
+LICENSE="Apache-2.0 BSD-2 Elastic-2.0 LGPL-3 MIT public-domain"
+SLOT="0/8"
+KEYWORDS="~amd64"
+
+DEPEND="acct-group/elasticsearch
+ acct-user/elasticsearch"
+RDEPEND="acct-group/elasticsearch
+ acct-user/elasticsearch
+ sys-libs/zlib
+ virtual/jre:17"
+
+QA_FLAGS_IGNORED="usr/share/elasticsearch/lib/platform/linux-x64/*.so"
+QA_PREBUILT="
+ usr/share/elasticsearch/lib/platform/linux-x64/*.so
+ usr/share/elasticsearch/modules/x-pack-ml/platform/linux-x86_64/\(bin\|lib\)/.*
+"
+QA_PRESTRIPPED="
+ usr/share/elasticsearch/lib/platform/linux-x64/*.so
+ usr/share/elasticsearch/modules/x-pack-ml/platform/linux-x86_64/\(bin\|lib\)/.*
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-env.patch"
+)
+
+src_prepare() {
+ default
+
+ rm -rf jdk || die
+ sed -i -e "s:logs/:${EPREFIX}/var/log/${PN}/:g" config/jvm.options || die "Unable to set Elasticsearch log location"
+ # elasticsearch-env sets the envvar for the config location if not specified elsewhere;
+ # certain utilities try and source this. Although we patch ES_JAVA_HOME for Gentoo slightly earlier,
+ # it's easier to respect EPREFIX for the config location using sed.
+ sed -i "s:ES_PATH_CONF=\"\$ES_HOME\"/config:ES_PATH_CONF=\"${EPREFIX}/etc/${PN}\":" bin/elasticsearch-env \
+ || die "Unable to set Elasticsearch config directory"
+ rm LICENSE.txt NOTICE.txt || die
+ rmdir logs || die
+}
+
+src_install() {
+ keepdir /etc/${PN}
+ keepdir /etc/${PN}/scripts
+
+ insinto /etc/${PN}
+ doins -r config/.
+ rm -r config || die
+
+ fowners -R root:${PN} /etc/${PN}
+ fperms -R 2750 /etc/${PN}
+
+ insinto /usr/share/${PN}
+ doins -r .
+
+ keepdir /usr/share/${PN}/plugins
+
+ exeinto /usr/share/${PN}/bin
+ doexe "${FILESDIR}"/elasticsearch-systemd-pre-exec
+
+ fperms -R +x /usr/share/${PN}/bin
+ fperms -R +x /usr/share/${PN}/modules/x-pack-ml/platform/linux-x86_64/bin
+
+ keepdir /var/{lib,log}/${PN}
+ fowners ${PN}:${PN} /var/{lib,log}/${PN}
+ fperms 0750 /var/{lib,log}/${PN}
+
+ insinto /etc/sysctl.d
+ newins "${FILESDIR}/${PN}.sysctl.d" ${PN}.conf
+
+ newconfd "${FILESDIR}/${PN}.conf.4" ${PN}
+ newinitd "${FILESDIR}/${PN}.init.8" ${PN}
+
+ systemd_install_serviced "${FILESDIR}/${PN}.service.conf"
+ systemd_newunit "${FILESDIR}"/${PN}.service.4 ${PN}.service
+
+ newtmpfiles "${FILESDIR}"/${PN}.tmpfiles.d ${PN}.conf
+}
+
+pkg_postinst() {
+ # Elasticsearch will choke on our keep file and dodir will not preserve the empty dir
+ local KEEPFILE
+ KEEPFILE=$(find "${EROOT}/usr/share/${PN}/plugins/" -type f -name '.keep*')
+ rm "${KEEPFILE}" || die
+ tmpfiles_process /usr/lib/tmpfiles.d/${PN}.conf
+ if ! systemd_is_booted ; then
+ elog "You may create multiple instances of ${PN} by"
+ elog "symlinking the init script:"
+ elog "ln -sf /etc/init.d/${PN} /etc/init.d/${PN}.instance"
+ elog
+ elog "Please make sure you put elasticsearch.yml, log4j2.properties and scripts"
+ elog "from /etc/${PN} into the configuration directory of the instance:"
+ elog "/etc/${PN}/instance"
+ elog
+ fi
+ ewarn "Please make sure you have proper permissions on /etc/${PN}"
+ ewarn "prior to keystore generation or you may experience startup failures."
+ ewarn "chown root:${PN} /etc/${PN} && chmod 2750 /etc/${PN}"
+ ewarn "chown root:${PN} /etc/${PN}/${PN}.keystore && chmod 0660 /etc/${PN}/${PN}.keystore"
+}