summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/lsx
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/lsx')
-rw-r--r--app-misc/lsx/Manifest1
-rw-r--r--app-misc/lsx/lsx-0.1.ebuild48
-rw-r--r--app-misc/lsx/metadata.xml8
3 files changed, 57 insertions, 0 deletions
diff --git a/app-misc/lsx/Manifest b/app-misc/lsx/Manifest
new file mode 100644
index 000000000000..b9b532b2b000
--- /dev/null
+++ b/app-misc/lsx/Manifest
@@ -0,0 +1 @@
+DIST lsx-0.1.tar.gz 2130 SHA256 b30f8282f2de25bd59edb2dfdc033320539adf56199351a6b5d80e05965add94 SHA512 19f3fa4ecc22817332716d58d287ab7ea4b07bbed1d909b00931b272f1613d8aeb315435495d51a5f918f53e3f0ce68e964813cdbfefce0176924f3c75aa623a WHIRLPOOL 3a17d3a1b5856b69bc1b44fb7a5f145d11579fb52a862189d6f01d62d01a1a28b3a2b79f3648e7e74893da0393bd22781f7c375fa011046ca8ae4ce6548a99b3
diff --git a/app-misc/lsx/lsx-0.1.ebuild b/app-misc/lsx/lsx-0.1.ebuild
new file mode 100644
index 000000000000..73c4a8dd87b5
--- /dev/null
+++ b/app-misc/lsx/lsx-0.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="list executables"
+HOMEPAGE="http://tools.suckless.org/lsx"
+SRC_URI="http://suckless.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "s/.*strip.*//" \
+ Makefile || die "sed failed"
+
+ sed -i \
+ -e "s/CFLAGS = -Os/CFLAGS +=/" \
+ -e "s/LDFLAGS =/LDFLAGS +=/" \
+ config.mk || die "sed failed"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install || die "emake install failed"
+
+ # collision with net-dialup/lrzsz
+ mv "${D}/usr/bin/${PN}" "${D}/usr/bin/${PN}-suckless"
+
+ dodoc README
+}
+
+pkg_postinst() {
+ elog "Run ${PN} with ${PN}-suckless"
+}
diff --git a/app-misc/lsx/metadata.xml b/app-misc/lsx/metadata.xml
new file mode 100644
index 000000000000..c4cfedcdc836
--- /dev/null
+++ b/app-misc/lsx/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+<longdescription>Prints all executable file names of given absolute paths to standard output</longdescription>
+</pkgmetadata>