summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-05-30 20:46:18 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-06-18 00:34:31 +0200
commit7392e452876276ca2efeb4cf20530e55dfcfd751 (patch)
treeeec062f11679df0d8544ddc3106182c52caf3287 /app-misc/dfshow
parentapp-misc/cstream: use HTTPS (diff)
downloadgentoo-7392e452876276ca2efeb4cf20530e55dfcfd751.tar.gz
gentoo-7392e452876276ca2efeb4cf20530e55dfcfd751.tar.bz2
gentoo-7392e452876276ca2efeb4cf20530e55dfcfd751.zip
app-misc/dfshow: add 0.10.3
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://bugs.gentoo.org/827851 Closes: https://bugs.gentoo.org/926235 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-misc/dfshow')
-rw-r--r--app-misc/dfshow/Manifest1
-rw-r--r--app-misc/dfshow/dfshow-0.10.3_beta.ebuild60
-rw-r--r--app-misc/dfshow/files/dfshow-0.10.3_beta-use-PKG_CHECK_MODULES-for-ncurses-libconfig.patch82
3 files changed, 143 insertions, 0 deletions
diff --git a/app-misc/dfshow/Manifest b/app-misc/dfshow/Manifest
index 84f13b6ee364..55168b1422a3 100644
--- a/app-misc/dfshow/Manifest
+++ b/app-misc/dfshow/Manifest
@@ -1 +1,2 @@
+DIST dfshow-0.10.3_beta.tar.gz 317703 BLAKE2B 88694fbb85b2126aa82fd25b8a4d600d6ee952346abd616537dc14eaf1160917d1d85dcacb41028f2d9265da39570e180277c1704dcf968b172bbcc210cfb665 SHA512 08d5e03a77dcc97d517caa2fbef117a362129dfbf5913d52402aabd5c306f0cdb3c8ca006d85046df2661d13047c0ccef7ad079429fcf8dc4a65c9a205eb6907
DIST dfshow-0.9.1_beta.tar.gz 109882 BLAKE2B a8351a4ae1e3d8f0a4166f7642bb32a1ec60723f73d7da9bdc8b496162c4174421e0e369499ace22cfeec64a32b3dbcd9411bdc10c19cc6427d04bc1df298c44 SHA512 c13347075f51c213e804855a1cc432076d8fcd5f278e4945b457fdddc3945e9d743f3dc4f26e4194f6a5b612a4e118081dd3afbb1a4523ae3c962a4fae68494e
diff --git a/app-misc/dfshow/dfshow-0.10.3_beta.ebuild b/app-misc/dfshow/dfshow-0.10.3_beta.ebuild
new file mode 100644
index 000000000000..30ee0b1bae6b
--- /dev/null
+++ b/app-misc/dfshow/dfshow-0.10.3_beta.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools bash-completion-r1 flag-o-matic
+
+MY_PV="${PV//_beta/-beta}"
+DESCRIPTION="Unix-like rewrite of some of the applications from DF-EDIT"
+HOMEPAGE="https://github.com/roberthawdon/dfshow"
+SRC_URI="https://github.com/roberthawdon/dfshow/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ sys-apps/acl
+ dev-libs/libconfig:=
+ sys-libs/ncurses:0=
+"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-use-PKG_CHECK_MODULES-for-ncurses-libconfig.patch
+)
+
+src_prepare() {
+ default
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ # Standard on macOS
+ # No real motivation to push libtool upstream just for this
+ append-ldflags -Wl,-undefined -Wl,dynamic_lookup
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/854726
+ # https://github.com/roberthawdon/dfshow/issues/172
+ filter-lto
+
+ default
+}
+
+src_install() {
+ default
+
+ newbashcomp "${S}/misc/auto-completion/bash/sf-completion.bash" sf
+ newbashcomp "${S}/misc/auto-completion/bash/show-completion.bash" show
+
+ insinto /usr/share/zsh/site-functions
+ doins "${S}/misc/auto-completion/zsh/_sf"
+ doins "${S}/misc/auto-completion/zsh/_show"
+}
diff --git a/app-misc/dfshow/files/dfshow-0.10.3_beta-use-PKG_CHECK_MODULES-for-ncurses-libconfig.patch b/app-misc/dfshow/files/dfshow-0.10.3_beta-use-PKG_CHECK_MODULES-for-ncurses-libconfig.patch
new file mode 100644
index 000000000000..ae45de9e28be
--- /dev/null
+++ b/app-misc/dfshow/files/dfshow-0.10.3_beta-use-PKG_CHECK_MODULES-for-ncurses-libconfig.patch
@@ -0,0 +1,82 @@
+From a8185ad9270db54b9e0c66002e7ceebdc264af19 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Fri, 30 Apr 2021 04:49:26 +0100
+Subject: [PATCH] Use PKG_CHECK_MODULES for ncurses, libconfig
+
+It's not always clear how to link against ncurses
+and the choices before us are:
+1) use a convoluted chain of autoconf checks
+2) use pkg-config (this commit)
+3) guess and hardcode the most popular values
+
+This is an iteration of a previous change [0] by a
+Gentoo contributor which landed upstream.
+
+The previous change ended up doing 3) which is fine
+but doesn't always work in strange situations. Gentoo
+_usually_ builds 'split tinfo' on Linux but this isn't
+guaranteed.
+
+This change now uses PKG_CHECK_MODULES which uses
+pkg-config behind the scenes to query ncurses
+for the correct way to build & link against it.
+
+(We do the same thing for libconfig too.)
+
+[0] https://github.com/roberthawdon/dfshow/pull/115
+---
+ Makefile.am | 13 ++++---------
+ configure.ac | 5 +++--
+ 2 files changed, 7 insertions(+), 11 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 048ded5..6dcaa1f 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -7,21 +7,16 @@
+
+ AM_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\"
+ AM_CFLAGS = -DSYSCONFIG=\"$(dfshowconfdir)\" -DDATADIR=\"$(dfshowdatadir)\" -D_XOPEN_SOURCE_EXTENDED -fno-common
++AM_CFLAGS += $(ncurses_CFLAGS) $(libconfig_CFLAGS)
+
+-LDADD = -lm -lconfig $(LIBINTL)
+-
+-if DARWIN
+-LDADD += -lncurses
+-else
+-LDADD += -lncursesw
+-endif
++LDADD = -lm $(ncurses_LIBS) $(libconfig_LIBS)
+
+ if LINUX
+-LDADD += -lacl -ltinfo
++LDADD += -lacl
+ endif
+
+ if HURD
+-LDADD += -lacl -ltinfo
++LDADD += -lacl
+ endif
+
+ if SELINUX
+diff --git a/configure.ac b/configure.ac
+index f185b69..8acf1ab 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -34,10 +34,11 @@
+
+ AC_CHECK_MEMBERS([struct stat.st_author])
+ AC_CHECK_HEADERS([stdio.h limits.h signal.h ctype.h wctype.h getopt.h sys/types.h sys/stat.h dirent.h fcntl.h pwd.h string.h stdlib.h unistd.h time.h sys/statvfs.h libgen.h errno.h wchar.h hurd.h math.h sys/sysmacros.h regex.h utime.h sys/xattr.h acl/libacl.h stdint.h])
+-AC_CHECK_HEADERS(ncurses.h, , AC_MSG_ERROR(ncurses header (ncurses.h) not found. You may need to install an ncurses development package.))
+-AC_CHECK_HEADERS(libconfig.h, , AC_MSG_ERROR(libconfig header (libconfig.h) not found. You may need to install a libconfig development package.))
+ AC_CHECK_HEADERS(sys/acl.h, , AC_MSG_ERROR(libacl header (sys/acl.h) not found. You may need to install a libacl development package.))
+
++PKG_CHECK_MODULES([ncurses], [ncursesw ncurses])
++PKG_CHECK_MODULES([libconfig], [libconfig])
++
+ AC_CHECK_PROG(VIM_CHECK,vim,yes)
+ AS_IF([test "x$VIM_CHECK" = "xyes"], [
+ AC_DEFINE(HAVE_VIM, 1, [True for systems with Vim])
+--
+2.31.1
+