summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYongxiang Liang <tanekliang@gmail.com>2024-10-10 01:42:37 +0800
committerYixun Lan <dlan@gentoo.org>2024-10-11 08:06:48 +0800
commitfc9f5c2782c21282f52d3ffa04142addeb86430c (patch)
treee8ee6f81c557d4d15edd68e60cae63d14aee6d0e /app-i18n
parentapp-i18n/fcitx-chewing: add 5.1.6 (diff)
downloadgentoo-fc9f5c2782c21282f52d3ffa04142addeb86430c.tar.gz
gentoo-fc9f5c2782c21282f52d3ffa04142addeb86430c.tar.bz2
gentoo-fc9f5c2782c21282f52d3ffa04142addeb86430c.zip
app-i18n/fcitx-configtool: add 5.1.7
Closes: https://github.com/gentoo/gentoo/pull/38931 Signed-off-by: Yongxiang Liang <tanekliang@gmail.com> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/fcitx-configtool/Manifest1
-rw-r--r--app-i18n/fcitx-configtool/fcitx-configtool-5.1.7.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/app-i18n/fcitx-configtool/Manifest b/app-i18n/fcitx-configtool/Manifest
index 163bf9731340..bb214e00b058 100644
--- a/app-i18n/fcitx-configtool/Manifest
+++ b/app-i18n/fcitx-configtool/Manifest
@@ -1,2 +1,3 @@
DIST fcitx-configtool-0.4.10.tar.xz 50440 BLAKE2B f2f2241d3ea139f6f3de9b8c6ffcc71c789dfa291efe4c551596eebc8a04f13f9fe698cc25d8349a174399044d15ddca2aeab952ac2bc7f0f4e9e47d453329ca SHA512 1c1267e9de694bbd5f258b5bba1e7514c4f8556cdc82a1cce5eafd8a4ec571955285dade0acd02f128eca01f867a30c5c6264ee7e91d32a333eba6e4d275fe8f
DIST fcitx-configtool-5.1.6.tar.zst 149667 BLAKE2B 2536258eb92c04623b2f1aa77c99cf91919cd4f1d23c0bdf7f87ab8528b2b1305ed6771ee93b25d67ace24dfc5b14413d96d13f5487fe58efe93b36c452ff67a SHA512 1cedd3b5eae3c069774da3456799e26ab36cf8b8a6515cf008fe6e9822bfa7d0992ed69c4ef9671484082778cd5560ee6255446be3ebbf00f305143b20531aeb
+DIST fcitx-configtool-5.1.7.tar.zst 149763 BLAKE2B 74fcdf6edccc239c768a308cf590369439dd398bf1a6667f5ca1277991bf504fbcd4c00af51c3e21747a005bc9226315d2e5a441ab183b0f060bfa964d3c520f SHA512 5e6c98478d85ea912d30d213acb232c5abd31b30626d41b7697719bd18c5c5947a3f401cf2d75153fbe3720328f1d8eb76b1a807f02dedd5fcaf44a2bc2b0126
diff --git a/app-i18n/fcitx-configtool/fcitx-configtool-5.1.7.ebuild b/app-i18n/fcitx-configtool/fcitx-configtool-5.1.7.ebuild
new file mode 100644
index 000000000000..2e4cdd69bfab
--- /dev/null
+++ b/app-i18n/fcitx-configtool/fcitx-configtool-5.1.7.ebuild
@@ -0,0 +1,66 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="fcitx5-configtool"
+
+inherit cmake unpacker
+
+DESCRIPTION="Configuration module for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx5-configtool"
+SRC_URI="https://download.fcitx-im.org/fcitx5/${MY_PN}/${MY_PN}-${PV}.tar.zst -> ${P}.tar.zst"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="GPL-2+"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE="kcm +config-qt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=app-i18n/fcitx-5.1.6:5
+ >=app-i18n/fcitx-qt-5.1.4:5[qt6(+),-onlyplugin]
+ app-text/iso-codes
+ dev-qt/qtbase:6[concurrent,dbus,gui,widgets]
+ dev-qt/qtsvg:6
+ kde-frameworks/kwidgetsaddons:6
+ sys-devel/gettext
+ virtual/libintl
+ x11-libs/libX11
+ x11-libs/libxkbfile
+ x11-misc/xkeyboard-config
+ config-qt? ( kde-frameworks/kitemviews:6 )
+ kcm? (
+ dev-qt/qtdeclarative:6
+ kde-frameworks/kcoreaddons:6
+ kde-frameworks/kdeclarative:6
+ kde-frameworks/ki18n:6
+ kde-frameworks/kiconthemes:6
+ kde-frameworks/kirigami:6
+ kde-frameworks/kpackage:6
+ kde-frameworks/ksvg:6
+ kde-frameworks/kcmutils:6
+ kde-plasma/libplasma:6
+ x11-libs/libxkbcommon
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ $(unpacker_src_uri_depends)
+ kde-frameworks/extra-cmake-modules:0
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=yes
+ -DENABLE_KCM=$(usex kcm)
+ -DENABLE_CONFIG_QT=$(usex config-qt)
+ -DENABLE_TEST=$(usex test)
+ -DUSE_QT6=ON
+ )
+
+ cmake_src_configure
+}