summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2021-10-12 22:22:50 +0900
committerAkinori Hattori <hattya@gentoo.org>2021-10-12 22:22:50 +0900
commit67c32b3dffa245e4d44c95e13e8f9db50994567b (patch)
treea21a505b33d3b133a5dff561a470bf7bc915ed49 /app-i18n/tomoe-gtk
parentapp-i18n/tomoe: update to EAPI 7 (diff)
downloadgentoo-67c32b3dffa245e4d44c95e13e8f9db50994567b.tar.gz
gentoo-67c32b3dffa245e4d44c95e13e8f9db50994567b.tar.bz2
gentoo-67c32b3dffa245e4d44c95e13e8f9db50994567b.zip
app-i18n/tomoe-gtk: fix link with gold
Closes: https://bugs.gentoo.org/746485 Closes: https://bugs.gentoo.org/734206 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n/tomoe-gtk')
-rw-r--r--app-i18n/tomoe-gtk/files/tomoe-gtk-math.patch11
-rw-r--r--app-i18n/tomoe-gtk/tomoe-gtk-0.6.0-r7.ebuild (renamed from app-i18n/tomoe-gtk/tomoe-gtk-0.6.0-r6.ebuild)13
2 files changed, 23 insertions, 1 deletions
diff --git a/app-i18n/tomoe-gtk/files/tomoe-gtk-math.patch b/app-i18n/tomoe-gtk/files/tomoe-gtk-math.patch
new file mode 100644
index 000000000000..05fba04a194d
--- /dev/null
+++ b/app-i18n/tomoe-gtk/files/tomoe-gtk-math.patch
@@ -0,0 +1,11 @@
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -4,7 +4,7 @@
+ -DTOMOEGTKDATADIR=\""$(datadir)"/$(PACKAGE)\"
+
+ INCLUDES = $(GTK2_CFLAGS) $(TOMOE_CFLAGS) $(GUCHARMAP_CFLAGS)
+-LIBS = $(GTK2_LIBS) $(TOMOE_LIBS) $(GUCHARMAP_LIBS)
++LIBS = $(GTK2_LIBS) $(TOMOE_LIBS) $(GUCHARMAP_LIBS) -lm
+
+ lib_LTLIBRARIES = libtomoe-gtk.la
+ libtomoe_gtk_la_SOURCES = \
diff --git a/app-i18n/tomoe-gtk/tomoe-gtk-0.6.0-r6.ebuild b/app-i18n/tomoe-gtk/tomoe-gtk-0.6.0-r7.ebuild
index 24a7bebf2397..e18c92f169e5 100644
--- a/app-i18n/tomoe-gtk/tomoe-gtk-0.6.0-r6.ebuild
+++ b/app-i18n/tomoe-gtk/tomoe-gtk-0.6.0-r7.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
+inherit autotools
+
DESCRIPTION="Tomoe GTK+ interface widget library"
HOMEPAGE="http://tomoe.osdn.jp/"
SRC_URI="mirror://sourceforge/tomoe/${P}.tar.gz"
@@ -20,6 +22,15 @@ BDEPEND="dev-util/glib-utils
sys-devel/gettext
virtual/pkgconfig"
+PATCHES=( "${FILESDIR}"/${PN}-math.patch )
+
+AT_M4DIR="macros"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
econf \
--disable-static \