summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-i18n/ibus-anthy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-i18n/ibus-anthy')
-rw-r--r--app-i18n/ibus-anthy/Manifest3
-rw-r--r--app-i18n/ibus-anthy/ibus-anthy-1.2.7-r1.ebuild62
-rw-r--r--app-i18n/ibus-anthy/ibus-anthy-1.5.4.ebuild66
-rw-r--r--app-i18n/ibus-anthy/metadata.xml13
4 files changed, 144 insertions, 0 deletions
diff --git a/app-i18n/ibus-anthy/Manifest b/app-i18n/ibus-anthy/Manifest
new file mode 100644
index 000000000000..dc4d549595c7
--- /dev/null
+++ b/app-i18n/ibus-anthy/Manifest
@@ -0,0 +1,3 @@
+DIST anthy.i 3170 SHA256 3615639f5cd9bf2adcbc2bac8d3ae968646df1d9d2ba987d80442d5ad99ecdf9 SHA512 400d67c2f0ffbdb3eab241646922d549ec4a42ae5b33714a91b864f4b5dfdf0d9a0d28cb6dcdffa55eb9633651ceae034bb547d7a5c41d9b8d352e955773e069 WHIRLPOOL 9be409df613530658c68bc7491e1dd258f5f1ef1d09895a3557a9e63c3ced5083c1ecd9e274536c9afbc98031c353c05c73304bb4354aaf8e21a1c15de39b8b6
+DIST ibus-anthy-1.2.7.tar.gz 523139 SHA256 33c42c1612423f84fddd8c38f8b2439b8af5f0b5fc7725ae195a01b8999d85e9 SHA512 ee45759bb8303967d09d0f92ee0a97fa63611de936c61073078d795b9ba8858cc882e539611bb5ea68848d471e6d2b0e4d8f51df5335aad7942f15e63c4d159d WHIRLPOOL a27945667347d0fb121d028b23b68219df6417369d32d47a43665c828e8935cd74e04b861e0a4e04a117c08665771c22750eab2869fffd21f23b1e21f633b358
+DIST ibus-anthy-1.5.4.tar.gz 592595 SHA256 4c0a8b88a2c547e72173a7d682d82797f6c65fe712abe5f3b89495d4eec7b031 SHA512 8478e9ea14472d0153cc7a35feae4edea791476dc98cfc266b598f915376d267bd5db48ea0a676209d7a6fa680628116a30fec59afaf696477cfaa14082aad8d WHIRLPOOL f4aec300dc5cff62f81a3ae64ac2d46768e3fbaa579e14abac8bd87e0801155e8258f6f3d66d7015122e929cd2e0f48183aeb37245b3046afa3d80b8ce42d58c
diff --git a/app-i18n/ibus-anthy/ibus-anthy-1.2.7-r1.ebuild b/app-i18n/ibus-anthy/ibus-anthy-1.2.7-r1.ebuild
new file mode 100644
index 000000000000..276c57d0c50d
--- /dev/null
+++ b/app-i18n/ibus-anthy/ibus-anthy-1.2.7-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+PYTHON_DEPEND="2:2.5"
+inherit eutils python
+
+DESCRIPTION="Japanese input method Anthy IMEngine for IBus Framework"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="nls"
+
+RDEPEND=">=app-i18n/ibus-1.2.0.20100111
+ !>=app-i18n/ibus-1.4.99
+ app-i18n/anthy
+ >=dev-python/pygtk-2.15.2
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-lang/swig
+ dev-util/intltool
+ virtual/pkgconfig
+ nls? ( >=sys-devel/gettext-0.16.1 )"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ >py-compile #397497
+}
+
+src_configure() {
+ PYTHON="$(PYTHON -a)" econf $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README || die
+
+ find "${ED}" -name '*.la' -type f -delete || die
+}
+
+pkg_postinst() {
+ elog
+ elog "app-dicts/kasumi is not required but probably useful for you."
+ elog
+ elog "# emerge app-dicts/kasumi"
+ elog
+
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}
diff --git a/app-i18n/ibus-anthy/ibus-anthy-1.5.4.ebuild b/app-i18n/ibus-anthy/ibus-anthy-1.5.4.ebuild
new file mode 100644
index 000000000000..8ff72f13bca4
--- /dev/null
+++ b/app-i18n/ibus-anthy/ibus-anthy-1.5.4.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit eutils python-single-r1 autotools gnome2-utils
+
+DESCRIPTION="Japanese input method Anthy IMEngine for IBus Framework"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz
+ https://raw.github.com/ibus/ibus-anthy/${PV}/engine/anthy.i"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="deprecated nls"
+
+RDEPEND="${PYTHON_DEPS}
+ >=app-i18n/ibus-1.5.0
+ app-i18n/anthy
+ deprecated? ( >=dev-python/pygtk-2.15.2 )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-libs/gobject-introspection
+ dev-util/intltool
+ virtual/pkgconfig
+ deprecated? ( dev-lang/swig )
+ nls? ( >=sys-devel/gettext-0.16.1 )"
+
+src_prepare() {
+ >py-compile #397497
+ cp "${DISTDIR}"/anthy.i "${S}"/engine # deal with packaging bug
+}
+
+src_configure() {
+ econf --enable-private-png \
+ $(use_enable deprecated pygtk2-anthy) \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc AUTHORS ChangeLog NEWS README
+
+ find "${ED}" -name '*.la' -type f -delete || die
+
+ python_optimize
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ elog
+ elog "app-dicts/kasumi is not required but probably useful for you."
+ elog
+ elog "# emerge app-dicts/kasumi"
+ elog
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/app-i18n/ibus-anthy/metadata.xml b/app-i18n/ibus-anthy/metadata.xml
new file mode 100644
index 000000000000..96a29926bf06
--- /dev/null
+++ b/app-i18n/ibus-anthy/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cjk</herd>
+ <longdescription lang="en">The Anthy engine for IBus platform. It provides Japanese input method from
+libanthy.</longdescription>
+ <upstream>
+ <remote-id type="google-code">ibus</remote-id>
+ </upstream>
+ <use>
+ <flag name="deprecated">Install deprecated pygtk2 library</flag>
+ </use>
+</pkgmetadata>