summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-eselect/eselect-opencascade
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-eselect/eselect-opencascade')
-rw-r--r--app-eselect/eselect-opencascade/eselect-opencascade-0.ebuild29
-rw-r--r--app-eselect/eselect-opencascade/files/eselect-opencascade-0.eselect104
-rw-r--r--app-eselect/eselect-opencascade/metadata.xml9
3 files changed, 142 insertions, 0 deletions
diff --git a/app-eselect/eselect-opencascade/eselect-opencascade-0.ebuild b/app-eselect/eselect-opencascade/eselect-opencascade-0.ebuild
new file mode 100644
index 000000000000..e39891fed56a
--- /dev/null
+++ b/app-eselect/eselect-opencascade/eselect-opencascade-0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="Manages opencascade env file"
+HOMEPAGE="http://www.gentoo.org/proj/en/eselect/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}"
+
+src_install() {
+ dodir /etc/env.d/opencascade
+ insinto /usr/share/eselect/modules
+ newins "${FILESDIR}"/${P}.eselect opencascade.eselect
+}
+
+pkg_postrm() {
+ rm -v "${EROOT}"etc/env.d/51opencascade
+}
diff --git a/app-eselect/eselect-opencascade/files/eselect-opencascade-0.eselect b/app-eselect/eselect-opencascade/files/eselect-opencascade-0.eselect
new file mode 100644
index 000000000000..da97cb4a8c33
--- /dev/null
+++ b/app-eselect/eselect-opencascade/files/eselect-opencascade-0.eselect
@@ -0,0 +1,104 @@
+# -*-eselect-*- vim: ft=eselect
+# Copyright (c) 2006-2013 Gentoo Foundation
+#
+# This file is part of the 'eselect' tools framework.
+#
+# eselect is free software: you can redistribute it and/or modify it under the
+# terms of the GNU General Public License as published by the Free Software
+# Foundation, either version 2 of the License, or (at your option) any later
+# version.
+#
+# eselect is distributed in the hope that it will be useful, but WITHOUT ANY
+# WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR
+# A PARTICULAR PURPOSE. See the GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along with
+# eselect. If not, see <http://www.gnu.org/licenses/>.
+
+MODULE=opencascade
+TARGET=${EROOT}/etc/env.d/51${MODULE}
+CONFDIR=${EROOT}/etc/env.d/${MODULE}
+
+inherit tests path-manipulation
+
+find_implems() {
+ local -a implems
+ for file in "${CONFDIR}"/* ; do
+ [[ -f ${file} ]] || continue
+ implems=(${implems[@]} "${file##*/}")
+ done
+ echo ${implems[@]}
+}
+
+is_active() {
+ local f
+ [[ $# -eq 1 ]] || die "Need exactly 1 arguments!"
+ [[ -L ${TARGET} ]] || return 1
+ f=$(canonicalise ${TARGET})
+ [[ -e ${f} ]] || return 1
+ [[ ${f##*/} == ${1} ]]
+}
+
+# switch_implem $implem
+# switches $iface combination to $implem
+switch_implem() {
+ [[ $# -eq 1 ]] || die "Need exactly 1 arguments!"
+ $(is_active ${1}) && return
+ [[ -L ${TARGET} ]] && rm -f ${TARGET}
+ ln -s ${MODULE}/${1} ${TARGET}
+ env-update
+ echo "If you intend to use the selected opencascade in"
+ echo "an already running shell, please remember to do:"
+ echo
+ echo ". /etc/profile"
+}
+
+do_list() {
+ local implem i
+ write_list_start "Installed $MODULE"
+ for implem in $(find_implems) ; do
+ (( i++ ))
+ is_active ${implem##*/} \
+ && implem=$(highlight_marker "${implem}")
+ write_numbered_list_entry $i "${implem}"
+ done
+}
+
+describe_set() {
+ echo "Activate one of the installed $MODULE implementations"
+}
+
+describe_set_parameters() {
+ echo "<implementation>"
+}
+
+describe_set_options() {
+ echo "implementation : implementation name or number (from 'list' action)"
+}
+
+do_set() {
+ [[ $# -ne 1 ]] && die -q "Please specify exactly 1 implementation!"
+ local -a implems
+
+ implems=( $(find_implems) )
+
+ if is_number ${1} ; then
+ new_implem=${implems[$(( ${1} - 1 ))]}
+ else
+ new_implem=${1}
+ fi
+ echo $new_implem
+ switch_implem ${new_implem}
+}
+
+describe_show() {
+ echo "Print the currently active $MODULE implementation"
+}
+
+do_show() {
+ local f n
+ [[ -L ${TARGET} ]] || return 1
+ f=$(canonicalise ${TARGET})
+ [[ -f ${f} ]] || return 1
+ echo ${f##*/}
+}
diff --git a/app-eselect/eselect-opencascade/metadata.xml b/app-eselect/eselect-opencascade/metadata.xml
new file mode 100644
index 000000000000..59acc2cc580e
--- /dev/null
+++ b/app-eselect/eselect-opencascade/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>xmw@gentoo.org</email>
+<name>Michael Weber</name>
+</maintainer>
+</pkgmetadata>
+