summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2023-03-21 14:59:18 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2023-03-21 14:59:38 -0500
commitfd1f5ea54ad79c7c5c97c7743936aff1896e2d0d (patch)
treec13816aa61275bda20912415b77fbade3d0aee88 /app-emulation
parentdev-libs/libgit2: Stabilize 1.5.2 ppc64, #902553 (diff)
downloadgentoo-fd1f5ea54ad79c7c5c97c7743936aff1896e2d0d.tar.gz
gentoo-fd1f5ea54ad79c7c5c97c7743936aff1896e2d0d.tar.bz2
gentoo-fd1f5ea54ad79c7c5c97c7743936aff1896e2d0d.zip
app-emulation/diskimage-builder: add 3.27.0
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/diskimage-builder/Manifest1
-rw-r--r--app-emulation/diskimage-builder/diskimage-builder-3.27.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/app-emulation/diskimage-builder/Manifest b/app-emulation/diskimage-builder/Manifest
index 98151b81f75a..7ee933cf154f 100644
--- a/app-emulation/diskimage-builder/Manifest
+++ b/app-emulation/diskimage-builder/Manifest
@@ -1 +1,2 @@
DIST diskimage-builder-3.26.0.tar.gz 515778 BLAKE2B ac57ddb043f08052c337093e74255e7a4a01d6469e26387dd3c968dabb840db2323c8bb6cb4d4758c62c4b6e659873d2c6228312d6798a4101a3792ce760d067 SHA512 06b949f7561e2d60397b27f905ebd997356537091b39a9a2ec26c14da9d7ebcf44f79c97895cfd3b4dde576407840b6f407b9009fbea3def40bcc218589a034f
+DIST diskimage-builder-3.27.0.tar.gz 515925 BLAKE2B 5a064098542bf5a9936868622e8cb90f975b8e23df5ba868689e2f27b4168de40aa12678c643674f127076268f8103fc02f126486efceb5456a5b21ec14e7304 SHA512 25966991ad81eb500a5573b15fc37c0ec1ea55b0f8b9f418a14e30652adaa6e8cb817fb017f4af83343a66300a5d10739b5e99729e947ef27aee45965a3a147f
diff --git a/app-emulation/diskimage-builder/diskimage-builder-3.27.0.ebuild b/app-emulation/diskimage-builder/diskimage-builder-3.27.0.ebuild
new file mode 100644
index 000000000000..ba17dcfdbb9d
--- /dev/null
+++ b/app-emulation/diskimage-builder/diskimage-builder-3.27.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9,10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYPI_NO_NORMALIZE=1
+inherit distutils-r1
+
+DESCRIPTION="Golden Disk Image builder"
+HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://opendev.org/openstack/diskimage-builder.git"
+else
+ inherit pypi
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"
+RDEPEND="${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/networkx-1.10[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ app-emulation/qemu
+ sys-block/parted
+ sys-fs/multipath-tools
+ sys-fs/dosfstools
+ sys-apps/gptfdisk
+ !dev-python/dib-utils[${PYTHON_USEDEP}]"