summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-10-14 22:22:12 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-10-14 22:59:16 -0400
commit7fd63cb7951b2a4a47ff6eceed77eba2ef4779da (patch)
tree20936366eac93937d99fa421e6681b4766ffa7b2 /app-emulation
parentmedia-sound/xmms2: drop IUSE=mms (diff)
downloadgentoo-7fd63cb7951b2a4a47ff6eceed77eba2ef4779da.tar.gz
gentoo-7fd63cb7951b2a4a47ff6eceed77eba2ef4779da.tar.bz2
gentoo-7fd63cb7951b2a4a47ff6eceed77eba2ef4779da.zip
app-emulation/ruffle: skip flaky test
May need more looking into, but is not considered harmful at the moment. Closes: https://bugs.gentoo.org/915726 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/ruffle/ruffle-0_p20230919.ebuild11
-rw-r--r--app-emulation/ruffle/ruffle-9999.ebuild11
2 files changed, 22 insertions, 0 deletions
diff --git a/app-emulation/ruffle/ruffle-0_p20230919.ebuild b/app-emulation/ruffle/ruffle-0_p20230919.ebuild
index ae303b001a1d..ac51947b5041 100644
--- a/app-emulation/ruffle/ruffle-0_p20230919.ebuild
+++ b/app-emulation/ruffle/ruffle-0_p20230919.ebuild
@@ -613,9 +613,20 @@ src_configure() {
exporter
$(usev test tests)
)
+
cargo_src_configure ${workspaces[*]/#/--package=}
}
+src_test() {
+ local skip=(
+ # may need more investigation, strangely "pass" (xfail) when
+ # RUSTFLAGS is unset, skip for now (bug #915726)
+ --skip from_avmplus/as3/Types/Int/wraparound
+ )
+
+ cargo_src_test -- "${skip[@]}"
+}
+
src_install() {
dodoc README.md
diff --git a/app-emulation/ruffle/ruffle-9999.ebuild b/app-emulation/ruffle/ruffle-9999.ebuild
index fbc440002e65..a54f26933afa 100644
--- a/app-emulation/ruffle/ruffle-9999.ebuild
+++ b/app-emulation/ruffle/ruffle-9999.ebuild
@@ -78,9 +78,20 @@ src_configure() {
exporter
$(usev test tests)
)
+
cargo_src_configure ${workspaces[*]/#/--package=}
}
+src_test() {
+ local skip=(
+ # may need more investigation, strangely "pass" (xfail) when
+ # RUSTFLAGS is unset, skip for now (bug #915726)
+ --skip from_avmplus/as3/Types/Int/wraparound
+ )
+
+ cargo_src_test -- "${skip[@]}"
+}
+
src_install() {
dodoc README.md