summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-03-16 17:30:57 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-03-16 17:48:41 -0400
commit29e4a14ba29f05f5a591c7443732bffab5edc2b5 (patch)
tree5ff91f8443047968c94c888aa4280d6e2fba1968 /app-emulation
parentapp-emulation/wine-vanilla: add IUSE=wayland in live (diff)
downloadgentoo-29e4a14ba29f05f5a591c7443732bffab5edc2b5.tar.gz
gentoo-29e4a14ba29f05f5a591c7443732bffab5edc2b5.tar.bz2
gentoo-29e4a14ba29f05f5a591c7443732bffab5edc2b5.zip
app-emulation/wine-staging: add IUSE=wayland in live
Not that should expect this to be useful yet, it's early work in progress. But the option exists so let's add it for anyone interested. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine-staging/wine-staging-9999.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/app-emulation/wine-staging/wine-staging-9999.ebuild b/app-emulation/wine-staging/wine-staging-9999.ebuild
index 48fe559d673c..5f90e2ce8870 100644
--- a/app-emulation/wine-staging/wine-staging-9999.ebuild
+++ b/app-emulation/wine-staging/wine-staging-9999.ebuild
@@ -34,7 +34,8 @@ IUSE="
llvm-libunwind debug custom-cflags +fontconfig +gecko gphoto2
+gstreamer kerberos +mingw +mono netapi nls opencl +opengl osmesa
pcap perl pulseaudio samba scanner +sdl selinux smartcard +ssl
- +truetype udev udisks +unwind usb v4l +vulkan +xcomposite xinerama"
+ +truetype udev udisks +unwind usb v4l +vulkan wayland +xcomposite
+ xinerama"
REQUIRED_USE="
X? ( truetype )
crossdev-mingw? ( mingw )" # bug #551124 for truetype
@@ -93,7 +94,8 @@ WINE_COMMON_DEPEND="
llvm-libunwind? ( sys-libs/llvm-libunwind[${MULTILIB_USEDEP}] )
!llvm-libunwind? ( sys-libs/libunwind:=[${MULTILIB_USEDEP}] )
)
- usb? ( dev-libs/libusb:1[${MULTILIB_USEDEP}] )"
+ usb? ( dev-libs/libusb:1[${MULTILIB_USEDEP}] )
+ wayland? ( dev-libs/wayland[${MULTILIB_USEDEP}] )"
RDEPEND="
${WINE_COMMON_DEPEND}
app-emulation/wine-desktop-common
@@ -250,6 +252,7 @@ src_configure() {
$(use_with usb)
$(use_with v4l v4l2)
$(use_with vulkan)
+ $(use_with wayland)
$(use_with xcomposite)
$(use_with xinerama)
)