summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2021-07-06 13:34:50 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2021-07-06 13:37:12 +0200
commit0213828ca60596e7f7d2c0c83e4ea2812b772a0d (patch)
tree196aeb058e69af0fe9f6270b0ed027ab556bb57c /app-emulation/free42/free42-3.0.5.ebuild
parentapp-emulation/free42: drop old (diff)
downloadgentoo-0213828ca60596e7f7d2c0c83e4ea2812b772a0d.tar.gz
gentoo-0213828ca60596e7f7d2c0c83e4ea2812b772a0d.tar.bz2
gentoo-0213828ca60596e7f7d2c0c83e4ea2812b772a0d.zip
app-emulation/free42: 3.0.5 bump
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'app-emulation/free42/free42-3.0.5.ebuild')
-rw-r--r--app-emulation/free42/free42-3.0.5.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-emulation/free42/free42-3.0.5.ebuild b/app-emulation/free42/free42-3.0.5.ebuild
new file mode 100644
index 000000000000..d25a89b2d1c4
--- /dev/null
+++ b/app-emulation/free42/free42-3.0.5.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_PV="${PN}-nologo-${PV}"
+
+DESCRIPTION="An HP-42S Calculator Simulator"
+HOMEPAGE="https://thomasokken.com/free42/"
+SRC_URI="https://thomasokken.com/free42/upstream/${MY_PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+alsa"
+
+DEPEND="dev-libs/atk
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ alsa? ( media-libs/alsa-lib )"
+
+RDEPEND="${DEPEND}"
+
+DOCS=( CREDITS HISTORY README )
+S="${WORKDIR}/${MY_PV}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.5.16-fix-makefile.patch"
+ "${FILESDIR}/${PN}-2.5.3-fix-build-intel-lib.patch"
+)
+
+src_prepare() {
+ default
+}
+
+src_compile() {
+ local myconf
+ use alsa && myconf="AUDIO_ALSA=yes"
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" ${myconf} -C gtk
+ emake -C gtk clean
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" BCD_MATH=1 ${myconf} -C gtk
+}
+
+src_install() {
+ default
+ dobin gtk/free42bin gtk/free42dec
+}