summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-11-05 21:48:28 +0100
committerManuel Rüger <mrueg@gentoo.org>2017-11-05 21:48:52 +0100
commit0c81232c6ee2d169c5cd9aa033d028f1118075fa (patch)
treebd3649506cd36ddb1cd287a6dbbddae8e94cfe2b /app-emulation/docker-compose
parentnet-nds/openldap: fix modules libtool files prune (diff)
downloadgentoo-0c81232c6ee2d169c5cd9aa033d028f1118075fa.tar.gz
gentoo-0c81232c6ee2d169c5cd9aa033d028f1118075fa.tar.bz2
gentoo-0c81232c6ee2d169c5cd9aa033d028f1118075fa.zip
app-emulation/docker-compose: Version bump to 1.17.0
Package-Manager: Portage-2.3.12, Repoman-2.3.4
Diffstat (limited to 'app-emulation/docker-compose')
-rw-r--r--app-emulation/docker-compose/Manifest1
-rw-r--r--app-emulation/docker-compose/docker-compose-1.17.0.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/app-emulation/docker-compose/Manifest b/app-emulation/docker-compose/Manifest
index 8b5719c7fece..e167d98dbe38 100644
--- a/app-emulation/docker-compose/Manifest
+++ b/app-emulation/docker-compose/Manifest
@@ -1,2 +1,3 @@
DIST docker-compose-1.15.0.tar.gz 210455 SHA256 af569f676c7a04a32d3fc4a72c739cb52d8b6305040295178c5388394b45e579 SHA512 98de68db089754eb73a6f65971fca393703680241bce02e13fdbc88cbcdab93a3dbf3b94f359f8a9ff296535f001f06baee238d174e1555b39bd581d46328f42 WHIRLPOOL 7e13fceca7142f1e4ac80893faeb85bd4e935329c041a04c75e11b4c353520db748ad3e6c20fdc4ba1070bc130cc993e5a122758e6cb9b703fe889a1ee4f649c
DIST docker-compose-1.16.1.tar.gz 212167 SHA256 fb46a6a2c4d193a3ff1e4d7208eea920b629c81dc92257c87f3f93095cfb0bdf SHA512 add6aa5647352b993e5eba81c41815467cea82d39643a755c9f24ffeeb482e2b22423a9e3facdd94f41b382b2726cb65433516881971a8f373c79bce44923c4a WHIRLPOOL 144c8905fc06d11a2ed9583acb8d2dbf739771f2b90f60b6d90bce64a27d705b449a9df9e79754be094e3d1fec15993f88eecebc3647af32b7e54050338e39ca
+DIST docker-compose-1.17.0.tar.gz 221464 SHA256 ba1c2117d24bdad9f0e1c717a433d49c381099e6016adbd59a904426509f4c60 SHA512 2c42312e5eb848726cf8c78e07b6fbf63c34988b1bb85ffc8f30b5cb8eb1cbfc3b0b77746142e933b3311967c3f20610bc68477b33e10abf936f82f491a33682 WHIRLPOOL b806aaa4d0f8da66ffa074d8d697ab0cc1476b4a56a4eb60500abedc996721fd16e5849b47246dc081f218baf25b430b25805726554e6fbfac9e5b86a92cd104
diff --git a/app-emulation/docker-compose/docker-compose-1.17.0.ebuild b/app-emulation/docker-compose/docker-compose-1.17.0.ebuild
new file mode 100644
index 000000000000..e3bff20d7e04
--- /dev/null
+++ b/app-emulation/docker-compose/docker-compose-1.17.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit bash-completion-r1 distutils-r1 vcs-snapshot
+
+MY_PV=${PV//_/}
+
+DESCRIPTION="Multi-container orchestration for Docker"
+HOMEPAGE="https://www.docker.com/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${PN}-${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+CDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/cached-property-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/cached-property-2[${PYTHON_USEDEP}]
+ >=dev-python/dockerpty-0.4.1[${PYTHON_USEDEP}]
+ <dev-python/dockerpty-0.5[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-2.5.1[${PYTHON_USEDEP}]
+ <dev-python/docker-py-3.0[${PYTHON_USEDEP}]
+ >=dev-python/docopt-0.6.1[${PYTHON_USEDEP}]
+ <dev-python/docopt-0.7[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.5.1[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-3[${PYTHON_USEDEP}]
+ >=dev-python/PySocks-1.5.6[${PYTHON_USEDEP}]
+ !~dev-python/PySocks-1.5.7[${PYTHON_USEDEP}]
+ <dev-python/PySocks-2[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+ <dev-python/pyyaml-4[${PYTHON_USEDEP}]
+ !~dev-python/requests-2.11.0[${PYTHON_USEDEP}]
+ <dev-python/requests-2.12[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.6.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
+ <dev-python/six-2[${PYTHON_USEDEP}]
+ >=dev-python/texttable-0.9[${PYTHON_USEDEP}]
+ <dev-python/texttable-0.10[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
+ <dev-python/websocket-client-1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/enum34-1.0.4[${PYTHON_USEDEP}]' 'python2_7' )
+ $(python_gen_cond_dep '<dev-python/enum34-2[${PYTHON_USEDEP}]' 'python2_7' )
+ $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
+ $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' )
+"
+DEPEND="
+ ${CDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2_7' )
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_test() {
+ ${PYTHON} -m pytest tests/unit || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ newbashcomp contrib/completion/bash/docker-compose ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ doins contrib/completion/zsh/*
+
+ distutils-r1_python_install_all
+}