summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-10-06 11:25:18 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-10-06 17:20:46 +0200
commit3005e2b919d40703e8373567fdd880804606f124 (patch)
treed9800afb843bba5f106b31c35d4ab1a7260d2ba0 /app-emacs/swift-mode
parentapp-emacs/swift-mode: drop old 8.6.0 (diff)
downloadgentoo-3005e2b919d40703e8373567fdd880804606f124.tar.gz
gentoo-3005e2b919d40703e8373567fdd880804606f124.tar.bz2
gentoo-3005e2b919d40703e8373567fdd880804606f124.zip
app-emacs/swift-mode: bump to 9.1.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/swift-mode')
-rw-r--r--app-emacs/swift-mode/Manifest1
-rw-r--r--app-emacs/swift-mode/swift-mode-9.1.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/app-emacs/swift-mode/Manifest b/app-emacs/swift-mode/Manifest
index b77080e6c256..e6fceecbe5f8 100644
--- a/app-emacs/swift-mode/Manifest
+++ b/app-emacs/swift-mode/Manifest
@@ -1 +1,2 @@
DIST swift-mode-9.0.0.tar.gz 227995 BLAKE2B ac60f1dbf03f37a9e95372702f43eceeab2463d579c0e69110921851dc3d549ad32496648bfdca288003e17821dbc92b226d9581ebac8eb7d3e2e07ca4bd2f91 SHA512 affc7606456d44fdd82f7b5b47536e8822c1efb2f1dc49efb09451975b6c95dc9c9445e742a8c1f8038a9799e5cfd73b424ff56f50d9190c3f057bd34fb21f1c
+DIST swift-mode-9.1.0.tar.gz 228848 BLAKE2B 8da59aacc7b2f49b3156c5c22b92c7574df96657aeb95154b82551008f883f676935cabc3ddca86da8ab6c0364ab6ab9c963025f0fb361652179ab655076cf24 SHA512 ba06f67695cf10a3b78b29d5e375d8c76fb2f19cb2b6420d63332502062a461cc5e836f54dcc56f10cef3e6f3ed38c8803332c94372f2fbbdc681dc7a0fafbe9
diff --git a/app-emacs/swift-mode/swift-mode-9.1.0.ebuild b/app-emacs/swift-mode/swift-mode-9.1.0.ebuild
new file mode 100644
index 000000000000..3c78d0b5123e
--- /dev/null
+++ b/app-emacs/swift-mode/swift-mode-9.1.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Emacs support for Apple's Swift programming language"
+HOMEPAGE="https://github.com/swift-emacs/swift-mode/"
+SRC_URI="https://github.com/swift-emacs/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md CONTRIBUTING.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} \
+ -L . -L test \
+ -l test/swift-mode-test.el \
+ -f swift-mode:run-test || die "tests failed"
+}