summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-10-21 22:57:08 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-10-22 02:08:43 +0200
commita98cec5d54c41ebd490f17f58231a2502774c43d (patch)
tree1b2667668bcb3cd0b1276d1ab34917157e4e7255 /app-emacs/mastodon
parentapp-emacs/tp: new package; add 0.4 (diff)
downloadgentoo-a98cec5d54c41ebd490f17f58231a2502774c43d.tar.gz
gentoo-a98cec5d54c41ebd490f17f58231a2502774c43d.tar.bz2
gentoo-a98cec5d54c41ebd490f17f58231a2502774c43d.zip
app-emacs/mastodon: bump to 1.1.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/mastodon')
-rw-r--r--app-emacs/mastodon/Manifest1
-rw-r--r--app-emacs/mastodon/mastodon-1.1.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-emacs/mastodon/Manifest b/app-emacs/mastodon/Manifest
index 708fa10fecc7..6f0ea9647987 100644
--- a/app-emacs/mastodon/Manifest
+++ b/app-emacs/mastodon/Manifest
@@ -1 +1,2 @@
DIST mastodon-1.0.27.tar.gz 628054 BLAKE2B 7c023cfcd674ee221312ce65293ea39ceba4be4bed50682f546c2195404867ad3cdf790c806d52e128564e9f30e09ed2633d7c81d76cc8c211478389fa73db2d SHA512 dd1061d13104ea0ab8fc39333feb9aeb0b566130fb7ec5039b8b5b11809fabc65a7829346f76c0b66e922e5fb4cf70a96efcb6c9f972d90f6489c819a622fb9e
+DIST mastodon-1.1.0.tar.gz 691247 BLAKE2B 45052db00d143d3b225e4bd8be22796421528b4b7e7a87d9d71346c6e26e027dc9fc8b6982c458c3582ec16728ba81b959d2a88182aa2f00d9d5206d33f117a0 SHA512 6258d7859adb7a29a8a19a89367f02a56a453ec1f054f55015a5adaf20fe1d9d4f3847fb6ad2821735ecb547d653870f500f7d9cb7163a385a2502ed0a2cafe7
diff --git a/app-emacs/mastodon/mastodon-1.1.0.ebuild b/app-emacs/mastodon/mastodon-1.1.0.ebuild
new file mode 100644
index 000000000000..5f2eb49458d6
--- /dev/null
+++ b/app-emacs/mastodon/mastodon-1.1.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS="28.1"
+
+inherit elisp
+
+DESCRIPTION="Emacs client for Mastodon, federated microblogging social network"
+HOMEPAGE="https://codeberg.org/martianh/mastodon.el/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://codeberg.org/martianh/${PN}.el.git"
+ S="${WORKDIR}/${P}/lisp"
+else
+ SRC_URI="https://codeberg.org/martianh/${PN}.el/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}.el/lisp"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ app-emacs/persist
+ app-emacs/request
+ app-emacs/tp
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+DOCS=( ../README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp_src_install
+ doinfo "../${PN}.info"
+}