summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-05-20 01:31:25 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-05-20 01:32:29 +0200
commitce02acf5ebe864a0911620d829f4c41c88f046fa (patch)
treeaab9034219b68418bc528ce43b487b7a6a7b9730 /app-emacs/magit
parentapp-emacs/magit: bump to 3.3.0.50_p20240520 (diff)
downloadgentoo-ce02acf5ebe864a0911620d829f4c41c88f046fa.tar.gz
gentoo-ce02acf5ebe864a0911620d829f4c41c88f046fa.tar.bz2
gentoo-ce02acf5ebe864a0911620d829f4c41c88f046fa.zip
app-emacs/magit: update live deps
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/magit')
-rw-r--r--app-emacs/magit/magit-9999.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/app-emacs/magit/magit-9999.ebuild b/app-emacs/magit/magit-9999.ebuild
index a9701898bfb4..31188d0515ae 100644
--- a/app-emacs/magit/magit-9999.ebuild
+++ b/app-emacs/magit/magit-9999.ebuild
@@ -9,13 +9,14 @@ DESCRIPTION="A Git porcelain inside Emacs"
HOMEPAGE="https://magit.vc/
https://github.com/magit/magit/"
-if [[ ${PV} == *9999* ]] ; then
+if [[ "${PV}" == *9999* ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/magit/magit.git"
else
SRC_URI="https://github.com/magit/magit/archive/v${PV}.tar.gz
-> ${P}.tar.gz"
+
KEYWORDS="~amd64 ~arm ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
fi
@@ -29,9 +30,10 @@ ELISP_TEXINFO="../docs/*.texi"
SITEFILE="50${PN}-gentoo.el"
RDEPEND="
+ >=app-emacs/compat-29.1.4.5
>=app-emacs/dash-2.19.1
- >=app-emacs/transient-0.3.6
- >=app-emacs/with-editor-3.0.5
+ >=app-emacs/transient-0.6.0
+ >=app-emacs/with-editor-3.3.2
"
BDEPEND="
${RDEPEND}
@@ -45,5 +47,5 @@ src_prepare() {
default
rm magit-libgit.el || die
- echo "(setq magit-version \"${PV}\")" > magit-version.el || die
+ echo "(setq magit-version \"${PV}\")" > ./magit-version.el || die
}