summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2024-01-08 17:07:54 +0100
committerUlrich Müller <ulm@gentoo.org>2024-01-08 17:07:54 +0100
commit91725802e16f5a4907aa97d48064300aa59f0276 (patch)
tree6438662cd48bad282514c4af624f331a23d994b9 /app-emacs/ebuild-mode
parentdev-lang/spidermonkey: Stabilize 115.3.1 sparc, #920048 (diff)
downloadgentoo-91725802e16f5a4907aa97d48064300aa59f0276.tar.gz
gentoo-91725802e16f5a4907aa97d48064300aa59f0276.tar.bz2
gentoo-91725802e16f5a4907aa97d48064300aa59f0276.zip
app-emacs/ebuild-mode: add 1.70
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/ebuild-mode')
-rw-r--r--app-emacs/ebuild-mode/Manifest1
-rw-r--r--app-emacs/ebuild-mode/ebuild-mode-1.70.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/app-emacs/ebuild-mode/Manifest b/app-emacs/ebuild-mode/Manifest
index a8d6a63d7b35..85b64522542d 100644
--- a/app-emacs/ebuild-mode/Manifest
+++ b/app-emacs/ebuild-mode/Manifest
@@ -1,2 +1,3 @@
DIST ebuild-mode-1.67.tar.xz 40332 BLAKE2B 545106fbf63737015c8b80b715708c430dafc83484bd2d27901c1e81b5ecb10a0494a0f8ab9e0d3243f62c57045c1571ea75fd6813cbd74a04e507a2dadc3b3a SHA512 672c23ae77de6784a43329607b05f3ff354f0271a5051b886ede7b1d92a667f7968579a941b55e60839cbf0b79082e726aa32e1a81d3302acc84d866e3892a2b
DIST ebuild-mode-1.69.tar.xz 41436 BLAKE2B 9c3a41e6dac89d1c3908f72dfd4f2c2f62a1337fa9de1318d26901ae51c5b17cec429839378fa8df155f65807bc16efb9235b1913d4a3704d0d79df9fddd7af6 SHA512 2ba94f268f74a8424fccfc7ffff3d0e008261224a389253f67be91b6ade0301600fd50c0bb4b5f0487acb5b0add68dd6895a03dd7b096095034d59bc300e8a53
+DIST ebuild-mode-1.70.tar.xz 41528 BLAKE2B 51eecdaa262b20517aae269d4e8d41684d58a8aa73b316e08d03e4578b9bd0775577a46e15b637e4636978295629d36df774d39c253c3544ade985ad82b588dc SHA512 81e156adc19afe89778b9eb708414ba4cb6dd69ad3df05965eac6d5d46e6fda5b7e96f10933827639a17d8b349ae8c115b39e1ebd5c54350dcd07f9003d517e3
diff --git a/app-emacs/ebuild-mode/ebuild-mode-1.70.ebuild b/app-emacs/ebuild-mode/ebuild-mode-1.70.ebuild
new file mode 100644
index 000000000000..e3e259a0b9bd
--- /dev/null
+++ b/app-emacs/ebuild-mode/ebuild-mode-1.70.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp optfeature
+
+DESCRIPTION="Emacs modes for editing ebuilds and other Gentoo specific files"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Emacs"
+SRC_URI="https://dev.gentoo.org/~ulm/emacs/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+BDEPEND="sys-apps/texinfo"
+
+DOCS="ChangeLog keyword-generation.sh"
+ELISP_TEXINFO="${PN}.texi"
+SITEFILE="50${PN}-gentoo-1.54.el"
+
+pkg_postinst() {
+ elisp_pkg_postinst
+ optfeature "ebuild commands support" sys-apps/portage
+ optfeature "additional development tools" dev-util/pkgdev
+ optfeature "ebuild QA utilities" dev-util/pkgcheck
+ optfeature "generating HTML from GLEPs" dev-python/docutils-glep
+}