summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-10-08 22:44:14 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-10-08 22:44:14 +0300
commit18da52bb4dd845e110f59da4e25a1873d6d975e9 (patch)
tree8e39c91a2dd02a87759558bb9c71b5674711d6b8 /app-editors
parentapp-editors/vscode: add 1.72.0 (diff)
downloadgentoo-18da52bb4dd845e110f59da4e25a1873d6d975e9.tar.gz
gentoo-18da52bb4dd845e110f59da4e25a1873d6d975e9.tar.bz2
gentoo-18da52bb4dd845e110f59da4e25a1873d6d975e9.zip
app-editors/vscodium: add 1.72.0.22279
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vscodium/Manifest3
-rw-r--r--app-editors/vscodium/vscodium-1.72.0.22279.ebuild119
2 files changed, 122 insertions, 0 deletions
diff --git a/app-editors/vscodium/Manifest b/app-editors/vscodium/Manifest
index cb5fd0cc63b2..a266380eea1d 100644
--- a/app-editors/vscodium/Manifest
+++ b/app-editors/vscodium/Manifest
@@ -4,3 +4,6 @@ DIST vscodium-1.71.0.22245-arm64.tar.gz 112480037 BLAKE2B 730fe3e6564c7c72ddd9bb
DIST vscodium-1.71.2.22258-amd64.tar.gz 119405578 BLAKE2B dc6275d923dd48db78f6d9fdd219de822d16ba312fbcda3b1c5764f73321f38ddb62a338dfbde59df8f9e86b00011e71d9dd432e392b98b2f6eb19699df12df2 SHA512 5f3f8cbdac8aa3c8c9c4a954c62dffe8764db048fb4e8e5cb679ee9e7b68bf32a572093302ba035eea3358a7c3b18b40b5080ce04d24ef1558f858aa4d29f4f9
DIST vscodium-1.71.2.22258-arm.tar.gz 101454282 BLAKE2B b3ef1f4c1d16cba4ffe1cad177bb31611b2a5fc94a8b6b47629bdb570617245ebb5c0e417240ea4e7cd6ac643e031914b1786179de4653f707b522e0491bd944 SHA512 64d5fc48f0de1358cc30a2200d60c8a739bf579058f280e1bb4dd2c2db0241169d7bc4404b8b631554e4ecf764dc2587db31c81af73116019dbef15a4cf675ea
DIST vscodium-1.71.2.22258-arm64.tar.gz 112485387 BLAKE2B 879f16278a1b221283ef1f217634e589aaa37afad295c26ddb005fcca0df20bbc2c2c80b8c8f59d1dfff9bd33bbcbe8a27482996a4426c776e4a23d0a754ca0e SHA512 9bb531e3f08be4d5578fbc68c51c0a2e7797a2c89602f3133729b12bac3ca1ad48cc16ed71049ed6cdf4aef74a0ce518108d757de7fee175470cdba97b54712a
+DIST vscodium-1.72.0.22279-amd64.tar.gz 119675804 BLAKE2B a035d8832efde76e190c132c56ab36808dcbe0a078f60b8e1494386d078f131721e0c3c3c8d912082d62205524e2064693ce7895f7591db5d25b19b81f6c4ccf SHA512 c224c0e78bca4f4a955a953ae598bf7eaa2df8b70d93106d317e5e3494433ca67227d7b220c1cf0e4bba76245f49b25d04a26837bb9fae65f74e1c9115d988d6
+DIST vscodium-1.72.0.22279-arm.tar.gz 101721054 BLAKE2B 2fdeb9b1ac695b40f6100c039b15183b5a714e37236f801e6adf1dfdcadb5d15d33cdd70650bf4ea008342c810526ea90af7d2af67528ea664187dbb4640b9b8 SHA512 5290195b46663a11e23b035067e3eb6271e0a040e2bebec8fecf49e2d48be92d59d77876c07c8d38d0f6ea43855d1eba6cbd6c32ca92cdb6180beab53d316896
+DIST vscodium-1.72.0.22279-arm64.tar.gz 112756235 BLAKE2B 447b94bb45d28b2123ee6497cb696866137a1df0dd4eab83a9c9a7cc7a88d3febd8ecd09c927d602a88f0b12cc8162db0c06f3f13386c86068d709c8cd65715b SHA512 a226de551d29be28abdba029295756bb81adc19c3b1db3e5e111d1b33dacfa24dff5f6969d4558ad826dcea3e8d0c940a3ea271310b0d68fada18f6a72bdfa92
diff --git a/app-editors/vscodium/vscodium-1.72.0.22279.ebuild b/app-editors/vscodium/vscodium-1.72.0.22279.ebuild
new file mode 100644
index 000000000000..82dd29cba537
--- /dev/null
+++ b/app-editors/vscodium/vscodium-1.72.0.22279.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop pax-utils xdg optfeature
+
+DESCRIPTION="A community-driven, freely-licensed binary distribution of Microsoft's VSCode"
+HOMEPAGE="https://vscodium.com/"
+SRC_URI="
+ amd64? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-x64-${PV}.tar.gz -> ${P}-amd64.tar.gz )
+ arm? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-armhf-${PV}.tar.gz -> ${P}-arm.tar.gz )
+ arm64? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-arm64-${PV}.tar.gz -> ${P}-arm64.tar.gz )
+"
+
+RESTRICT="strip bindist"
+
+LICENSE="
+ Apache-2.0
+ BSD
+ BSD-1
+ BSD-2
+ BSD-4
+ CC-BY-4.0
+ ISC
+ LGPL-2.1+
+ MIT
+ MPL-2.0
+ openssl
+ PYTHON
+ TextMate-bundle
+ Unlicense
+ UoI-NCSA
+ W3C
+"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~arm64"
+IUSE=""
+
+RDEPEND="
+ || (
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ ( app-accessibility/at-spi2-atk dev-libs/atk )
+ )
+ app-crypt/libsecret[crypt]
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/mesa
+ sys-apps/util-linux
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libxshmfence
+ x11-libs/pango
+"
+
+QA_PREBUILT="
+ /opt/vscodium/chrome_crashpad_handler
+ /opt/vscodium/chrome-sandbox
+ /opt/vscodium/codium
+ /opt/vscodium/libEGL.so
+ /opt/vscodium/libffmpeg.so
+ /opt/vscodium/libGLESv2.so
+ /opt/vscodium/libvk_swiftshader.so
+ /opt/vscodium/libvulkan.so*
+ /opt/vscodium/resources/app/extensions/*
+ /opt/vscodium/resources/app/node_modules.asar.unpacked/*
+ /opt/vscodium/swiftshader/libEGL.so
+ /opt/vscodium/swiftshader/libGLESv2.so
+"
+
+S="${WORKDIR}"
+
+src_install() {
+ # Cleanup
+ rm "${S}/resources/app/LICENSE.txt" || die
+
+ # Disable update server
+ sed -i "/updateUrl/d" "${S}"/resources/app/product.json || die
+
+ # Install
+ pax-mark m codium
+ insinto "/opt/${PN}"
+ doins -r *
+ fperms +x /opt/${PN}/{,bin/}codium
+ fperms +x /opt/${PN}/chrome_crashpad_handler
+ fperms 4711 /opt/${PN}/chrome-sandbox
+ fperms 755 /opt/${PN}/resources/app/extensions/git/dist/{askpass,git-editor}{,-empty}.sh
+ fperms -R +x /opt/${PN}/resources/app/out/vs/base/node
+ fperms +x /opt/${PN}/resources/app/node_modules.asar.unpacked/@vscode/ripgrep/bin/rg
+ dosym "../../opt/${PN}/bin/codium" "usr/bin/vscodium"
+ dosym "../../opt/${PN}/bin/codium" "usr/bin/codium"
+ domenu "${FILESDIR}/vscodium.desktop"
+ domenu "${FILESDIR}/vscodium-url-handler.desktop"
+ domenu "${FILESDIR}/vscodium-wayland.desktop"
+ domenu "${FILESDIR}/vscodium-url-handler-wayland.desktop"
+ newicon "resources/app/resources/linux/code.png" "vscodium.png"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ elog "When compared to the regular VSCode, VSCodium has a few quirks"
+ elog "More information at: https://github.com/VSCodium/vscodium/blob/master/DOCS.md"
+ optfeature "keyring support inside vscode" "gnome-base/gnome-keyring"
+}