summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2022-08-03 23:18:31 +0200
committerSam James <sam@gentoo.org>2022-08-31 23:15:11 +0100
commit387d202839e119f7d1d3b3b2c67b2ecb0828c4bd (patch)
tree6ec8150c9a798012d9d46bff510ea914cfd41fdb /app-editors/hyx
parentprofiles/features/musl: tidy up comment slightly (diff)
downloadgentoo-387d202839e119f7d1d3b3b2c67b2ecb0828c4bd.tar.gz
gentoo-387d202839e119f7d1d3b3b2c67b2ecb0828c4bd.tar.bz2
gentoo-387d202839e119f7d1d3b3b2c67b2ecb0828c4bd.zip
app-editors/hyx: new package, add 2021.06.09
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://github.com/gentoo/gentoo/pull/26731 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors/hyx')
-rw-r--r--app-editors/hyx/Manifest1
-rw-r--r--app-editors/hyx/files/hyx-ldflags.patch27
-rw-r--r--app-editors/hyx/hyx-2021.06.09.ebuild27
-rw-r--r--app-editors/hyx/metadata.xml12
4 files changed, 67 insertions, 0 deletions
diff --git a/app-editors/hyx/Manifest b/app-editors/hyx/Manifest
new file mode 100644
index 000000000000..8505c8b69dda
--- /dev/null
+++ b/app-editors/hyx/Manifest
@@ -0,0 +1 @@
+DIST hyx-2021.06.09.tar.xz 13864 BLAKE2B 2c97364e1ae185e7dd63fdfb452637cb68b8ab0d76d0009ce515d6f0fe709d38b910f86dfa465ac6843c88feb997dfdc3c736e21bb0b4265a39440c054f75251 SHA512 43f990e29ce097f8e2378a4511a3097e2576fd72e16f3b5c81688702487c8715e7189cb4a368e344c5440a90a1c759d2f76e7831ab401fa814f7e5ff7e145bd8
diff --git a/app-editors/hyx/files/hyx-ldflags.patch b/app-editors/hyx/files/hyx-ldflags.patch
new file mode 100644
index 000000000000..714e76a795db
--- /dev/null
+++ b/app-editors/hyx/files/hyx-ldflags.patch
@@ -0,0 +1,27 @@
+diff -Naur hyx-2021.06.09.org/Makefile hyx-2021.06.09/Makefile
+--- hyx-2021.06.09.org/Makefile 2021-06-09 18:09:18.000000000 +0200
++++ hyx-2021.06.09/Makefile 2022-08-31 08:20:27.711819466 +0200
+@@ -1,18 +1,19 @@
+
+ all: CFLAGS ?= -O2 -Wl,-s \
+- -Wl,-z,relro,-z,now -fpic -pie -D_FORTIFY_SOURCE=2 -fstack-protector-all
+-all: CFLAGS += -std=c99 -pedantic -Wall -Wextra -DNDEBUG
++ -std=c99 -pedantic -Wall -Wextra -DNDEBUG
++all: LDFLAGS ?= -Wl,-z,relro,-z,now -fpic -pie -D_FORTIFY_SOURCE=2 -fstack-protector-all
+ all: hyx
+
+ debug: CFLAGS ?= -O0 -g \
+ -fsanitize=undefined \
+- -Wl,-z,relro,-z,now -fpic -pie -fstack-protector-all
+-debug: CFLAGS += -std=c99 -pedantic -Wall -Wextra -Werror
++ -std=c99 -pedantic -Wall -Wextra -Werror
++debug: LDFLAGS ?= -Wl,-z,relro,-z,now -fpic -pie -fstack-protector-all
+ debug: hyx
+
+ hyx: *.h *.c
+ $(CC) \
+ $(CFLAGS) \
++ $(LDFLAGS) \
+ hyx.c common.c blob.c history.c view.c input.c \
+ -o hyx
+
diff --git a/app-editors/hyx/hyx-2021.06.09.ebuild b/app-editors/hyx/hyx-2021.06.09.ebuild
new file mode 100644
index 000000000000..d185af4b0b5f
--- /dev/null
+++ b/app-editors/hyx/hyx-2021.06.09.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A minimalistic console hex editor with vim-like controls"
+HOMEPAGE="https://yx7.cc/code/"
+SRC_URI="https://yx7.cc/code/hyx/${P}.tar.xz"
+
+LICENSE="MIT-with-advertising"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+ # Avoid complaining about not respecting LDFLAGS
+ "${FILESDIR}/${PN}-ldflags.patch"
+)
+
+src_compile() {
+ CC=$(tc-getCC) emake
+}
+
+src_install() {
+ dobin hyx
+}
diff --git a/app-editors/hyx/metadata.xml b/app-editors/hyx/metadata.xml
new file mode 100644
index 000000000000..daba394f5855
--- /dev/null
+++ b/app-editors/hyx/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>mario.haustein@hrz.tu-chemnitz.de</email>
+ <name>Mario Haustein</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>