summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Byrne <salah.coronya@gmail.com>2024-11-15 15:09:57 -0600
committerSam James <sam@gentoo.org>2024-11-23 19:48:29 +0000
commit48c323e3eb7da8eef5ba85e14d7b83f2f548aa1e (patch)
treef146f387229642b5e940883d51ec03f4f1201125 /app-crypt
parentdev-libs/libtpms: add 0.10.0 (diff)
downloadgentoo-48c323e3eb7da8eef5ba85e14d7b83f2f548aa1e.tar.gz
gentoo-48c323e3eb7da8eef5ba85e14d7b83f2f548aa1e.tar.bz2
gentoo-48c323e3eb7da8eef5ba85e14d7b83f2f548aa1e.zip
app-crypt/swtpm: add 0.10.0
Signed-off-by: Christopher Byrne <salah.coronya@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/39318 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/swtpm/Manifest1
-rw-r--r--app-crypt/swtpm/files/swtpm-0.10.0-build-sys-Remove-WError.patch13
-rw-r--r--app-crypt/swtpm/swtpm-0.10.0.ebuild74
3 files changed, 88 insertions, 0 deletions
diff --git a/app-crypt/swtpm/Manifest b/app-crypt/swtpm/Manifest
index 119e21ba83c2..1a1a41801d8a 100644
--- a/app-crypt/swtpm/Manifest
+++ b/app-crypt/swtpm/Manifest
@@ -1,3 +1,4 @@
+DIST swtpm-0.10.0.tar.gz 414698 BLAKE2B 62ebc5638e7c0b6c2be42d8da5369dfce708339882b582b154aa46d5ae6ed4a59f4e6cc31a05b062190b98a461caed82281bf64b05e8941d3923d200cfde501c SHA512 6f1848b0514799417582c1a5bedf9b7110e3627ab14f02ea193ad76ce8a188eba596494f410405c5f7226e2daf7d9ee889983a2265285839e72de12e6368180d
DIST swtpm-0.8.1.tar.gz 364169 BLAKE2B 4b364ed581ea97d78c5c6248870503b1612d7d164b05b76c1f02644aade6fd09f204396f0a2d0db4e0ecec2792dc512f7c4393c44bf7ce447a3a7fbb8754594f SHA512 07276519b0e20c9c4167ce78e789d2072eb90172ed9bcba2a11eef46ee03a77860f7a2218f4dc013a2ddb8471079e3cbe43f8ab02174bd704a78aea8eee3d2fc
DIST swtpm-0.8.2.tar.gz 364432 BLAKE2B 1ffa6feed88a67a2eeea1fca1c034f6513347173d59ae0c0654696faa1e791529e7fa044c478e5fb7e016117ce5f3151b875014d85eac528e4b6d92d5cf9017b SHA512 3b63116b1ed56087e05b0b697462720a10fe384ea2b8ec7115b549df8f557f6a9cf4de8e7d65b8061a1c85e54e015e0249bfbb613d35c1b64453a98d23ce334f
DIST swtpm-0.9.0.tar.gz 370942 BLAKE2B bed63851dfdb94f463bbac962044114f75abd36f6558f173fd67be608f50c8954c6038d33bb6e3d2e88427238c7c06048beae23b84b2a1e186c0de98a9bd5ad8 SHA512 4f1723679b85218e80ea6aacdffa687e541ee309ddab9bcb8d8e5aa0b461ee431c880f2e300f1dcae112646f3636593005a342ee0cb762ec115aa599369e111c
diff --git a/app-crypt/swtpm/files/swtpm-0.10.0-build-sys-Remove-WError.patch b/app-crypt/swtpm/files/swtpm-0.10.0-build-sys-Remove-WError.patch
new file mode 100644
index 000000000000..214f107b690d
--- /dev/null
+++ b/app-crypt/swtpm/files/swtpm-0.10.0-build-sys-Remove-WError.patch
@@ -0,0 +1,13 @@
+diff --git a/configure.ac b/configure.ac
+index 76f3501..f3a4c6f 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -542,7 +542,7 @@ AC_SUBST([TSS_USER])
+ AC_SUBST([TSS_GROUP])
+
+ CFLAGS="$CFLAGS -Wreturn-type -Wsign-compare -Wswitch-enum"
+-CFLAGS="$CFLAGS -Wmissing-prototypes -Wall -Werror"
++CFLAGS="$CFLAGS -Wmissing-prototypes -Wall"
+ CFLAGS="$CFLAGS -Wformat -Wformat-security -Wshadow"
+ CFLAGS="$CFLAGS $GNUTLS_CFLAGS $COVERAGE_CFLAGS $SANITIZER_CFLAGS"
+
diff --git a/app-crypt/swtpm/swtpm-0.10.0.ebuild b/app-crypt/swtpm/swtpm-0.10.0.ebuild
new file mode 100644
index 000000000000..eeeaaf2f76aa
--- /dev/null
+++ b/app-crypt/swtpm/swtpm-0.10.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit autotools python-any-r1
+
+DESCRIPTION="Libtpms-based TPM emulator"
+HOMEPAGE="https://github.com/stefanberger/swtpm"
+SRC_URI="https://github.com/stefanberger/swtpm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="fuse seccomp test"
+RESTRICT="!test? ( test )"
+
+# net-libs/gnutls[pkcs11,tools] is required otherwsie it not possible to
+# provision new vTPMs. swtpm_cert spawns certttool, and upstream expects
+# pkcs11 in gnutls: https://github.com/stefanberger/swtpm/issues/477.
+
+RDEPEND="fuse? (
+ dev-libs/glib:2
+ sys-fs/fuse:0
+ )
+ seccomp? ( sys-libs/libseccomp )
+ acct-group/tss
+ acct-user/tss
+ dev-libs/gmp:=
+ dev-libs/openssl:=
+ dev-libs/json-glib
+ >=dev-libs/libtpms-0.10.0
+ dev-libs/libtasn1:=
+ net-libs/gnutls:=[pkcs11,tools]
+"
+
+DEPEND="${RDEPEND}
+ test? (
+ net-misc/socat
+ dev-tcltk/expect
+ )"
+
+BDEPEND="${PYTHON_DEPS}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.6.0-fix-localca-path.patch"
+ "${FILESDIR}/${PN}-0.10.0-build-sys-Remove-WError.patch"
+ "${FILESDIR}/${PN}-0.8.2-slibtool.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-openssl \
+ --with-gnutls \
+ --without-selinux \
+ $(use_with fuse cuse) \
+ $(use_with seccomp) \
+ $(use_enable test tests)
+}
+
+src_install() {
+ default
+ fowners -R tss:root /var/lib/swtpm-localca
+ fperms 750 /var/lib/swtpm-localca
+ keepdir /var/lib/swtpm-localca
+ find "${D}" -name '*.la' -delete || die
+}