summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-11-11 16:53:22 +0000
committerMarek Szuba <marecki@gentoo.org>2021-11-11 20:15:29 +0000
commitc9c0e2920b970b5cd69d1204efdb34344c8d8ffb (patch)
tree35029c5fc7357d16ddf502eaf01ca987fc1334e3 /app-crypt/yubioath-desktop
parentx11-misc/xdotool: add 3.20211022.1 (diff)
downloadgentoo-c9c0e2920b970b5cd69d1204efdb34344c8d8ffb.tar.gz
gentoo-c9c0e2920b970b5cd69d1204efdb34344c8d8ffb.tar.bz2
gentoo-c9c0e2920b970b5cd69d1204efdb34344c8d8ffb.zip
app-crypt/yubioath-desktop: add 5.1.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-crypt/yubioath-desktop')
-rw-r--r--app-crypt/yubioath-desktop/Manifest1
-rw-r--r--app-crypt/yubioath-desktop/yubioath-desktop-5.1.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/app-crypt/yubioath-desktop/Manifest b/app-crypt/yubioath-desktop/Manifest
index 79259f2181a8..e37919968b57 100644
--- a/app-crypt/yubioath-desktop/Manifest
+++ b/app-crypt/yubioath-desktop/Manifest
@@ -1 +1,2 @@
DIST yubioath-desktop-5.0.5.tar.gz 5659179 BLAKE2B 31dd1a7e9b8a5034e916f38c7893572b6b7e75fa0bc45b5b807c89010ac0e4a01a446f03d1591dd6323a015fc8fb17861fa60dc5a5e4eff40b5261fb6e3f7088 SHA512 b5a0df306916896e1fd84d6a794a43365b0e0a2cecd97ec1dacc6312507dd2e4dd55fc12b0de9d72d1d0a1b40625330373b7c74dacb2ec37a24ea3e1fd2d4ff7
+DIST yubioath-desktop-5.1.0.tar.gz 6322224 BLAKE2B e1fc93bd38af3c6937f390c738248e43dbd17052df5103a0e25547adf7b34eca60ed8b45c9681568202d01802a5d8503cf2a5bf53d57c7c18ee2ee53cecd8d51 SHA512 152e27fca3c082c996c96fb05ed66781a52a47f30d8c5649d43937cf87c566f09c1fcb6afd65402b5f7fbe2a1f71872f10c8b456bd8a9b240c360018defd48c9
diff --git a/app-crypt/yubioath-desktop/yubioath-desktop-5.1.0.ebuild b/app-crypt/yubioath-desktop/yubioath-desktop-5.1.0.ebuild
new file mode 100644
index 000000000000..e2f85896c574
--- /dev/null
+++ b/app-crypt/yubioath-desktop/yubioath-desktop-5.1.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit desktop python-single-r1 qmake-utils xdg
+
+DESCRIPTION="Library and tool for personalization of Yubico's YubiKey NEO"
+HOMEPAGE="
+ https://developers.yubico.com/yubioath-desktop/
+ https://github.com/Yubico/yubioath-desktop"
+SRC_URI="https://github.com/Yubico/yubioath-desktop/archive/${P}.tar.gz"
+S="${WORKDIR}/${PN}-${P}"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtquickcontrols2:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ x11-libs/libdrm"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '>=app-crypt/yubikey-manager-4.0.0[${PYTHON_USEDEP}]')
+ dev-python/pyotherside[${PYTHON_SINGLE_USEDEP}]"
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s:python build_qrc.py:${PYTHON} build_qrc.py:" \
+ yubioath-desktop.pro || die
+
+ python_fix_shebang "${S}"
+}
+
+src_configure() {
+ eqmake5 yubioath-desktop.pro
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+
+ domenu resources/com.yubico.yubioath.desktop
+ doicon resources/icons/com.yubico.yubioath.png
+ doicon -s scalable resources/icons/com.yubico.yubioath.svg
+}