summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSalah Coronya <salah.coronya@gmail.com>2020-09-23 16:02:54 -0500
committerJoonas Niilola <juippis@gentoo.org>2020-10-11 12:29:56 +0300
commitdafe3d1624affb9c284e9820a4dafaee48c92694 (patch)
tree4d60e5926692496656ce9ff476da8cc8732ee12b /app-crypt/tpm2-tss
parentapp-crypt/tpm2-tss: Bump to 2.4.3, fix CVE-2020-24455 (diff)
downloadgentoo-dafe3d1624affb9c284e9820a4dafaee48c92694.tar.gz
gentoo-dafe3d1624affb9c284e9820a4dafaee48c92694.tar.bz2
gentoo-dafe3d1624affb9c284e9820a4dafaee48c92694.zip
app-crypt/tpm2-tss: Bump to 3.0.1, fix CVE-2020-24455
Bug: https://bugs.gentoo.org/746563 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Salah Coronya <salah.coronya@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-crypt/tpm2-tss')
-rw-r--r--app-crypt/tpm2-tss/Manifest1
-rw-r--r--app-crypt/tpm2-tss/tpm2-tss-3.0.1.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/app-crypt/tpm2-tss/Manifest b/app-crypt/tpm2-tss/Manifest
index f8dc34670e99..61e41c91162d 100644
--- a/app-crypt/tpm2-tss/Manifest
+++ b/app-crypt/tpm2-tss/Manifest
@@ -2,3 +2,4 @@ DIST tpm2-tss-2.4.1.tar.gz 1445103 BLAKE2B c7be91b93d19b5afeddb6ec455db9ba06795f
DIST tpm2-tss-2.4.2.tar.gz 1461987 BLAKE2B 7d37818ba91c4128862206d5179dcde2c5149b5b00807b242a0b4311531ad2da9e8ad435a6b46872aab5eb91777012010a352ba0f478737740175e0353275643 SHA512 db31d216abcefdad76f5d9ff2995c99c552400392a4dec800b962fa1fa3ac83effacca831602a9b7f814045c996a1bb066802c5373b54233aa24ddafd636c27e
DIST tpm2-tss-2.4.3.tar.gz 1439120 BLAKE2B 21acce29f96e8039124874c024b43eb8d2c4ffda27db58bb4f34446747c0fa6953c6ca390f8e87d22c1349123bada81051b119eaf7a28c7d1ad8a9195287c312 SHA512 4adaeb2724b720017e9d488f66de879ebdc0dbc2a4f7536493214913a49d2c631e302be26f710f0f45b0d514212cb036ca7ba9715ee13c29dda1d4a61595aa27
DIST tpm2-tss-3.0.0.tar.gz 1509288 BLAKE2B 23c46ba6c9ea2b61703556d3aab5b4e75b1a0242a688c44e8c254a4defd8258e100a933598755373ffec9db3ca0ab9d35e6a290a73851c2a456449e04bd8313a SHA512 ba54904f2cd8cbcca85ce4d4ac5c8650da6ab076e8d8d142e1b7ee75c5e9a645520f1a5ac8ffe5269deceba84762c9074b131296e8b2d4c684ddc335a828d7a8
+DIST tpm2-tss-3.0.1.tar.gz 1488285 BLAKE2B 2ccf123a2e0ff6355d8022402fb2e12932565f345b4b2c9ac68249b5de3ea5851256c38057323b19cb84dfd2ea5b63292b8b8f1bd4d9576d27bd57a35f0250f1 SHA512 206830fecea22c4974a16b5e76599b3c22e077a448f15e2707b260eba6832b2089f9d7c12d3e42daf314cdfbd83309b2b623a7abeb1409234f1930a835365529
diff --git a/app-crypt/tpm2-tss/tpm2-tss-3.0.1.ebuild b/app-crypt/tpm2-tss/tpm2-tss-3.0.1.ebuild
new file mode 100644
index 000000000000..c6148898feee
--- /dev/null
+++ b/app-crypt/tpm2-tss/tpm2-tss-3.0.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools linux-info tmpfiles udev
+
+DESCRIPTION="TCG Trusted Platform Module 2.0 Software Stack"
+HOMEPAGE="https://github.com/tpm2-software/tpm2-tss"
+SRC_URI="https://github.com/tpm2-software/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="doc +fapi +openssl mbedtls static-libs test"
+
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="^^ ( mbedtls openssl )
+ fapi? ( openssl !mbedtls )"
+
+RDEPEND="acct-group/tss
+ acct-user/tss
+ fapi? ( dev-libs/json-c
+ net-misc/curl )
+ mbedtls? ( net-libs/mbedtls:= )
+ openssl? ( dev-libs/openssl:= )"
+DEPEND="${RDEPEND}
+ test? ( dev-util/cmocka )"
+BDEPEND="virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.0.0-Dont-run-systemd-sysusers-in-Makefile.patch"
+)
+
+pkg_setup() {
+ local CONFIG_CHECK=" \
+ ~TCG_TPM
+ "
+ linux-info_pkg_setup
+ kernel_is ge 4 12 0 || ewarn "At least kernel 4.12.0 is required"
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ $(use_enable doc doxygen-doc) \
+ $(use_enable fapi) \
+ $(use_enable static-libs static) \
+ $(use_enable test unit) \
+ --disable-tcti-mssim \
+ --disable-defaultflags \
+ --disable-weakcrypto \
+ --with-crypto="$(usex mbedtls mbed ossl)" \
+ --with-runstatedir=/run \
+ --with-udevrulesdir="$(get_udevdir)/rules.d" \
+ --with-udevrulesprefix=60- \
+ --with-sysusersdir="/usr/lib/sysusers.d" \
+ --with-tmpfilesdir="/usr/lib/tmpfiles.d"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ tmpfiles_process tpm2-tss-fapi.conf
+}