summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/openvpn-blacklist
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/openvpn-blacklist')
-rw-r--r--app-crypt/openvpn-blacklist/Manifest1
-rw-r--r--app-crypt/openvpn-blacklist/metadata.xml5
-rw-r--r--app-crypt/openvpn-blacklist/openvpn-blacklist-0.4-r1.ebuild33
3 files changed, 39 insertions, 0 deletions
diff --git a/app-crypt/openvpn-blacklist/Manifest b/app-crypt/openvpn-blacklist/Manifest
new file mode 100644
index 000000000000..8f42e2e0a1f0
--- /dev/null
+++ b/app-crypt/openvpn-blacklist/Manifest
@@ -0,0 +1 @@
+DIST openvpn-blacklist_0.4.tar.gz 1808103 SHA256 01d0cddab3db957661dc8019c1b672068699f1f7cf8633748b6222601ecb0108 SHA512 3301f7425520eb086306acb30bd718465208b5aa5606e879b65f936161d1955b93254d9c1dd6f5d66ec6480850652afadabb05db2a0df9fd5acb73a5ed5c19e3 WHIRLPOOL 7eba98ff8e1281e5008f01a360aa37aba87a494d187ef1a83599aa57d16cb2980e021af4ee25abc92c83eee1a8c287b4567f671a4bca0753ef1ea68120aa2600
diff --git a/app-crypt/openvpn-blacklist/metadata.xml b/app-crypt/openvpn-blacklist/metadata.xml
new file mode 100644
index 000000000000..8cb548491f4e
--- /dev/null
+++ b/app-crypt/openvpn-blacklist/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>hanno@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/app-crypt/openvpn-blacklist/openvpn-blacklist-0.4-r1.ebuild b/app-crypt/openvpn-blacklist/openvpn-blacklist-0.4-r1.ebuild
new file mode 100644
index 000000000000..a7fb81d908ff
--- /dev/null
+++ b/app-crypt/openvpn-blacklist/openvpn-blacklist-0.4-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1
+
+DESCRIPTION="Detection of weak openvpn keys produced by certain debian versions between 2006 and 2008"
+HOMEPAGE="http://packages.debian.org/sid/openvpn-blacklist"
+SRC_URI="mirror://debian/pool/main/o/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=${PYTHON_DEPS}
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+src_prepare() {
+ python_fix_shebang openvpn-vulnkey
+}
+
+src_install() {
+ dobin openvpn-vulnkey
+ doman openvpn-vulnkey.1
+ dodir /usr/share/openvpn-blacklist
+ cat "${S}/debian/blacklist.prefix" > "${D}/usr/share/openssl-blacklist/blacklist.RSA-2048"
+ cut "${S}/blacklist.RSA-2048" -d ' ' -f 2 | cut -b13- | sort \
+ >> "${D}/usr/share/openvpn-blacklist/blacklist.RSA-2048"
+}