summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2022-12-18 10:46:19 +0000
committerMatthew Smith <matthew@gentoo.org>2022-12-18 11:11:07 +0000
commit56e7435cd1acfdbaaea2103c574789c513fef777 (patch)
treef11f7d9e011f48d073832adcd6b454380a04367a /app-crypt/mkp224o/mkp224o-1.6.1-r1.ebuild
parentsci-libs/flann: Stabilize 1.9.1-r5 arm64, #886643 (diff)
downloadgentoo-56e7435cd1acfdbaaea2103c574789c513fef777.tar.gz
gentoo-56e7435cd1acfdbaaea2103c574789c513fef777.tar.bz2
gentoo-56e7435cd1acfdbaaea2103c574789c513fef777.zip
app-crypt/mkp224o: rename pcre2 use flag to pcre
Bug: https://bugs.gentoo.org/886541 Closes: https://github.com/gentoo/gentoo/pull/28701 Acked-by: Sam James <sam@gentoo.org> Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'app-crypt/mkp224o/mkp224o-1.6.1-r1.ebuild')
-rw-r--r--app-crypt/mkp224o/mkp224o-1.6.1-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-crypt/mkp224o/mkp224o-1.6.1-r1.ebuild b/app-crypt/mkp224o/mkp224o-1.6.1-r1.ebuild
new file mode 100644
index 000000000000..1185aeba051a
--- /dev/null
+++ b/app-crypt/mkp224o/mkp224o-1.6.1-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Vanity address generator for v3 Tor hidden service addresses"
+HOMEPAGE="https://github.com/cathugger/mkp224o"
+SRC_URI="https://github.com/cathugger/${PN}/releases/download/v${PV}/${PN}-${PV}-src.tar.gz"
+
+LICENSE="CC0-1.0"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE="cpu_flags_x86_sse2 pcre"
+
+DEPEND="
+ dev-libs/libsodium:=
+ pcre? ( dev-libs/libpcre2:= )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( OPTIMISATION.txt README.md )
+
+src_configure() {
+ local myeconfargs=(
+ --enable-regex=$(usex pcre)
+ --enable-statistics
+ )
+ use cpu_flags_x86_sse2 && myeconfargs+=( --enable-donna-sse2 )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ einstalldocs
+ dobin ${PN}
+}