summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-09 18:12:06 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-09 18:12:06 +0200
commitcb3c650ff96680a6b679bee69cc80b79b8c7e179 (patch)
tree3016df3d77281549e9ebf1557c8625cccbfecd17 /app-crypt/certbot-dns-nsone
parentapp-misc/timew-report: EAPI, PEP517, py3.11 (diff)
downloadgentoo-cb3c650ff96680a6b679bee69cc80b79b8c7e179.tar.gz
gentoo-cb3c650ff96680a6b679bee69cc80b79b8c7e179.tar.bz2
gentoo-cb3c650ff96680a6b679bee69cc80b79b8c7e179.zip
app-crypt/certbot-dns-nsone: PEP517, py3.11
Closes: https://bugs.gentoo.org/896516 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-crypt/certbot-dns-nsone')
-rw-r--r--app-crypt/certbot-dns-nsone/Manifest1
-rw-r--r--app-crypt/certbot-dns-nsone/certbot-dns-nsone-1.18.0-r1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-crypt/certbot-dns-nsone/Manifest b/app-crypt/certbot-dns-nsone/Manifest
index cf97e5c2cb7e..d8d93538f258 100644
--- a/app-crypt/certbot-dns-nsone/Manifest
+++ b/app-crypt/certbot-dns-nsone/Manifest
@@ -1 +1,2 @@
+DIST certbot-1.18.0.gh.tar.gz 1332615 BLAKE2B eb086710b943893025d6e1091470ca02de074232372f4c9fa21fa83a347fe54df988b9553c8cf6afd6e166b8c464d595171984c984008a872e16c0179bb774b2 SHA512 94b16ba0586e0f5d3036280c68f9976c25889ca48fbbe7aded41f0d9feba2300a3f0ff8fe321b39d8642bcdd874c7332cf2acb3187b5869fe415831f58a75a7b
DIST certbot-dns-nsone-1.18.0.tar.gz 1332615 BLAKE2B eb086710b943893025d6e1091470ca02de074232372f4c9fa21fa83a347fe54df988b9553c8cf6afd6e166b8c464d595171984c984008a872e16c0179bb774b2 SHA512 94b16ba0586e0f5d3036280c68f9976c25889ca48fbbe7aded41f0d9feba2300a3f0ff8fe321b39d8642bcdd874c7332cf2acb3187b5869fe415831f58a75a7b
diff --git a/app-crypt/certbot-dns-nsone/certbot-dns-nsone-1.18.0-r1.ebuild b/app-crypt/certbot-dns-nsone/certbot-dns-nsone-1.18.0-r1.ebuild
new file mode 100644
index 000000000000..925d64f17b47
--- /dev/null
+++ b/app-crypt/certbot-dns-nsone/certbot-dns-nsone-1.18.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P=certbot-${PV}
+DESCRIPTION="NS1 DNS Authenticator plugin for Certbot (Let's Encrypt Client)"
+HOMEPAGE="
+ https://github.com/certbot/certbot/
+ https://letsencrypt.org/
+"
+SRC_URI="
+ https://github.com/certbot/certbot/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}/${PN}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ >=dev-python/dns-lexicon-3.2.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest