summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2024-10-11 16:30:51 -0700
committerZac Medico <zmedico@gentoo.org>2024-10-11 16:31:14 -0700
commit6a6e7a1a0f27330a8a68ebc431126550de34c390 (patch)
treed0f6413ed882b1b3e8646d6b820e8acc3fc23a3c /app-containers
parentnet-misc/passt: add 2024.09.06 (diff)
downloadgentoo-6a6e7a1a0f27330a8a68ebc431126550de34c390.tar.gz
gentoo-6a6e7a1a0f27330a8a68ebc431126550de34c390.tar.bz2
gentoo-6a6e7a1a0f27330a8a68ebc431126550de34c390.zip
app-containers/containers-common: add 0.60.4
Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/containers-common/Manifest1
-rw-r--r--app-containers/containers-common/containers-common-0.60.4.ebuild75
-rw-r--r--app-containers/containers-common/containers-common-9999.ebuild14
3 files changed, 83 insertions, 7 deletions
diff --git a/app-containers/containers-common/Manifest b/app-containers/containers-common/Manifest
index 09300934cd25..bcb3c04ac308 100644
--- a/app-containers/containers-common/Manifest
+++ b/app-containers/containers-common/Manifest
@@ -1,3 +1,4 @@
DIST containers-common-0.57.0.tar.gz 12700958 BLAKE2B 8432a7d839b94b59eabd75d4978a4d0c1340a64ed626db74e74a8318e08c61172bfba5e4f4c4b0dfffec302c5a310bb5be8fad3ab4d91a6d89ced373a0a6f297 SHA512 b993821040788085ff44e48023a64cea4e3e7e50731c359087bd287168e6849a543d930acbdaff2437fc7951acc46f7183f337dd977215eca814332e6869d1e3
DIST containers-common-0.58.0.tar.gz 13164567 BLAKE2B 17795eec2d38b4d8b9d6afeb20e249208c5ae2ac767a365ef7313d1e7c36eadb9a9eb284a657dfe3f4fcb0577448d4883fabbad76e0318425fdc03809e27cd7c SHA512 6f569d68d3b0e5ead304c7f23341808d66a47b6352c772d353d50c5f4777cd8a5a5b85d6faaf2887f828c17ec49b9c5f929177a67294b5bbb69baa80656982a8
DIST containers-common-0.59.1.tar.gz 13131960 BLAKE2B 5b3b947789f889955716816fa15a84eb2f398d6cfb59c85bd969442fb8f55715f2c17c78d963ae913d96e6a109f69da745cfc7db8d23e2ed6516f992b982dda0 SHA512 452c9b84f7631afdf39b7b1fcaf2f721bede312d8fb55b89a953f16ca3546c0df11bb23c99588a592b6375275516d1364570261fbc15301ca3ad486ee66eae32
+DIST containers-common-0.60.4.tar.gz 13106900 BLAKE2B 1afb428044bc8eebd002b884f2a2072971cd83fca561fd509b83088ccdf82b3a62d63ff32ec5ef856c3d0ee0ffac316201fa8f1d7956153ce30e2244cc860f02 SHA512 5d61415d4959486223a36ff98304363a558e6da9ccbdca94f976649a37d404ac00c8454019f60a79360029c91c9565d22868b109dbb84c19f13377e0e23dcc4d
diff --git a/app-containers/containers-common/containers-common-0.60.4.ebuild b/app-containers/containers-common/containers-common-0.60.4.ebuild
new file mode 100644
index 000000000000..985ebb5c0ca4
--- /dev/null
+++ b/app-containers/containers-common/containers-common-0.60.4.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit readme.gentoo-r1
+
+DESCRIPTION="Common config files and docs for Containers stack"
+HOMEPAGE="https://github.com/containers/common"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/containers/common.git"
+else
+ SRC_URI="https://github.com/containers/common/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${P#containers-}"
+ KEYWORDS="~amd64 ~arm64 ~loong ~riscv"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+RESTRICT="test"
+RDEPEND="
+ >=app-containers/aardvark-dns-1.12.0
+ >=app-containers/crun-1.17
+ >=app-containers/containers-image-5.32.0
+ >=app-containers/containers-storage-1.55.0
+ app-containers/containers-shortnames
+ >=app-containers/netavark-1.12.0
+ net-firewall/nftables
+ net-firewall/iptables[nftables]
+ >=net-misc/passt-2024.09.06
+ >=sys-fs/fuse-overlayfs-1.14
+"
+
+BDEPEND="
+ >=dev-go/go-md2man-2.0.3
+"
+
+PATCHES=(
+ "${FILESDIR}/examplify-mounts-conf.patch"
+)
+
+DOC_CONTENTS="\n
+For rootless operations, one needs to configure subuid(5) and subgid(5)\n
+See /etc/sub{uid,gid} to check whether rootless user is already configured\n
+If not, quickly configure it with:\n
+usermod --add-subuids 1065536-1131071 <rootless user>\n
+usermod --add-subgids 1065536-1131071 <rootless user>\n
+"
+
+src_prepare() {
+ default
+
+ [[ -f docs/Makefile && -f Makefile ]] || die
+ sed -i -e 's|/usr/local|/usr|g;' docs/Makefile Makefile || die
+}
+
+src_compile() {
+ emake docs
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+ readme.gentoo_create_doc
+
+ insinto /usr/share/containers
+ doins pkg/seccomp/seccomp.json pkg/subscriptions/mounts.conf
+
+ keepdir /etc/containers/certs.d /etc/containers/oci/hooks.d /etc/containers/systemd /var/lib/containers/sigstore
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/app-containers/containers-common/containers-common-9999.ebuild b/app-containers/containers-common/containers-common-9999.ebuild
index deb362fc0d3b..985ebb5c0ca4 100644
--- a/app-containers/containers-common/containers-common-9999.ebuild
+++ b/app-containers/containers-common/containers-common-9999.ebuild
@@ -21,16 +21,16 @@ LICENSE="Apache-2.0"
SLOT="0"
RESTRICT="test"
RDEPEND="
- >=app-containers/aardvark-dns-1.10.0
- >=app-containers/crun-1.14.3
- >=app-containers/containers-image-5.30.0
- >=app-containers/containers-storage-1.53.0
+ >=app-containers/aardvark-dns-1.12.0
+ >=app-containers/crun-1.17
+ >=app-containers/containers-image-5.32.0
+ >=app-containers/containers-storage-1.55.0
app-containers/containers-shortnames
- >=app-containers/netavark-1.10.3
+ >=app-containers/netavark-1.12.0
net-firewall/nftables
net-firewall/iptables[nftables]
- >=net-misc/passt-2024.03.20
- >=sys-fs/fuse-overlayfs-1.13
+ >=net-misc/passt-2024.09.06
+ >=sys-fs/fuse-overlayfs-1.14
"
BDEPEND="