summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-12-17 00:05:58 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-12-17 00:25:56 +0100
commitd29b0d1a6cdd645f5b1ed2c22e3e07185c733521 (patch)
treea1e8f05ed60556d1a386de3a951df08d0f49e62b /app-arch
parentdev-dotnet/dotnet-sdk: filter lto-type-mismatch (diff)
downloadgentoo-d29b0d1a6cdd645f5b1ed2c22e3e07185c733521.tar.gz
gentoo-d29b0d1a6cdd645f5b1ed2c22e3e07185c733521.tar.bz2
gentoo-d29b0d1a6cdd645f5b1ed2c22e3e07185c733521.zip
app-arch/bzip3: bump to 1.5.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/bzip3/Manifest1
-rw-r--r--app-arch/bzip3/bzip3-1.5.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-arch/bzip3/Manifest b/app-arch/bzip3/Manifest
index ae651b30a1be..044efe7c38d7 100644
--- a/app-arch/bzip3/Manifest
+++ b/app-arch/bzip3/Manifest
@@ -1 +1,2 @@
DIST bzip3-1.4.0.tar.xz 278424 BLAKE2B d3e4ae283d3b4512e70ffe3ef63c4ee4fe6f7a0a272aacfe67aae155aed547b54c7e46bce2448b140c7af58ec968b33a1ea7660ffa492bd6bf6eed9fd9f9c4d1 SHA512 584eb77b3071b09c15f20ec88248c9295ca2107107fdcb0495364ac60807c688d167a6cbbdd1b67cc851cbebc0791661ecb44b4d03ca5fb7d2b89ce839452062
+DIST bzip3-1.5.1.tar.xz 284364 BLAKE2B 7d14df6cd649ee86c2c0ca617b49cf0a42fe46f46d512795729ae71642d23d864131e979d4aec7305f31a7af88fc5cfa281aa2709bcd17864d3a786a9b0891e2 SHA512 e74fc3fea9c70f286bacb710301255b304a7acf342dac025331781118238aa69f0e564ab636e6984a10e9b8fa896ce1fba717035d9da1da1a376865fa59c73b7
diff --git a/app-arch/bzip3/bzip3-1.5.1.ebuild b/app-arch/bzip3/bzip3-1.5.1.ebuild
new file mode 100644
index 000000000000..d68cee20c76b
--- /dev/null
+++ b/app-arch/bzip3/bzip3-1.5.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A better and stronger spiritual successor to BZip2"
+HOMEPAGE="https://github.com/kspalaiologos/bzip3"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/kspalaiologos/${PN}.git"
+else
+ SRC_URI="https://github.com/kspalaiologos/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+ KEYWORDS="~amd64 ~arm64 ~loong ~x86"
+fi
+
+LICENSE="LGPL-3+"
+SLOT="0"
+
+src_configure() {
+ # ./configure script will default to Clang if it is found on the system,
+ # force the use of CC selected by the user with CC=$(tc-getCC)
+ econf CC="$(tc-getCC)"
+}
+
+src_install() {
+ default
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}