summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2023-01-14 09:57:17 -0600
committerSam James <sam@gentoo.org>2023-01-14 17:10:02 +0000
commit75180a96ea6c34e3f37b5c623ceeae66119d5bd7 (patch)
tree8080457c3759767832000de91fd8779a70eadef9 /app-arch
parentapp-emacs/osm: new package; add 0.9 (diff)
downloadgentoo-75180a96ea6c34e3f37b5c623ceeae66119d5bd7.tar.gz
gentoo-75180a96ea6c34e3f37b5c623ceeae66119d5bd7.tar.bz2
gentoo-75180a96ea6c34e3f37b5c623ceeae66119d5bd7.zip
app-arch/gzip: remove gzip-reference exec fixups
`gunzip` and `zcat` are shellscripts provided by gzip that redirect to the `gzip` executable (with flags added for the desired behavior). Some development tools, such as bitbake from Yocto Linux, sanitize the PATH to remove `/usr/bin` and `/bin`, but create symlinks for specific tools into a directory that is in the path ('hosttools' for Yocto/bitbake). This means that the original executables (gzip, gunzip zcat) are in the PATH but the new `*-reference` files are not. Remove the fixups from `gunzip` and `zcat` that exec to `gzip-reference` directly and instead let them use the `gzip` (which is likely symlinked to the real `gzip-reference`) directly. Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Closes: https://github.com/gentoo/gentoo/pull/29104 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/gzip/gzip-1.12-r4.ebuild (renamed from app-arch/gzip/gzip-1.12-r3.ebuild)2
-rw-r--r--app-arch/gzip/gzip-1.12_p20221228-r1.ebuild (renamed from app-arch/gzip/gzip-1.12_p20221228.ebuild)2
2 files changed, 0 insertions, 4 deletions
diff --git a/app-arch/gzip/gzip-1.12-r3.ebuild b/app-arch/gzip/gzip-1.12-r4.ebuild
index 652ddbb3151e..acc085235bb1 100644
--- a/app-arch/gzip/gzip-1.12-r3.ebuild
+++ b/app-arch/gzip/gzip-1.12-r4.ebuild
@@ -56,8 +56,6 @@ src_install() {
for x in gunzip gzip zcat; do
mv "${ED}/usr/bin/${x}" "${ED}/bin/${x}-reference" || die
done
- sed -i -e 's:exec gzip:&-reference:' \
- "${ED}"/bin/{gunzip,zcat}-reference || die
mv "${ED}"/usr/share/man/man1/gzip{,-reference}.1 || die
rm "${ED}"/usr/share/man/man1/{gunzip,zcat}.1 || die
}
diff --git a/app-arch/gzip/gzip-1.12_p20221228.ebuild b/app-arch/gzip/gzip-1.12_p20221228-r1.ebuild
index 5e5dd9d96e0a..23e799f74e59 100644
--- a/app-arch/gzip/gzip-1.12_p20221228.ebuild
+++ b/app-arch/gzip/gzip-1.12_p20221228-r1.ebuild
@@ -71,8 +71,6 @@ src_install() {
for x in gunzip gzip zcat; do
mv "${ED}/usr/bin/${x}" "${ED}/bin/${x}-reference" || die
done
- sed -i -e 's:exec gzip:&-reference:' \
- "${ED}"/bin/{gunzip,zcat}-reference || die
mv "${ED}"/usr/share/man/man1/gzip{,-reference}.1 || die
rm "${ED}"/usr/share/man/man1/{gunzip,zcat}.1 || die
}