summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/vault/vault-9999.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/vault/vault-9999.ebuild')
-rw-r--r--app-admin/vault/vault-9999.ebuild97
1 files changed, 97 insertions, 0 deletions
diff --git a/app-admin/vault/vault-9999.ebuild b/app-admin/vault/vault-9999.ebuild
new file mode 100644
index 000000000000..f315b8c60689
--- /dev/null
+++ b/app-admin/vault/vault-9999.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit fcaps git-r3 systemd user
+
+KEYWORDS=""
+DESCRIPTION="A tool for managing secrets"
+HOMEPAGE="https://vaultproject.io/"
+GO_PN="github.com/hashicorp/${PN}"
+EGIT_REPO_URI="git://${GO_PN}.git"
+LICENSE="MPL-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-lang/go-1.4:=
+ dev-go/go-oauth2:="
+RDEPEND=""
+
+SRC_URI=""
+STRIP_MASK="*.a"
+S="${WORKDIR}/src/${GO_PN}"
+EGIT_CHECKOUT_DIR="${S}"
+
+FILECAPS=(
+ -m 755 'cap_ipc_lock=+ei' usr/bin/${PN}
+)
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 -1 ${PN}
+}
+
+src_unpack() {
+ local x
+
+ git-r3_src_unpack
+
+ # Create a writable GOROOT in order to avoid sandbox violations.
+ export GOROOT="${WORKDIR}/goroot"
+ cp -sR "${EPREFIX}"/usr/lib/go "${GOROOT}" || die
+ rm -rf "${GOROOT}/src/${GO_PN}" || die
+
+ export GOPATH=${WORKDIR}:${WORKDIR}/src/github.com/hashicorp/vault/Godeps/_workspace
+
+ while read -r -d '' x; do
+ rm -rf "${GOROOT}/src/${x}" "${GOROOT}/pkg/${KERNEL}_${ARCH}/${x}"{,.a} || die
+ done < <(find "${WORKDIR}/src/github.com/hashicorp/vault/Godeps/_workspace/src" -maxdepth 3 -mindepth 3 -type d -print0)
+
+ rm -rf "${WORKDIR}/src/github.com/hashicorp/vault/Godeps/_workspace/src/github.com/awslabs"
+ go get -d -v -x github.com/awslabs/aws-sdk-go || die
+
+ if ! type -P gox >/dev/null; then
+ pushd "${S}" >/dev/null || die
+ go get -d -v -x github.com/mitchellh/gox || die
+ fi
+}
+
+src_compile() {
+ go install -v -x github.com/awslabs/aws-sdk-go || die
+ if ! type -P gox >/dev/null; then
+ go install -v -x github.com/mitchellh/gox || die
+ fi
+ PATH=${WORKDIR}/bin:${GOROOT}/bin:${PATH} emake dev
+}
+
+src_install() {
+ local x
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}.service"
+
+ keepdir /etc/${PN}.d
+ insinto /etc/${PN}.d
+ doins "${FILESDIR}/"*.json.example
+
+ keepdir /var/log/${PN}
+ fowners ${PN}:${PN} /var/log/${PN}
+
+ dobin bin/${PN}
+ find "${WORKDIR}"/{pkg,src} -name '.git*' -exec rm -rf {} \; 2>/dev/null
+ find "${WORKDIR}"/src/${GO_PN} -mindepth 1 -maxdepth 1 -type f -delete
+ while read -r -d '' x; do
+ x=${x#${WORKDIR}/src}
+ [[ -d ${WORKDIR}/pkg/${KERNEL}_${ARCH}/${x} ||
+ -f ${WORKDIR}/pkg/${KERNEL}_${ARCH}/${x}.a ]] && continue
+ rm -rf "${WORKDIR}"/src/${x}
+ done < <(find "${WORKDIR}"/src/${GO_PN} -mindepth 1 -maxdepth 1 -type d -print0)
+ insopts -m0644 -p # preserve timestamps for bug 551486
+ insinto /usr/lib/go/pkg/${KERNEL}_${ARCH}/${GO_PN%/*}
+ doins -r "${WORKDIR}"/pkg/${KERNEL}_${ARCH}/${GO_PN}
+ insinto /usr/lib/go/src/${GO_PN%/*}
+ doins -r "${WORKDIR}"/src/${GO_PN}
+}