summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-04-02 15:22:43 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-04-02 15:23:52 -0500
commit70ebbb02d3a18c7c44abf75f815356cb61577392 (patch)
tree00ae87c5802e519852765e6f76018371456d096c /app-admin/terraform/terraform-1.1.7.ebuild
parentxorg-3.eclass: Unset GIT_ECLASS later (diff)
downloadgentoo-70ebbb02d3a18c7c44abf75f815356cb61577392.tar.gz
gentoo-70ebbb02d3a18c7c44abf75f815356cb61577392.tar.bz2
gentoo-70ebbb02d3a18c7c44abf75f815356cb61577392.zip
app-admin/terraform: add 1.1.7
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-admin/terraform/terraform-1.1.7.ebuild')
-rw-r--r--app-admin/terraform/terraform-1.1.7.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-admin/terraform/terraform-1.1.7.ebuild b/app-admin/terraform/terraform-1.1.7.ebuild
new file mode 100644
index 000000000000..3b98b8a98fb3
--- /dev/null
+++ b/app-admin/terraform/terraform-1.1.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="A tool for building, changing, and combining infrastructure safely"
+HOMEPAGE="https://www.terraform.io/"
+SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 MPL-2.0 MIT ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="test"
+
+DOCS=( {README,CHANGELOG}.md )
+
+src_compile() {
+ ego build
+}
+
+src_install() {
+ dobin terraform
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "If you would like to install shell completions please run:"
+ elog " terraform -install-autocomplete"
+}