summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2019-07-24 17:33:58 +0200
committerSebastian Pipping <sping@gentoo.org>2019-07-24 17:38:32 +0200
commit6aa766dcc79dab122ce43be0beb296050d8b421d (patch)
tree21b4ecf714c80b01b8ea50d52e97a1435d6fb544 /app-admin/checksec/checksec-2.0.1.ebuild
parentdev-ruby/puppetdb-termini: 6.5.0 bump (diff)
downloadgentoo-6aa766dcc79dab122ce43be0beb296050d8b421d.tar.gz
gentoo-6aa766dcc79dab122ce43be0beb296050d8b421d.tar.bz2
gentoo-6aa766dcc79dab122ce43be0beb296050d8b421d.zip
app-admin/checksec: 2.0.1
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.68, Repoman-2.3.16
Diffstat (limited to 'app-admin/checksec/checksec-2.0.1.ebuild')
-rw-r--r--app-admin/checksec/checksec-2.0.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-admin/checksec/checksec-2.0.1.ebuild b/app-admin/checksec/checksec-2.0.1.ebuild
new file mode 100644
index 000000000000..3dd38365d970
--- /dev/null
+++ b/app-admin/checksec/checksec-2.0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+MY_PN=${PN}.sh
+DESCRIPTION="Tool to check properties of executables (e.g. ASLR/PIE, RELRO, PaX, Canaries)"
+HOMEPAGE="https://github.com/slimm609/checksec.sh"
+SRC_URI="https://github.com/slimm609/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~x86"
+IUSE=""
+
+S="${WORKDIR}"/${MY_PN}-${PV}
+
+DOCS=( ChangeLog README.md )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.7.2-path.patch
+)
+
+src_prepare() {
+ sed 's,^pkg_release=false,pkg_release=true,' -i ${PN} || die
+ default
+}
+
+src_install() {
+ default
+
+ doman extras/man/*
+
+ insinto /usr/share/zsh/site-functions
+ doins extras/zsh/_${PN}
+
+ dobin ${PN}
+}