summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-30 19:49:40 +0200
committerMichał Górny <mgorny@gentoo.org>2022-03-30 20:45:42 +0200
commit123df62470394978b5e1aa7bc2bebf15355c0764 (patch)
treee5fc03c4ac03e56004c98e2e12d24463a397b834 /app-admin/awscli
parentdev-python/boto3: Bump to 1.21.29 (diff)
downloadgentoo-123df62470394978b5e1aa7bc2bebf15355c0764.tar.gz
gentoo-123df62470394978b5e1aa7bc2bebf15355c0764.tar.bz2
gentoo-123df62470394978b5e1aa7bc2bebf15355c0764.zip
app-admin/awscli: Bump to 1.22.84
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin/awscli')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.22.84.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 8a6d06e87ea3..37b3f5ba9be4 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -5,3 +5,4 @@ DIST awscli-1.22.80.tar.gz 2182289 BLAKE2B 632aa3806ffc6924b9d359f437b89f4c49406
DIST awscli-1.22.81.tar.gz 2182494 BLAKE2B 57f62fc372f065f7b7c3a7b7b4fe32fed1bdb439d2abb8070d0383bede89ece50016b92ecd48c0b6b9b258a56843a0989bca63c49f41923b702b38c5d5a09daf SHA512 ef2b452ac579730eb37796b55e3214df10df54307c826773f4c8334270eb08d1d72a5de468c1e058ce72cc92c93e913c8d9e764b74af0fc35ba078b190af5364
DIST awscli-1.22.82.tar.gz 2182473 BLAKE2B 0d73e62f7c394c1ac77f6b011e2303d9b48b8fd6d874360aef6b2fc4378feb8f9fa04b88e9c1ee8cf0cb5fb7d1884d4a08eee64093c151de274c1aa50777ebf3 SHA512 195061199fa3ed24b5be2a22a5d0ee2891bfb616239aaf54e5aa8715b3374e68edad613ea6e6b71a165e501b5a009856993259de3ac57f14ff3cd2a39453ec38
DIST awscli-1.22.83.tar.gz 2182511 BLAKE2B 45e4868e83d130bee6c5a7cb59792d4d66e76d3c1ac14a5c99f49f3f93461970ba881a515b4816374baea81250733d061a8618ca8244b9fb4bbd289b67b0c7fd SHA512 dc24134650aceb45e035d6009cafd353aef9cf08a8db00d7bdfa4e7a0056bcf3ded50b94086fae8ca70ff349cf880ad75ef756748f8f70d84b2bb5397d6685bd
+DIST awscli-1.22.84.tar.gz 2182437 BLAKE2B 0b61b6d96da302c95c83bdeedfa14abbcacb1cb3f1a320faa8ca2ee275e43407c0c109c73b7e39879002a920a100a9808fd74582b0620b97534a8eb0deef54a2 SHA512 14054f90c0d4e000869bd6313f61241a736474faf79b8e5768f5e0aadf7230fc6c8441f5c332a1ee4dc22e0023416713d89cde96a4fff4d83ab6826748aaff53
diff --git a/app-admin/awscli/awscli-1.22.84.ebuild b/app-admin/awscli/awscli-1.22.84.ebuild
new file mode 100644
index 000000000000..2040c8cb81d2
--- /dev/null
+++ b/app-admin/awscli/awscli-1.22.84.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="https://pypi.org/project/awscli/"
+#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/aws/aws-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/aws-cli-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# awscli 1.22.55 → botocore 1.24.0
+# so botocore is x.(y+2).(z-55)
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(( $(ver_cut 3-) - 55))"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.4.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}