summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-11-17 18:03:34 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-11-17 19:39:24 +0100
commitd1a72f7f436789219b86f2e51cf0c67359e97e9b (patch)
tree98f303aab5b39eef7c09c3c9ef5b815fb53494b2
parentkde-apps/kdepim-runtime: Drop 18.08.3 (r0) (diff)
downloadgentoo-d1a72f7f436789219b86f2e51cf0c67359e97e9b.tar.gz
gentoo-d1a72f7f436789219b86f2e51cf0c67359e97e9b.tar.bz2
gentoo-d1a72f7f436789219b86f2e51cf0c67359e97e9b.zip
dev-libs/appstream: 0.12.3 version bump
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-libs/appstream/Manifest1
-rw-r--r--dev-libs/appstream/appstream-0.12.3.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-libs/appstream/Manifest b/dev-libs/appstream/Manifest
index ee36d2e416fb..a2335c84eef7 100644
--- a/dev-libs/appstream/Manifest
+++ b/dev-libs/appstream/Manifest
@@ -1,3 +1,4 @@
DIST AppStream-0.12.2.tar.xz 1938868 BLAKE2B 968853e9d5f87ca2c1f894a6ffe5439f7fce611459243cd96d3859a15e225243585a1a43e90d8eca8271b91e1237d94eb4615b5c3c0543d9a37646b5fbd7d2fe SHA512 d5c95309d4fddb961f4a5b9ac460840e34d4bae0e256bd0be09ceeab0d45a3ac5254c9e9c183a1e6cb3983ce0a9d6d0e519908f612a5b135ed578ec26556e53d
+DIST AppStream-0.12.3.tar.xz 1940064 BLAKE2B a0160c4a922abfe315bdbfe6b7b32fea8d5eda5631347be4a39dcf102660ad26a3f40c5fed9dd0bdfb1b91956780ff7cf58e61d7f38b03d2f48a5bf67f2871f6 SHA512 3d54bb499e4056d341ffde2878549011708e6699b3ec58756ef2e4080864279ff5e5003224fcbad601007fd9296bb9ed062da7843e3e02272837ecc5d4c802f9
DIST appstream-0.10.6.tar.gz 1821879 BLAKE2B 49e0476ef41c37d2e9bb12a7c046fcbb2cd8fcb1f521321dce4cda15e504a966cf59a1cbf56fc7359a82f677c54906ba041ad37eeb7f639ad69691e8d2ccd24c SHA512 9f8b4ddc39d580c62b166df0d9a2c5e4caac1b433d25a4e9118b7c73ceea5c7b1ff78f02d682a68cdfeb8da29e806a4838cfc11637fca2982f436af333605256
DIST appstream-0.11.5.tar.gz 1856204 BLAKE2B 9f1e423e71e40b569cae0fb259bf5a0203a0abcba64f877c951c941f1dfdbc8005509ca46040586b8937cc168ad9315978dd2a3763592de1686c9648eac6c928 SHA512 308f65df2d03f09a5fdfe1d5b61ed37ddfd73a6f7cd861f685463c45ba17a2a937ba34216b4d5f533cb5f9f56c65ff9b261e03d07aaab74bec3f89e5bfb57d7b
diff --git a/dev-libs/appstream/appstream-0.12.3.ebuild b/dev-libs/appstream/appstream-0.12.3.ebuild
new file mode 100644
index 000000000000..f2aa30c08f78
--- /dev/null
+++ b/dev-libs/appstream/appstream-0.12.3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit meson xdg-utils
+
+if [[ ${PV} = 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ximion/${PN}"
+else
+ MY_PN="AppStream"
+ SRC_URI="https://www.freedesktop.org/software/appstream/releases/${MY_PN}-${PV}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+DESCRIPTION="Cross-distro effort for providing metadata for software in the Linux ecosystem"
+HOMEPAGE="https://www.freedesktop.org/wiki/Distributions/AppStream/"
+
+LICENSE="LGPL-2.1+ GPL-2+"
+# check as_api_level
+SLOT="0/4"
+IUSE="apt +introspection qt5 test"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/libxml2:2
+ dev-libs/libyaml
+ dev-libs/snowball-stemmer
+ introspection? ( >=dev-libs/gobject-introspection-1.56:= )
+ qt5? ( dev-qt/qtcore:5 )
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.5
+ dev-libs/appstream-glib
+ dev-util/itstool
+ >=dev-util/meson-0.42.0
+ >=sys-devel/gettext-0.19.8
+ qt5? (
+ dev-qt/linguist-tools:5
+ test? ( dev-qt/qttest:5 )
+ )
+"
+
+src_prepare() {
+ default
+ sed -e "/^as_doc_target_dir/s/appstream/${PF}/" -i docs/meson.build || die
+}
+
+src_configure() {
+ xdg_environment_reset
+
+ local emesonargs=(
+ -Dapidocs=false
+ -Ddocs=false
+ -Dmaintainer=false
+ -Dstemming=true
+ -Dvapi=false
+ -Dapt-support=$(usex apt true false)
+ -Dgir=$(usex introspection true false)
+ -Dqt=$(usex qt5 true false)
+ )
+
+ meson_src_configure
+}