summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2024-03-06 08:41:42 -0800
committerZac Medico <zmedico@gentoo.org>2024-03-06 08:42:43 -0800
commitc25c55d31b964dd460c38ef1d1079d4abe36321e (patch)
tree06bf905113142149b30b84e00406fd3fc84f68d8
parentsys-kernel/dkms: add 3.0.13 (diff)
downloadgentoo-c25c55d31b964dd460c38ef1d1079d4abe36321e.tar.gz
gentoo-c25c55d31b964dd460c38ef1d1079d4abe36321e.tar.bz2
gentoo-c25c55d31b964dd460c38ef1d1079d4abe36321e.zip
app-misc/jpipe: enable PEP517 build
Closes: https://bugs.gentoo.org/909882 Signed-off-by: Zac Medico <zmedico@gentoo.org>
-rw-r--r--app-misc/jpipe/jpipe-0.2.0-r1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/app-misc/jpipe/jpipe-0.2.0-r1.ebuild b/app-misc/jpipe/jpipe-0.2.0-r1.ebuild
index ada99312a317..850a03389239 100644
--- a/app-misc/jpipe/jpipe-0.2.0-r1.ebuild
+++ b/app-misc/jpipe/jpipe-0.2.0-r1.ebuild
@@ -1,10 +1,11 @@
-# Copyright 2021-2023 Gentoo Authors
+# Copyright 2021-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
GO_OPTIONAL=1
DISTUTILS_OPTIONAL=1
PYTHON_COMPAT=( python3_{9,10,11} )
+DISTUTILS_USE_PEP517=setuptools
inherit go-module distutils-r1 pypi
@@ -40,6 +41,8 @@ RDEPEND="
)
"
+distutils_enable_tests pytest
+
src_unpack() {
if use python; then
default