summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-11-11 16:04:22 +0100
committerMichał Górny <mgorny@gentoo.org>2017-11-11 16:07:28 +0100
commit7c9feafd05d62ac42c8cafb3b82fcc7e7623f083 (patch)
treefdc0573513e138e9975e5ea21d8a663370b09ea7
parentdev-python/pypy: Inline deps and include dev-python/pycparser dep (diff)
downloadgentoo-7c9feafd05d62ac42c8cafb3b82fcc7e7623f083.tar.gz
gentoo-7c9feafd05d62ac42c8cafb3b82fcc7e7623f083.tar.bz2
gentoo-7c9feafd05d62ac42c8cafb3b82fcc7e7623f083.zip
dev-python/pypy3: Inline deps and include dev-python/pycparser dep
Replace the autogenerated || dependency with an inlined version, and include dev-python/pycparser in it when using CPython 2.7 (it is built-in in dev-python/pypy, through CFFI).
-rw-r--r--dev-python/pypy3/pypy3-5.9.0.ebuild12
-rw-r--r--dev-python/pypy3/pypy3-9999.ebuild12
2 files changed, 20 insertions, 4 deletions
diff --git a/dev-python/pypy3/pypy3-5.9.0.ebuild b/dev-python/pypy3/pypy3-5.9.0.ebuild
index 68ba1a3ef97c..d81c5775b403 100644
--- a/dev-python/pypy3/pypy3-5.9.0.ebuild
+++ b/dev-python/pypy3/pypy3-5.9.0.ebuild
@@ -35,8 +35,16 @@ RDEPEND=">=sys-libs/zlib-1.1.3:0=
)
!dev-python/pypy3-bin:0"
DEPEND="${RDEPEND}
- low-memory? ( virtual/pypy:0 )
- !low-memory? ( ${PYTHON_DEPS} )"
+ low-memory? ( virtual/pypy )
+ !low-memory? (
+ || (
+ virtual/pypy
+ (
+ dev-lang/python:2.7
+ dev-python/pycparser[python_targets_python2_7(-),python_single_target_python2_7(+)]
+ )
+ )
+ )"
# doc? ( dev-python/sphinx )
S="${WORKDIR}/${MY_P}-src"
diff --git a/dev-python/pypy3/pypy3-9999.ebuild b/dev-python/pypy3/pypy3-9999.ebuild
index 92c2f84f5b09..5be752f1fc4c 100644
--- a/dev-python/pypy3/pypy3-9999.ebuild
+++ b/dev-python/pypy3/pypy3-9999.ebuild
@@ -36,8 +36,16 @@ RDEPEND=">=sys-libs/zlib-1.1.3:0=
)
!dev-python/pypy3-bin:0"
DEPEND="${RDEPEND}
- low-memory? ( virtual/pypy:0 )
- !low-memory? ( ${PYTHON_DEPS} )"
+ low-memory? ( virtual/pypy )
+ !low-memory? (
+ || (
+ virtual/pypy
+ (
+ dev-lang/python:2.7
+ dev-python/pycparser[python_targets_python2_7(-),python_single_target_python2_7(+)]
+ )
+ )
+ )"
# doc? ( dev-python/sphinx )
# Who would care about predictable directory names?