summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-05 04:35:52 +0000
committerSam James <sam@gentoo.org>2022-12-05 04:35:52 +0000
commit5e288b5eef64b3cb8d6fae135f98b88cb09109f1 (patch)
treec4245bb7a564257eb8b42cdd9b64b9c86f40a885
parentapp-editors/gvim: add 9.0.1000 (diff)
downloadgentoo-5e288b5eef64b3cb8d6fae135f98b88cb09109f1.tar.gz
gentoo-5e288b5eef64b3cb8d6fae135f98b88cb09109f1.tar.bz2
gentoo-5e288b5eef64b3cb8d6fae135f98b88cb09109f1.zip
app-editors/vim: use latest patchset (Perl fix)
Use latest vim-patches for Perl highlighting fix. Should be no functional change as it only matters in vim-core. Closes: https://bugs.gentoo.org/881385 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-editors/vim/Manifest1
-rw-r--r--app-editors/vim/vim-9.0.1000.ebuild6
-rw-r--r--app-editors/vim/vim-9999.ebuild7
3 files changed, 9 insertions, 5 deletions
diff --git a/app-editors/vim/Manifest b/app-editors/vim/Manifest
index be91e4d6c4ee..314cfce6aed3 100644
--- a/app-editors/vim/Manifest
+++ b/app-editors/vim/Manifest
@@ -4,3 +4,4 @@ DIST vim-9.0.0655.tar.gz 16804127 BLAKE2B e021ff4dd370cdd9b39fb9df0a12309215abd7
DIST vim-9.0.0828.tar.gz 16782339 BLAKE2B 6b997c1c828338d64a8b204a1e232676ec075834b1b7e74c2fc671e315f9bf6026b0c419ebb3c31e7ce58dbca23828ca11d866b2bfcb73f8a86fb31fa0d51b00 SHA512 03f93515039a2f275a8fe6b84bbac5875ffff17768ab3201e111eba4897a2485fe4ccfe238151f393334c7a6ea77eddd8898f0b816e26dbdb884f4e6bcbd2943
DIST vim-9.0.1000.tar.gz 16842747 BLAKE2B 85edab7d13daa3e84ef0aeb50e3e9bfd31f0634d8e480c105727b0c34318e0adf7f1276dcdac53df8fc416fd8dfb70377cd74ed570752a3e77f07a083fa6c113 SHA512 9d2b914a112948d77b92c8dcafc2f711a83c3fdaf35a28f7f606e77007b9320e2260a0f6b24fc875a817c33c012f077f89730b34e9f12d6f00795c5c806704c8
DIST vim-patches-vim-9.0.0049-patches.tar.gz 2743 BLAKE2B dff3e215b235e1cbc2c62b1af2d1414d10b794dbee9f5e7797fb3d34e00c2e065c339d4c82bf28aed53e0b5f2f8f1ee5c7ce69851cd63360788609bf144ac922 SHA512 7d5c64d674fa77048fdca7287072c0e488723133e254c10711dbadf750416c368725327ca9b76f332017bc70aa544a9baef671765eabf0d172d39921ffd7d942
+DIST vim-patches-vim-9.0.1000-patches.tar.bz2 3245 BLAKE2B 3bf3d0e314cc3f96d5d9675de196a62c4c8a72645d56ef94b80768571c99cba5cc556442e3bd2dfa8818460fd851fe7bd1ae15999af7225fb271b81c43105843 SHA512 2883441a2001bf7ce89a7f0862f780b71cc0164c8fcb8dbdf7040e1bcbcf408d138d3d77f308aa54c762e9975fa5ec89cfceeabbf721344dfc938870a363667a
diff --git a/app-editors/vim/vim-9.0.1000.ebuild b/app-editors/vim/vim-9.0.1000.ebuild
index 24d8c29f3e54..fd6fe05780b0 100644
--- a/app-editors/vim/vim-9.0.1000.ebuild
+++ b/app-editors/vim/vim-9.0.1000.ebuild
@@ -6,6 +6,8 @@ EAPI=8
# Please bump with app-editors/vim-core and app-editors/gvim
VIM_VERSION="9.0"
+VIM_PATCHES_VERSION="9.0.1000"
+
LUA_COMPAT=( lua5-{1..4} luajit )
PYTHON_COMPAT=( python3_{8..11} )
PYTHON_REQ_USE="threads(+)"
@@ -18,7 +20,7 @@ if [[ ${PV} == 9999* ]] ; then
EGIT_REPO_URI="https://github.com/vim/vim.git"
else
SRC_URI="https://github.com/vim/vim/archive/v${PV}.tar.gz -> ${P}.tar.gz
- https://gitweb.gentoo.org/proj/vim-patches.git/snapshot/vim-patches-vim-9.0.0049-patches.tar.gz"
+ https://gitweb.gentoo.org/proj/vim-patches.git/snapshot/vim-patches-vim-${VIM_PATCHES_VERSION}-patches.tar.bz2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
@@ -78,7 +80,7 @@ pkg_setup() {
src_prepare() {
if [[ ${PV} != 9999* ]] ; then
# Gentoo patches to fix runtime issues, cross-compile errors, etc
- eapply "${WORKDIR}"/vim-patches-vim-9.0.0049-patches
+ eapply "${WORKDIR}"/vim-patches-vim-${VIM_PATCHES_VERSION}-patches
fi
# Fixup a script to use awk instead of nawk
diff --git a/app-editors/vim/vim-9999.ebuild b/app-editors/vim/vim-9999.ebuild
index f9e1c2239e75..fd6fe05780b0 100644
--- a/app-editors/vim/vim-9999.ebuild
+++ b/app-editors/vim/vim-9999.ebuild
@@ -6,6 +6,8 @@ EAPI=8
# Please bump with app-editors/vim-core and app-editors/gvim
VIM_VERSION="9.0"
+VIM_PATCHES_VERSION="9.0.1000"
+
LUA_COMPAT=( lua5-{1..4} luajit )
PYTHON_COMPAT=( python3_{8..11} )
PYTHON_REQ_USE="threads(+)"
@@ -18,7 +20,7 @@ if [[ ${PV} == 9999* ]] ; then
EGIT_REPO_URI="https://github.com/vim/vim.git"
else
SRC_URI="https://github.com/vim/vim/archive/v${PV}.tar.gz -> ${P}.tar.gz
- https://gitweb.gentoo.org/proj/vim-patches.git/snapshot/vim-patches-vim-9.0.0049-patches.tar.gz"
+ https://gitweb.gentoo.org/proj/vim-patches.git/snapshot/vim-patches-vim-${VIM_PATCHES_VERSION}-patches.tar.bz2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
@@ -76,10 +78,9 @@ pkg_setup() {
}
src_prepare() {
-
if [[ ${PV} != 9999* ]] ; then
# Gentoo patches to fix runtime issues, cross-compile errors, etc
- eapply "${WORKDIR}"/vim-patches-vim-9.0.0049-patches
+ eapply "${WORKDIR}"/vim-patches-vim-${VIM_PATCHES_VERSION}-patches
fi
# Fixup a script to use awk instead of nawk