summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2024-12-29 03:33:13 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2024-12-29 03:33:13 +0000
commitea81bac61426ab8dcc69255b73674a2bae364975 (patch)
tree0896e4b4369b14baf4eb2930289a8c8b23f3d861
parent2024-12-29 02:48:24 UTC (diff)
parentdev-python/slixmpp: Bump to 1.8.6 (diff)
downloadgentoo-ea81bac61426ab8dcc69255b73674a2bae364975.tar.gz
gentoo-ea81bac61426ab8dcc69255b73674a2bae364975.tar.bz2
gentoo-ea81bac61426ab8dcc69255b73674a2bae364975.zip
Merge updates from master
-rw-r--r--dev-libs/libgit2/Manifest1
-rw-r--r--dev-libs/libgit2/libgit2-1.9.0.ebuild72
-rw-r--r--dev-python/inflect/Manifest1
-rw-r--r--dev-python/inflect/inflect-7.5.0.ebuild29
-rw-r--r--dev-python/nuitka/Manifest3
-rw-r--r--dev-python/nuitka/nuitka-2.5.7.ebuild55
-rw-r--r--dev-python/nuitka/nuitka-2.5.9.ebuild (renamed from dev-python/nuitka/nuitka-2.5.6.ebuild)0
-rw-r--r--dev-python/path/Manifest1
-rw-r--r--dev-python/path/path-17.1.0.ebuild37
-rw-r--r--dev-python/slixmpp/Manifest1
-rw-r--r--dev-python/slixmpp/slixmpp-1.8.6.ebuild52
-rw-r--r--dev-python/starlette/Manifest1
-rw-r--r--dev-python/starlette/starlette-0.44.0.ebuild57
-rw-r--r--llvm-core/clang-runtime/clang-runtime-19.1.6-r1.ebuild16
-rw-r--r--llvm-core/clang-runtime/clang-runtime-20.0.0.9999.ebuild16
-rw-r--r--profiles/package.mask6
16 files changed, 261 insertions, 87 deletions
diff --git a/dev-libs/libgit2/Manifest b/dev-libs/libgit2/Manifest
index 6f9c927d1955..0de0ebf9859e 100644
--- a/dev-libs/libgit2/Manifest
+++ b/dev-libs/libgit2/Manifest
@@ -1,3 +1,4 @@
DIST libgit2-1.7.2.tar.gz 7548186 BLAKE2B c27870124c7e63a37794014a802a6fce46c577313f3b6081580f920fa842a65305b5bc56aa6ab02cf87c533d6052afdc37317f96aa1fd67387b07f52415ccbe3 SHA512 825737e4a1991fba50ea535f15b0e560ebe76ead752e04aeba36925b944d0da77fe9826a70980a1aa3d0bf9afbedfab79dd92e799c9252931384c89ebec9b012
DIST libgit2-1.8.1.tar.gz 7608949 BLAKE2B 14558400d092dd963becfd3d4966a8d0799811be15fea8c5bc1e91be24f14bb81d33d82b2fb8dd8895e167f634a5d532d62a4609167bcb1d93143275207bbf6d SHA512 7429fbdc46ae44fd359e9260cbe33d9ce9276db810c096f12c43e5d302d01011463cdfd98d604e59780187e020e216e839823a77479dc12f952a37628516af78
DIST libgit2-1.8.4.tar.gz 7610171 BLAKE2B 5a6fd422bba7f65b220b0c98bb851f79ec7d6173c3f34ebbdcfe12398e1a138af346da592bedfc52c99b39c8c28ef52d6e9244ec653b8b2f01732f2b1b4e35d2 SHA512 f1409d97c8cf072ea24f3d923fdc9468d21f171f72005c13c5358f520fdccb5f3950d1c7c16cea48a8a08df6a57280da46fe60c9b6aa8a8aae2ab1363c41d246
+DIST libgit2-1.9.0.tar.gz 7660744 BLAKE2B c81beab379bd78a66d28a48600527979a6c51d33f946df1f996f52ac274cadc88f7afb8c90683f584300941a214bc69389412fb6c9be3b48d22c708b41ca0e1d SHA512 38547ace676b933a3146c2a00405fc6815063a7af923b9f2c09c536ec717be77d19c513b383939054913ce617d7917c100a5cbd3378d101fcdb5eacd1d14f687
diff --git a/dev-libs/libgit2/libgit2-1.9.0.ebuild b/dev-libs/libgit2/libgit2-1.9.0.ebuild
new file mode 100644
index 000000000000..2633d8d6db71
--- /dev/null
+++ b/dev-libs/libgit2/libgit2-1.9.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit cmake flag-o-matic python-any-r1
+
+DESCRIPTION="A linkable library for Git"
+HOMEPAGE="https://libgit2.org/"
+SRC_URI="
+ https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+"
+S=${WORKDIR}/${P/_/-}
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="examples gssapi +ssh test +threads trace"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/libpcre2:=
+ net-libs/llhttp:=
+ sys-libs/zlib
+ dev-libs/openssl:0=
+ gssapi? ( virtual/krb5 )
+ ssh? ( net-libs/libssh2 )
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTS=$(usex test)
+ -DUSE_SSH=$(usex ssh libssh2 OFF)
+ -DUSE_GSSAPI=$(usex gssapi ON OFF)
+ -DUSE_HTTP_PARSER=llhttp
+ -DREGEX_BACKEND=pcre2
+ )
+ # https://bugs.gentoo.org/925207
+ append-lfs-flags
+ cmake_src_configure
+}
+
+src_test() {
+ if [[ ${EUID} -eq 0 ]] ; then
+ # repo::iterator::fs_preserves_error fails if run as root
+ # since root can still access dirs with 0000 perms
+ ewarn "Skipping tests: non-root privileges are required for all tests to pass"
+ else
+ local TEST_VERBOSE=1
+ cmake_src_test -R offline
+ fi
+}
+
+src_install() {
+ cmake_src_install
+ dodoc docs/*.{md,txt}
+
+ if use examples ; then
+ find examples -name '.gitignore' -delete || die
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-python/inflect/Manifest b/dev-python/inflect/Manifest
index 24725cc7ddaf..c8fd4f91ac05 100644
--- a/dev-python/inflect/Manifest
+++ b/dev-python/inflect/Manifest
@@ -1 +1,2 @@
DIST inflect-7.4.0.tar.gz 72730 BLAKE2B eaaaa46a1f710f5b05165f3f894eb5a2437908299146369a2537a675a1d50facba56c7a9efa2e459b7cfb95a4f2c5f615d64948fb278a4a990423b40414f701a SHA512 fe3658a2f4c9303db90604268a525112c6a67f66ed37f6fbe76cd04a008658362e682413297dc1fcae6e6a0415098f3adaf0f205b781e1e24a050f59c9dc9021
+DIST inflect-7.5.0.tar.gz 73751 BLAKE2B a17c5cb5bfcd10530f29537335ffd1b4725fb1f53e78ef7ce1f40a3031fa486baae3400878e575c8ce6a77b4953332f051ec65dcba024a14c527301e51079edb SHA512 ee9f69dff451017a2aad2226d8c6ae02b4b7b4bc4d4c49f3efee50d85eeef43c49c6c6ef3e7f30fa2c5ef21e065ff5242140d5a98bc71af17c7e70d9e75e54c1
diff --git a/dev-python/inflect/inflect-7.5.0.ebuild b/dev-python/inflect/inflect-7.5.0.ebuild
new file mode 100644
index 000000000000..d1cdcca00005
--- /dev/null
+++ b/dev-python/inflect/inflect-7.5.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Correctly inflect words and numbers"
+HOMEPAGE="
+ https://pypi.org/project/inflect/
+ https://github.com/jaraco/inflect/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ >=dev-python/typeguard-4.0.1[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-8.5.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-3.4.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/nuitka/Manifest b/dev-python/nuitka/Manifest
index 5b9b3a564792..e223dfa8e11a 100644
--- a/dev-python/nuitka/Manifest
+++ b/dev-python/nuitka/Manifest
@@ -1,3 +1,2 @@
-DIST Nuitka-2.5.6.tar.gz 3776178 BLAKE2B f19d777820be2e097c787252842721d06be1a4f3bf8ae298c94d9772f1b2f11baff835b1fb610fd42549911b48c42ee0d2ea7ad9afbf5c3f0e137d1c5ec85603 SHA512 cec3801cc8d30d149f3057d65286d7169378c0e9717a8abd142ab6e4ee5411982688ac43876ca3d94b993ed0f2d14d8e315a8d786f2ecb6ca2c2edf96628ec00
-DIST Nuitka-2.5.7.tar.gz 3779250 BLAKE2B 5035fb52c85302d2877815be280bb3da40eca1ecc4e9608d038ff1960ed549a7525a0aa126758df2db35aca5549000d9ee343f144fe3c1a79fec04488393dc08 SHA512 1bd8ff4bed740c9ff2932e00d4f3f116c3c3496ca214f6563eb4aeaf44dd007783005eb0030e9b9a4b8ab21481883f33039893342ef62659d3a3e7ad54bea9c9
DIST Nuitka-2.5.8.tar.gz 3777360 BLAKE2B 77a7c4cb3b71c6e0d5ae5fc3467c75afa4374593a187312ddb7caf54053eca9dbd17744c323b55954699e491fd28810b660ea44c2b25aa69d2b595000fb0ab11 SHA512 024d32b28e312baff1a68e654a78c4581ad09dace681202d0077c46c2d9117f7666a87288a5cc1005604fd535ce0ae8409c2002b37694edab95788b38fcee30c
+DIST Nuitka-2.5.9.tar.gz 3777278 BLAKE2B 1140c02c0f204f70d6646efcf88178a59cd6ad4c7848855711a0ca7462f5e173f2260f7106552e785120c8f0f1926b45f459047b0053a6a1718ae793829c9232 SHA512 ef3645d9ed35579c2021c185418eb8e1a78390b80b88669e271703fd04910ee5e8d2203ef3c3dddc432bf5ab4f51f2ecb4d8b6c60c3ac02dc43545ce32c01606
diff --git a/dev-python/nuitka/nuitka-2.5.7.ebuild b/dev-python/nuitka/nuitka-2.5.7.ebuild
deleted file mode 100644
index d79d86fa299c..000000000000
--- a/dev-python/nuitka/nuitka-2.5.7.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYPI_PN=${PN^}
-PYTHON_COMPAT=( python3_{10..13} )
-
-inherit distutils-r1 flag-o-matic optfeature pypi
-
-DESCRIPTION="Python to native compiler"
-HOMEPAGE="
- https://nuitka.net/
- https://github.com/Nuitka/Nuitka/
- https://pypi.org/project/Nuitka/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~loong ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-build/scons[${PYTHON_USEDEP}]
- >=dev-python/ordered-set-4.1.0[${PYTHON_USEDEP}]
- >=dev-python/zstandard-0.15[${PYTHON_USEDEP}]
-"
-BDEPEND="
- ${RDEPEND}
- test? ( dev-util/ccache )
-"
-
-distutils-r1_src_prepare() {
- # remove vendored version of SCons that is Python2 only
- # this should be removed when upstream removes support for Python2
- rm -vR "nuitka/build/inline_copy/lib/scons-2.3.2/SCons" || die
- eapply_user
-}
-
-python_install() {
- distutils-r1_python_install
- doman doc/nuitka.1 doc/nuitka-run.1
-}
-
-python_test() {
- append-ldflags -Wl,--no-warn-search-mismatch
- ./tests/basics/run_all.py search || die
-}
-
-pkg_postinst() {
- optfeature "support for stand-alone executables" dev-util/patchelf
-}
diff --git a/dev-python/nuitka/nuitka-2.5.6.ebuild b/dev-python/nuitka/nuitka-2.5.9.ebuild
index d79d86fa299c..d79d86fa299c 100644
--- a/dev-python/nuitka/nuitka-2.5.6.ebuild
+++ b/dev-python/nuitka/nuitka-2.5.9.ebuild
diff --git a/dev-python/path/Manifest b/dev-python/path/Manifest
index 0c4a59b049be..665696a8d3f4 100644
--- a/dev-python/path/Manifest
+++ b/dev-python/path/Manifest
@@ -1 +1,2 @@
DIST path-17.0.0.tar.gz 49721 BLAKE2B eb25e41c5fd5a269023dbdf331a1abb4228707f8b2ca8e4523fabd749fe7c76dc564ea18dd1d9ee4af085bfe72a47400c2bd21c8235af8654998bbefbeb87512 SHA512 9e2e6d51f32f6380d944006fc618d41fb6136d878b758a10a81b3cee5b3e11e5330fba3cc88b0f185c4244aa38f338a32f49685da733539e2cf1cd281ed65412
+DIST path-17.1.0.tar.gz 50081 BLAKE2B ed3c87658cd65ff84e6283967d3d91c19f81bc462452592410fef6c86b576cba25584e55c02243dcad36a36ba5bfbe3086b8c427591f94fa32dcfcaab3e98ec0 SHA512 af369767442780c69ae73006f4a18aa2ca15a67718a482190bf0035352473ac2fdae7aa6dd017c9fec075cdd916f42768db16f8f40ebcd68861baaa47f115305
diff --git a/dev-python/path/path-17.1.0.ebuild b/dev-python/path/path-17.1.0.ebuild
new file mode 100644
index 000000000000..72968c7f7bdb
--- /dev/null
+++ b/dev-python/path/path-17.1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A module wrapper for os.path"
+HOMEPAGE="
+ https://github.com/jaraco/path/
+ https://pypi.org/project/path/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # unreliable, not really meaningful for end users
+ test_path.py::TestPerformance
+)
diff --git a/dev-python/slixmpp/Manifest b/dev-python/slixmpp/Manifest
index 1c0233af55fa..6b0a3e167a8a 100644
--- a/dev-python/slixmpp/Manifest
+++ b/dev-python/slixmpp/Manifest
@@ -1 +1,2 @@
DIST slixmpp-1.8.5.tar.gz 574560 BLAKE2B 3ac5b1f41acdf4dd725355cdb06e7642d67b5b51a533e933af1b451df424d3e81267ce945e577b21a07f943578119913a9a42dd4e65426223ff413ad52c3f110 SHA512 f2e123bd462097d0b7dc28cd960f723419f4fa2af59c8f5b7d30a05135c2f9fc6982e6d2855ea10b22936bdd4a96faeae73f87a495e2d1f10e6c63cdcb412665
+DIST slixmpp-1.8.6.tar.gz 581633 BLAKE2B 43482ae13020c8302ec432cb77da5bac53a4ed43368ee5398e05c300f63db5d14b4590aacbf592cbdf904b7ce6f07bcd72b152efd0614fba2028cf01f3663174 SHA512 b013145fbd44dd6f38fd7beb15af5d83bd9e6f843308a2124b2fbb1a70f0ead1f0739946c24d66a11aef60d660de6fcced846e91ecd1ad58ef84410be89b2356
diff --git a/dev-python/slixmpp/slixmpp-1.8.6.ebuild b/dev-python/slixmpp/slixmpp-1.8.6.ebuild
new file mode 100644
index 000000000000..bfb50b4c7a14
--- /dev/null
+++ b/dev-python/slixmpp/slixmpp-1.8.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python 3 library for XMPP"
+HOMEPAGE="
+ https://codeberg.org/poezio/slixmpp/
+ https://pypi.org/project/slixmpp/
+"
+LICENSE="MIT"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://codeberg.org/poezio/slixmpp.git"
+ inherit git-r3
+else
+ inherit pypi
+ KEYWORDS="~amd64 ~riscv"
+fi
+
+DEPEND="
+ net-dns/libidn:=
+"
+RDEPEND="
+ >=dev-python/aiodns-1.0[${PYTHON_USEDEP}]
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ ${DEPEND}
+ $(python_gen_cond_dep '
+ >=dev-lang/python-3.12.1_p1:3.12
+ ' python3_12)
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ rm -rf slixmpp || die
+ eunittest -s tests
+}
diff --git a/dev-python/starlette/Manifest b/dev-python/starlette/Manifest
index 4ece128715a8..3454030d2d87 100644
--- a/dev-python/starlette/Manifest
+++ b/dev-python/starlette/Manifest
@@ -1,3 +1,4 @@
DIST starlette-0.41.3.gh.tar.gz 2574193 BLAKE2B 4363317669b44df1e3f882aa88a32c2f6c53d9b349c8e65455a4f5bbd58a39a6e5342cfdd24cec2b652616fd57cbd4e46b9a81702251d336747d984c946bed3f SHA512 f6f0dc60dc557567fb342bbfff4b19b2c634f202d355589c4b66021f5018fdbf84e101b820926284519e0b8272f325045845f126239516034ce2d3c25558b7b3
DIST starlette-0.42.0.gh.tar.gz 2575175 BLAKE2B 8c8d85288ad7a42b9771431377e5b6ecd98f6c6088fa913bddf496db2de1c7c1e471d1b9a0a6a17885acfe96e503391e066d1b8c6f612329afe69d8ca8743935 SHA512 d7b0da5333930d6ce9315387cc7e23fd22b4ed379d37c8f143cf6e6a07b5cb2d207d4c349616788633387fa54c6fc377feb28df6ccd1216b824e66a47c950f2b
DIST starlette-0.43.0.gh.tar.gz 2575272 BLAKE2B 9905f678f5ea26e40e8b37cbf130fb03c1b6337c30777a24f3092134ac2ab077b4de2ca7b25feae8ee6bdb3334558c196688d8dca89f519d0949370992477218 SHA512 9cb80e0eebb6fecde411dce6c3beb1d733ccf887b9145c88b5608ef78e942d8c808c0bc8971fcdb233b6f2b973617fe7e60bc8a0d97cc14b002efe74f1900683
+DIST starlette-0.44.0.gh.tar.gz 2575663 BLAKE2B f566f354b87379ba076b37ebb7366ffc8c209bf1318f8c49ffcdc2cb604b90d29ecb24071b17c551c7e2aa4d383393fae9bf2b3e8129095e7adcaf10956d3a9d SHA512 052baac1a0f60354a35711e87de58b90b1c6fd13f6a2290746663dcc88d131840c340a2c95f8664b4b6347a7397639e26e547a1c353ca7b1911c3f5e3873868e
diff --git a/dev-python/starlette/starlette-0.44.0.ebuild b/dev-python/starlette/starlette-0.44.0.ebuild
new file mode 100644
index 000000000000..b7ad404f1294
--- /dev/null
+++ b/dev-python/starlette/starlette-0.44.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1
+
+MY_P=${P/_p/.post}
+DESCRIPTION="The little ASGI framework that shines"
+HOMEPAGE="
+ https://www.starlette.io/
+ https://github.com/encode/starlette/
+ https://pypi.org/project/starlette/
+"
+# no docs or tests in sdist, as of 0.27.0
+SRC_URI="
+ https://github.com/encode/starlette/archive/${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/anyio-5[${PYTHON_USEDEP}]
+ >=dev-python/anyio-3.4.0[${PYTHON_USEDEP}]
+ <dev-python/httpx-0.29[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.22.0[${PYTHON_USEDEP}]
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ dev-python/jinja2[${PYTHON_USEDEP}]
+ >=dev-python/python-multipart-0.0.18[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/pytest-8[${PYTHON_USEDEP}]
+ dev-python/trio[${PYTHON_USEDEP}]
+ )
+"
+
+: ${EPYTEST_TIMEOUT:-180}
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # Unpackaged 'databases' dependency
+ tests/test_database.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p anyio
+}
diff --git a/llvm-core/clang-runtime/clang-runtime-19.1.6-r1.ebuild b/llvm-core/clang-runtime/clang-runtime-19.1.6-r1.ebuild
index f18c95266d96..8f4209bb5172 100644
--- a/llvm-core/clang-runtime/clang-runtime-19.1.6-r1.ebuild
+++ b/llvm-core/clang-runtime/clang-runtime-19.1.6-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit multilib-build toolchain-funcs
+inherit multilib-build
DESCRIPTION="Meta-ebuild for clang runtime libraries"
HOMEPAGE="https://clang.llvm.org/"
@@ -29,17 +29,3 @@ RDEPEND="
)
)
"
-
-pkg_pretend() {
- if tc-is-clang; then
- ewarn "You seem to be using clang as a system compiler. As of clang-16,"
- ewarn "upstream has turned a few warnings that commonly occur during"
- ewarn "configure script runs into errors by default. This causes some"
- ewarn "configure tests to start failing, sometimes resulting in silent"
- ewarn "breakage, missing functionality or runtime misbehavior. It is"
- ewarn "not yet clear whether the change will remain or be reverted."
- ewarn
- ewarn "For more information, please see:"
- ewarn "https://discourse.llvm.org/t/configure-script-breakage-with-the-new-werror-implicit-function-declaration/65213"
- fi
-}
diff --git a/llvm-core/clang-runtime/clang-runtime-20.0.0.9999.ebuild b/llvm-core/clang-runtime/clang-runtime-20.0.0.9999.ebuild
index 731f7ca4c926..8fae33839019 100644
--- a/llvm-core/clang-runtime/clang-runtime-20.0.0.9999.ebuild
+++ b/llvm-core/clang-runtime/clang-runtime-20.0.0.9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit multilib-build toolchain-funcs
+inherit multilib-build
DESCRIPTION="Meta-ebuild for clang runtime libraries"
HOMEPAGE="https://clang.llvm.org/"
@@ -28,17 +28,3 @@ RDEPEND="
)
)
"
-
-pkg_pretend() {
- if tc-is-clang; then
- ewarn "You seem to be using clang as a system compiler. As of clang-16,"
- ewarn "upstream has turned a few warnings that commonly occur during"
- ewarn "configure script runs into errors by default. This causes some"
- ewarn "configure tests to start failing, sometimes resulting in silent"
- ewarn "breakage, missing functionality or runtime misbehavior. It is"
- ewarn "not yet clear whether the change will remain or be reverted."
- ewarn
- ewarn "For more information, please see:"
- ewarn "https://discourse.llvm.org/t/configure-script-breakage-with-the-new-werror-implicit-function-declaration/65213"
- fi
-}
diff --git a/profiles/package.mask b/profiles/package.mask
index 84470da43cb4..a0018a318931 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -33,6 +33,12 @@
#--- END OF EXAMPLES ---
+# Michał Górny <mgorny@gentoo.org> (2024-12-29)
+# As of 3.1.0, upstream has removed all mocking and made it impossible
+# to test the package locally. As such, we cannot maintain it going
+# forward. Removal on 2025-01-28. Bug #947144.
+dev-python/pslab
+
# Andreas Sturmlechner <asturm@gentoo.org> (2024-12-28)
# Cleanup transitional Bitcoin Core meta packages, as well as
# unmaintainable net-p2p/bitcoin-core[system-leveldb] and