summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-25 08:07:35 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-25 08:40:12 +0200
commitd7be2c7ca13aa18425ed9460a67d18bd89a01e82 (patch)
tree428d6e81c954a1531dd966a979d9f6c54fda1443
parentdev-ros/rqt_top: remove old (diff)
downloadgentoo-d7be2c7ca13aa18425ed9460a67d18bd89a01e82.tar.gz
gentoo-d7be2c7ca13aa18425ed9460a67d18bd89a01e82.tar.bz2
gentoo-d7be2c7ca13aa18425ed9460a67d18bd89a01e82.zip
dev-ros/rqt_top: bump to 0.4.8 and update to split repo
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--dev-ros/rqt_top/Manifest1
-rw-r--r--dev-ros/rqt_top/metadata.xml2
-rw-r--r--dev-ros/rqt_top/rqt_top-0.4.8.ebuild23
-rw-r--r--dev-ros/rqt_top/rqt_top-9999.ebuild5
4 files changed, 27 insertions, 4 deletions
diff --git a/dev-ros/rqt_top/Manifest b/dev-ros/rqt_top/Manifest
index 7bb8c4d74093..ad7d13806bc9 100644
--- a/dev-ros/rqt_top/Manifest
+++ b/dev-ros/rqt_top/Manifest
@@ -1 +1,2 @@
DIST rqt_common_plugins-0.4.7.tar.gz 246977 SHA256 83153ad89c67551c3fb4f36cad7f056d90c559958ac80203e2aa4605beb49a7f SHA512 eb10a7c03bb079d939a9705a08e9194c83e020235a13ed2d4ff8e9c3c73e5abbd0a9bd7c00587135767497b155bb9516d7b4c2240fbe2118d7b0668d6ee32ab7 WHIRLPOOL b002f836ee0f5ea213ec31be8e59910c7c3c9508301389309e60eeb7dd35989ae4e4dfa5fa9ee592371f05e6cd842a6e3b0ccd6ac4ed7a9efd8d60c36b1e6d65
+DIST rqt_top-0.4.8.tar.gz 6407 SHA256 6fa62b8fcb9ebc6d45173aa8a03189625856a26b8672f29518209f1d01b770ab SHA512 feef0e3430ee547f3f1a8a799c632fe0c1b7c4f380aaaa96ff58814ca791cf68082f2cb92763d7660f302034759f807e1bdf2995a1b7c87bb3beb9b2cb072b2e WHIRLPOOL ec5c24dc659f70c1a3281188b54257010f4e94fa236e36ff3989a668042888437eb2c938a65ee8b1cb7368d456b0ef5a0a279845e3571a4feac3b7bcfa2841ff
diff --git a/dev-ros/rqt_top/metadata.xml b/dev-ros/rqt_top/metadata.xml
index cb473d142b8e..f9af3304ee72 100644
--- a/dev-ros/rqt_top/metadata.xml
+++ b/dev-ros/rqt_top/metadata.xml
@@ -6,6 +6,6 @@
<name>Gentoo ROS Project</name>
</maintainer>
<upstream>
- <remote-id type="github">ros-visualization/rqt_common_plugins</remote-id>
+ <remote-id type="github">ros-visualization/rqt_top</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-ros/rqt_top/rqt_top-0.4.8.ebuild b/dev-ros/rqt_top/rqt_top-0.4.8.ebuild
new file mode 100644
index 000000000000..820eade78b5b
--- /dev/null
+++ b/dev-ros/rqt_top/rqt_top-0.4.8.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_top"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="RQT plugin for monitoring ROS processes"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rqt_top/rqt_top-9999.ebuild b/dev-ros/rqt_top/rqt_top-9999.ebuild
index 4ad1fed23af2..820eade78b5b 100644
--- a/dev-ros/rqt_top/rqt_top-9999.ebuild
+++ b/dev-ros/rqt_top/rqt_top-9999.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
KEYWORDS="~amd64"
-ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_top"
PYTHON_COMPAT=( python2_7 )
-ROS_SUBDIR=${PN}
inherit ros-catkin