summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2024-10-05 23:43:10 +0100
committerJames Le Cuirot <chewi@gentoo.org>2024-10-05 23:55:56 +0100
commita7de96e62e68d2c3af24cc69c7bb5cfa4395e553 (patch)
tree5676d421acac2aadd629d06d9b4674a5d640aa86
parentdev-debug/ddd: add 3.4.1, remove old (diff)
downloadgentoo-a7de96e62e68d2c3af24cc69c7bb5cfa4395e553.tar.gz
gentoo-a7de96e62e68d2c3af24cc69c7bb5cfa4395e553.tar.bz2
gentoo-a7de96e62e68d2c3af24cc69c7bb5cfa4395e553.zip
www-apps/tt-rss: Bump snapshot to 20241001
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
-rw-r--r--www-apps/tt-rss/Manifest1
-rw-r--r--www-apps/tt-rss/files/permissions-r14
-rw-r--r--www-apps/tt-rss/tt-rss-20230901.ebuild4
-rw-r--r--www-apps/tt-rss/tt-rss-20241001.ebuild90
-rw-r--r--www-apps/tt-rss/tt-rss-99999999.ebuild9
5 files changed, 100 insertions, 8 deletions
diff --git a/www-apps/tt-rss/Manifest b/www-apps/tt-rss/Manifest
index da200b684ec8..8d4177000e3d 100644
--- a/www-apps/tt-rss/Manifest
+++ b/www-apps/tt-rss/Manifest
@@ -1 +1,2 @@
DIST tt-rss-20230901.tar.xz 5368876 BLAKE2B af7dc8c7003f9bd83f656a1596458302eb29b7f27428e38e9cbc7fdeb0b920079622b577e5e578069d8475c265061efeb23648da621ad66263370a748512d49c SHA512 02111c89a3dc8fbf94be38d87fa90770eaaa644672aeeb7c1ece3ac7137c5a4f2f0f4412319bd887305f365fc7da9bfe3f644495a5655e8a351ecdae97a04d35
+DIST tt-rss-20241001.tar.xz 5436596 BLAKE2B 0f913496d93c702eaf3d33b2bfe2ec623d7a215457296399483927ba4bd8cf0dc44915bbc950b0635d452e67373d0a365736d7916141eb6d2cccb2487900d02d SHA512 fba5f5d18b855a299450d9659cd52d3c8d48995ab25778ae92ee8a5711a8afa5bf42cf21360fcd189664d3cd1ab12032bb67e688201b57e989bff1003cbea2ca
diff --git a/www-apps/tt-rss/files/permissions-r1 b/www-apps/tt-rss/files/permissions-r1
index 0ca420e97beb..ce698a1b25fa 100644
--- a/www-apps/tt-rss/files/permissions-r1
+++ b/www-apps/tt-rss/files/permissions-r1
@@ -14,8 +14,8 @@ if [[ $1 = install ]]; then
chown root:root cache/
chmod 00755 cache/
- chgrp --no-dereference ttrssd lock/ cache/*/
- chmod g+ws lock/ cache/*/
+ chgrp --no-dereference ttrssd feed-icons/ lock/ cache/*/
+ chmod g+ws feed-icons/ lock/ cache/*/
# Files within lock/ are exclusively written by the update daemon. cache/
# subdirectories hold files that are modified in place by both processes and
diff --git a/www-apps/tt-rss/tt-rss-20230901.ebuild b/www-apps/tt-rss/tt-rss-20230901.ebuild
index 34b6d313a90e..602be926f79d 100644
--- a/www-apps/tt-rss/tt-rss-20230901.ebuild
+++ b/www-apps/tt-rss/tt-rss-20230901.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -67,7 +67,7 @@ src_install() {
keepdir "${MY_HTDOCSDIR}"/cache/{feed-icons,starred-images}
local dir
- for dir in "${ED}${MY_HTDOCSDIR}"/{cache/*,lock}/; do
+ for dir in "${ED}${MY_HTDOCSDIR}"/{cache/*,feed-icons,lock}/; do
webapp_serverowned "${dir#${ED}}"
done
diff --git a/www-apps/tt-rss/tt-rss-20241001.ebuild b/www-apps/tt-rss/tt-rss-20241001.ebuild
new file mode 100644
index 000000000000..55c108a7ca49
--- /dev/null
+++ b/www-apps/tt-rss/tt-rss-20241001.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp
+
+DESCRIPTION="Tiny Tiny RSS - A web-based news feed (RSS/Atom) aggregator using AJAX"
+HOMEPAGE="https://tt-rss.org/"
+SRC_URI="https://dev.gentoo.org/~chewi/distfiles/${P}.tar.xz"
+S="${WORKDIR}/${PN}"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+IUSE="+acl daemon gd +mysqli postgres"
+REQUIRED_USE="|| ( mysqli postgres )"
+
+PHP_SLOTS="8.3"
+PHP_USE="gd?,mysqli?,postgres?,curl,fileinfo,intl,json(+),pdo,unicode,xml"
+
+php_rdepend() {
+ local slot
+ echo "|| ("
+ for slot in ${PHP_SLOTS}; do
+ echo "(
+ virtual/httpd-php:${slot}
+ dev-lang/php:${slot}[$1]
+ )"
+ done
+ echo ")"
+}
+
+DEPEND="
+ daemon? ( acl? ( sys-apps/acl ) )
+"
+
+RDEPEND="
+ ${DEPEND}
+ daemon? (
+ acct-user/ttrssd
+ acct-group/ttrssd
+ $(php_rdepend "${PHP_USE},cli,pcntl")
+ )
+ !daemon? (
+ $(php_rdepend "${PHP_USE}")
+ )
+"
+
+DEPEND="
+ !vhosts? ( ${DEPEND} )
+"
+
+need_httpd_cgi # From webapp.eclass
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-no-chmod.patch
+)
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r *
+
+ # When updating, grep the code for new DiskCache::instance occurrences as
+ # these directories cannot be created later due to permissions. Some
+ # of these directories are already present in the source tree.
+ keepdir "${MY_HTDOCSDIR}"/cache/{feed-icons,starred-images}
+
+ local dir
+ for dir in "${ED}${MY_HTDOCSDIR}"/{cache/*,feed-icons,lock}/; do
+ webapp_serverowned "${dir#${ED}}"
+ done
+
+ if use daemon; then
+ webapp_hook_script "${FILESDIR}"/permissions-r1
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-with-daemon-r1.txt
+
+ newinitd "${FILESDIR}"/ttrssd.initd-r4 ttrssd
+ newconfd "${FILESDIR}"/ttrssd.confd-r2 ttrssd
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/ttrssd.logrotated-r1 ttrssd
+
+ elog "After upgrading, please restart ttrssd."
+ else
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ fi
+
+ webapp_src_install
+}
diff --git a/www-apps/tt-rss/tt-rss-99999999.ebuild b/www-apps/tt-rss/tt-rss-99999999.ebuild
index 3ea3d6a0a40a..783f41b666ac 100644
--- a/www-apps/tt-rss/tt-rss-99999999.ebuild
+++ b/www-apps/tt-rss/tt-rss-99999999.ebuild
@@ -13,7 +13,7 @@ SLOT="${PV}" # Single live slot.
IUSE="+acl daemon gd +mysqli postgres"
REQUIRED_USE="|| ( mysqli postgres )"
-PHP_SLOTS="8.3 8.2 8.1"
+PHP_SLOTS="8.3"
PHP_USE="gd?,mysqli?,postgres?,curl,fileinfo,intl,json(+),pdo,unicode,xml"
php_rdepend() {
@@ -60,12 +60,13 @@ src_install() {
insinto "${MY_HTDOCSDIR}"
doins -r *
- # When updating, grep the code for additional DiskCache::instances as they
- # cannot be created later due to permissions.
+ # When updating, grep the code for new DiskCache::instance occurrences as
+ # these directories cannot be created later due to permissions. Some
+ # of these directories are already present in the source tree.
keepdir "${MY_HTDOCSDIR}"/cache/{feed-icons,starred-images}
local dir
- for dir in "${ED}${MY_HTDOCSDIR}"/{cache/*,lock}/; do
+ for dir in "${ED}${MY_HTDOCSDIR}"/{cache/*,feed-icons,lock}/; do
webapp_serverowned "${dir#${ED}}"
done