summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2024-01-21 10:42:06 +0100
committerDavid Seifert <soap@gentoo.org>2024-01-21 10:42:06 +0100
commit91d807c5ca433ee38fb3d2f6ae704afc07cc3af8 (patch)
treeec158dd32ac706a7f6d015fb23e00d1143eda570
parentnet-wireless/iwd: remove USE=crda (diff)
downloadgentoo-91d807c5ca433ee38fb3d2f6ae704afc07cc3af8.tar.gz
gentoo-91d807c5ca433ee38fb3d2f6ae704afc07cc3af8.tar.bz2
gentoo-91d807c5ca433ee38fb3d2f6ae704afc07cc3af8.zip
net-wireless/wpa_supplicant: remove USE=crda
Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--net-wireless/wpa_supplicant/metadata.xml1
-rw-r--r--net-wireless/wpa_supplicant/wpa_supplicant-2.10-r1.ebuild26
2 files changed, 9 insertions, 18 deletions
diff --git a/net-wireless/wpa_supplicant/metadata.xml b/net-wireless/wpa_supplicant/metadata.xml
index ecb638b513dc..489b2ea119fd 100644
--- a/net-wireless/wpa_supplicant/metadata.xml
+++ b/net-wireless/wpa_supplicant/metadata.xml
@@ -8,7 +8,6 @@
<use>
<flag name="ap">Add support for access point mode</flag>
<flag name="broadcom-sta">Flag to help users disable features not supported by broadcom-sta driver</flag>
- <flag name="crda">Use <pkg>net-wireless/crda</pkg> for regulatory domain loading instead of in-kernel (4.15+) support</flag>
<flag name="eap-sim">Add support for EAP-SIM authentication algorithm</flag>
<flag name="eapol-test">Build and install eapol_test binary</flag>
<flag name="fasteap">Add support for FAST-EAP authentication algorithm</flag>
diff --git a/net-wireless/wpa_supplicant/wpa_supplicant-2.10-r1.ebuild b/net-wireless/wpa_supplicant/wpa_supplicant-2.10-r1.ebuild
index dbd441303c31..867bb37f63ac 100644
--- a/net-wireless/wpa_supplicant/wpa_supplicant-2.10-r1.ebuild
+++ b/net-wireless/wpa_supplicant/wpa_supplicant-2.10-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -18,7 +18,7 @@ else
fi
SLOT="0"
-IUSE="ap +crda broadcom-sta dbus eap-sim eapol-test fasteap +fils +hs2-0 macsec +mbo +mesh p2p privsep ps3 qt5 readline selinux smartcard tdls tkip uncommon-eap-types wep wimax wps"
+IUSE="ap broadcom-sta dbus eap-sim eapol-test fasteap +fils +hs2-0 macsec +mbo +mesh p2p privsep ps3 qt5 readline selinux smartcard tdls tkip uncommon-eap-types wep wimax wps"
# CONFIG_PRIVSEP=y does not have sufficient support for the new driver
# interface functions used for MACsec, so this combination cannot be used
@@ -52,7 +52,6 @@ RDEPEND="${DEPEND}
selinux? ( sec-policy/selinux-networkmanager )
kernel_linux? (
net-wireless/wireless-regdb
- crda? ( net-wireless/crda )
)
"
BDEPEND="virtual/pkgconfig"
@@ -90,22 +89,15 @@ Kconfig_style_config() {
pkg_pretend() {
CONFIG_CHECK=""
- if use crda ; then
- CONFIG_CHECK="${CONFIG_CHECK} ~CFG80211_CRDA_SUPPORT"
- WARNING_CFG80211_CRDA_SUPPORT="REGULATORY DOMAIN PROBLEM: please enable CFG80211_CRDA_SUPPORT for proper regulatory domain support"
- fi
-
check_extra_config
- if ! use crda ; then
- if linux_config_exists && linux_chkconfig_builtin CFG80211 &&
- [[ $(linux_chkconfig_string EXTRA_FIRMWARE) != *regulatory.db* ]]
- then
- ewarn "REGULATORY DOMAIN PROBLEM:"
- ewarn "With CONFIG_CFG80211=y (built-in), the driver won't be able to load regulatory.db from"
- ewarn " /lib/firmware, resulting in broken regulatory domain support. Please set CONFIG_CFG80211=m"
- ewarn " or add regulatory.db and regulatory.db.p7s to CONFIG_EXTRA_FIRMWARE."
- fi
+ if linux_config_exists && linux_chkconfig_builtin CFG80211 &&
+ [[ $(linux_chkconfig_string EXTRA_FIRMWARE) != *regulatory.db* ]]
+ then
+ ewarn "REGULATORY DOMAIN PROBLEM:"
+ ewarn "With CONFIG_CFG80211=y (built-in), the driver won't be able to load regulatory.db from"
+ ewarn " /lib/firmware, resulting in broken regulatory domain support. Please set CONFIG_CFG80211=m"
+ ewarn " or add regulatory.db and regulatory.db.p7s to CONFIG_EXTRA_FIRMWARE."
fi
}