summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2016-09-02 10:18:11 -0600
committerJason A. Donenfeld <zx2c4@gentoo.org>2016-09-02 10:59:43 -0600
commit8db1fc902d345f1cb9280935e2239dd4d9a6fecf (patch)
tree37023c873f4b0bdb8da2050a090108881fb65ea8
parentnet-p2p/soulseek-qt: version bump (diff)
downloadgentoo-8db1fc902d345f1cb9280935e2239dd4d9a6fecf.tar.gz
gentoo-8db1fc902d345f1cb9280935e2239dd4d9a6fecf.tar.bz2
gentoo-8db1fc902d345f1cb9280935e2239dd4d9a6fecf.zip
net-wireless/osmocom: modernize
Package-Manager: portage-2.3.0
-rw-r--r--net-libs/libosmo-netif/libosmo-netif-9999.ebuild23
-rw-r--r--net-libs/libosmo-netif/metadata.xml8
-rw-r--r--net-misc/lcr/lcr-9999.ebuild3
-rw-r--r--net-wireless/openbsc/openbsc-9999.ebuild1
-rw-r--r--net-wireless/osmobts/osmobts-9999.ebuild11
5 files changed, 38 insertions, 8 deletions
diff --git a/net-libs/libosmo-netif/libosmo-netif-9999.ebuild b/net-libs/libosmo-netif/libosmo-netif-9999.ebuild
new file mode 100644
index 000000000000..2fb6bdf8631f
--- /dev/null
+++ b/net-libs/libosmo-netif/libosmo-netif-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils git-2
+
+DESCRIPTION="Utility functions for OsmocomBB, OpenBSC and related projects"
+HOMEPAGE="http://bb.osmocom.org/trac/wiki/"
+EGIT_REPO_URI="git://git.osmocom.org/${PN}.git"
+KEYWORDS=""
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="net-libs/libosmocore net-libs/libosmo-abis"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ eautoreconf
+}
diff --git a/net-libs/libosmo-netif/metadata.xml b/net-libs/libosmo-netif/metadata.xml
new file mode 100644
index 000000000000..1570f891c6a3
--- /dev/null
+++ b/net-libs/libosmo-netif/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>radio@gentoo.org</email>
+ <name>Radio</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-misc/lcr/lcr-9999.ebuild b/net-misc/lcr/lcr-9999.ebuild
index fd6b40bedbd9..8efd7d8fe054 100644
--- a/net-misc/lcr/lcr-9999.ebuild
+++ b/net-misc/lcr/lcr-9999.ebuild
@@ -27,11 +27,12 @@ DEPEND="
RDEPEND="${DEPEND}"
src_prepare() {
+ sed -i 's:#!/usr/bin/env python:#!/usr/bin/env python2:' "${S}"/libgsmhr/fetch_sources.py
eautoreconf
}
src_configure() {
- econf \
+ CXXFLAGS="$CXXFLAGS -I./include" CFLAGS="$CFLAGS -I./include" econf \
$(use_with asterisk) \
$(use_with ssl) \
$(use_with gsm-bs) \
diff --git a/net-wireless/openbsc/openbsc-9999.ebuild b/net-wireless/openbsc/openbsc-9999.ebuild
index a8b11303a00a..8ba6088d63db 100644
--- a/net-wireless/openbsc/openbsc-9999.ebuild
+++ b/net-wireless/openbsc/openbsc-9999.ebuild
@@ -9,7 +9,6 @@ inherit autotools git-2 eutils
DESCRIPTION="OpenBSC, OsmoSGSN, OsmoBSC and other programs"
HOMEPAGE="http://openbsc.osmocom.org/trac/wiki/OpenBSC"
EGIT_REPO_URI="git://git.osmocom.org/${PN}.git"
-EGIT_BRANCH="jolly/testing"
LICENSE="GPL-2"
SLOT="0"
diff --git a/net-wireless/osmobts/osmobts-9999.ebuild b/net-wireless/osmobts/osmobts-9999.ebuild
index 7f7a4e9eeb8f..40f564bb172f 100644
--- a/net-wireless/osmobts/osmobts-9999.ebuild
+++ b/net-wireless/osmobts/osmobts-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -9,7 +9,6 @@ inherit autotools git-2
DESCRIPTION="Osmocom BTS-Side code (Abis, scheduling)"
HOMEPAGE="http://openbsc.osmocom.org/trac/wiki/OsmoBTS"
EGIT_REPO_URI="git://git.osmocom.org/osmo-bts.git"
-EGIT_BRANCH="jolly/trx"
LICENSE="GPL-2"
SLOT="0"
@@ -20,12 +19,12 @@ DEPEND="net-libs/libosmocore net-libs/libosmo-abis"
RDEPEND="${DEPEND}"
src_prepare() {
- mkdir -p ../openbsc/openbsc/include/openbsc ../openbsc/openbsc/src/libcommon/ || die
- wget -O ../openbsc/openbsc/include/openbsc/gsm_data_shared.h http://cgit.osmocom.org/openbsc/plain/openbsc/include/openbsc/gsm_data_shared.h?h=jolly/testing || die
- wget -O ../openbsc/openbsc/src/libcommon/gsm_data_shared.c http://cgit.osmocom.org/openbsc/plain/openbsc/src/libcommon/gsm_data_shared.c?h=jolly/testing || die
eautoreconf
+ wget -O "${S}"/include/openbsc/gsm_data_shared.h http://cgit.osmocom.org/openbsc/plain/openbsc/include/openbsc/gsm_data_shared.h || die
+ wget -O "${S}"/src/common/gsm_data_shared.c http://cgit.osmocom.org/openbsc/plain/openbsc/src/libcommon/gsm_data_shared.c || die
+
}
src_configure() {
- econf --enable-trx
+ econf --enable-trx --with-openbsc="${S}"/include/openbsc
}