summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-03-02 14:14:16 +0100
committerManuel Rüger <mrueg@gentoo.org>2018-03-02 14:14:16 +0100
commit64a9702a67f63b58a159139bbe395595c864404a (patch)
tree421c67e4d016843bf36b24950a7a74fa6e3c8bdb
parentdev-db/etcd: Create user only if USE="server" is enabled (diff)
downloadgentoo-64a9702a67f63b58a159139bbe395595c864404a.tar.gz
gentoo-64a9702a67f63b58a159139bbe395595c864404a.tar.bz2
gentoo-64a9702a67f63b58a159139bbe395595c864404a.zip
dev-util/buildbot-prometheus: Drop dependency on pip
Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--dev-util/buildbot-prometheus/buildbot-prometheus-17.7.2-r1.ebuild26
-rw-r--r--dev-util/buildbot-prometheus/buildbot-prometheus-17.7.2.ebuild6
2 files changed, 31 insertions, 1 deletions
diff --git a/dev-util/buildbot-prometheus/buildbot-prometheus-17.7.2-r1.ebuild b/dev-util/buildbot-prometheus/buildbot-prometheus-17.7.2-r1.ebuild
new file mode 100644
index 000000000000..a930624175f3
--- /dev/null
+++ b/dev-util/buildbot-prometheus/buildbot-prometheus-17.7.2-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+inherit distutils-r1
+
+DESCRIPTION="A Prometheus metrics exporter for Buildbot"
+HOMEPAGE="https://github.com/claws/buildbot-prometheus"
+SRC_URI="https://github.com/claws/buildbot-prometheus/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-python/prometheus_client[${PYTHON_USEDEP}]
+ dev-util/buildbot[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${RDEPEND}"
+
+python_prepare_all() {
+ sed -i -e "/^install_reqs.*$/d" -e "/^from pip.*$/d" -e "s/requires = .*/requires = ['buildbot', 'prometheus_client']/" setup.py || die
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-util/buildbot-prometheus/buildbot-prometheus-17.7.2.ebuild b/dev-util/buildbot-prometheus/buildbot-prometheus-17.7.2.ebuild
index e84caf199146..a930624175f3 100644
--- a/dev-util/buildbot-prometheus/buildbot-prometheus-17.7.2.ebuild
+++ b/dev-util/buildbot-prometheus/buildbot-prometheus-17.7.2.ebuild
@@ -18,5 +18,9 @@ IUSE=""
RDEPEND="dev-python/prometheus_client[${PYTHON_USEDEP}]
dev-util/buildbot[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/pip[${PYTHON_USEDEP}]
${RDEPEND}"
+
+python_prepare_all() {
+ sed -i -e "/^install_reqs.*$/d" -e "/^from pip.*$/d" -e "s/requires = .*/requires = ['buildbot', 'prometheus_client']/" setup.py || die
+ distutils-r1_python_prepare_all
+}