summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-23 06:41:16 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-23 08:22:03 +0200
commit03ef4b3850a6913105f80478d7ea60b4c41784c8 (patch)
tree18140578ccaca67656541d1cc9090fdc7f691212
parentsys-apps/progress: keyword 0.15-r1 for ~riscv (diff)
downloadgentoo-03ef4b3850a6913105f80478d7ea60b4c41784c8.tar.gz
gentoo-03ef4b3850a6913105f80478d7ea60b4c41784c8.tar.bz2
gentoo-03ef4b3850a6913105f80478d7ea60b4c41784c8.zip
dev-python/botocore: Bump to 1.27.36
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.27.36.ebuild69
-rw-r--r--dev-python/botocore/botocore-9999.ebuild5
3 files changed, 74 insertions, 1 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 7500a63d5196..a1fe1e7d3b6a 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -3,3 +3,4 @@ DIST botocore-1.27.26.tar.gz 9167551 BLAKE2B 9e95c1e6e5261b08247615446a589318d92
DIST botocore-1.27.31.tar.gz 9184651 BLAKE2B 01dcd9e94490923f7d0f463d3019007f58c5e441ae65ea2c365ed20417e8f7b532228a335c6f461ca97411269aaa78aa48fa33cccd8b2e45a6665c2410bb4352 SHA512 27f810e0519144fae71600ea7f6d9a15cca30386ee0f2b06beeeb64c06da8728b54709fb770673f708697dd930fe744703728ce00b6a1149361ab550fef9ccb4
DIST botocore-1.27.32.tar.gz 9191251 BLAKE2B 757aa8e1efe16db3e9bedb545c32e9013eb80fc2b0b6fd61903c2c34d4c5140cce41f7c62822b277119079bdb921102d7d1c431edc5617131ab8cd8d6983054c SHA512 3ae2d0d092961bc061d744e74bbf3a387120a400173f54f4d62284535ee2e505a887f57be7c44f306560ce6d6f82c4ff435d0a9221e8e7f406eb13c7dd26ec11
DIST botocore-1.27.33.tar.gz 9194408 BLAKE2B 1e942308a19a827b5b05187879860e7f3b78c8a184bf948c2ea6c424410f878bef01feb452b89d3cb60b241c17024a4974ad6997373e8e2423e1f725d137c4b3 SHA512 b3b36e75822188f9080808188de6b2f435fd9fb2f76efc41b1052e24008120a399c75a4f944976732257a936eea9290dbca995db03d377f96f8910f2307a8427
+DIST botocore-1.27.36.gh.tar.gz 9465835 BLAKE2B c22c341d6e762316f3d8719bd8c1fd52140642739361a7ade326d739005dbd141a6b4e1798287b40bf7ba40cd5e158d36f195893d529f5ba375b06087d2122b9 SHA512 09ef156b3c0457ceef341bf26e3f060d3e91808f1da66d1dbb06ba2826be3c61e047383dc9d8a719bb8e172e91f6475f4613c14d30c57c6a909b51c8ba7334cc
diff --git a/dev-python/botocore/botocore-1.27.36.ebuild b/dev-python/botocore/botocore-1.27.36.ebuild
new file mode 100644
index 000000000000..6558cbe56a50
--- /dev/null
+++ b/dev-python/botocore/botocore-1.27.36.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}
diff --git a/dev-python/botocore/botocore-9999.ebuild b/dev-python/botocore/botocore-9999.ebuild
index 830c713f6036..6558cbe56a50 100644
--- a/dev-python/botocore/botocore-9999.ebuild
+++ b/dev-python/botocore/botocore-9999.ebuild
@@ -20,7 +20,10 @@ if [[ "${PV}" == "9999" ]]; then
EGIT_REPO_URI="https://github.com/boto/botocore"
inherit git-r3
else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
fi