aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2018-09-10 22:48:49 +0200
committerBart Ribbers <bribbers@disroot.org>2018-09-10 22:48:49 +0200
commitac0c3914fb8a8133630dd67f4e3f59712272b164 (patch)
tree9abf9b555acf7d2855ac417e5abc44517185638b /dev-libs
parentAdd some missing dependencies to Riot, fixes #13 (diff)
downloadmatrix-ac0c3914fb8a8133630dd67f4e3f59712272b164.tar.gz
matrix-ac0c3914fb8a8133630dd67f4e3f59712272b164.tar.bz2
matrix-ac0c3914fb8a8133630dd67f4e3f59712272b164.zip
Add first mtxclient release and remove matrix-structs
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/matrix-structs/Manifest1
-rw-r--r--dev-libs/matrix-structs/matrix-structs-9999.ebuild22
-rw-r--r--dev-libs/mtxclient/Manifest4
-rw-r--r--dev-libs/mtxclient/mtxclient-0.1.0.ebuild29
-rw-r--r--dev-libs/mtxclient/mtxclient-9999.ebuild19
5 files changed, 43 insertions, 32 deletions
diff --git a/dev-libs/matrix-structs/Manifest b/dev-libs/matrix-structs/Manifest
deleted file mode 100644
index d79c715..0000000
--- a/dev-libs/matrix-structs/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-EBUILD matrix-structs-9999.ebuild 475 BLAKE2B 351a83f1014ba9f83c175933ca98a68cc1453609c2d22c3c54553ce63517e026c96c0c6aba895b0e3dfc83e697197eb3aeff4a221eeafb639178ba97196b7aca SHA512 fa295a06bd654b4e6a7f9e6a992d7b7611b7c0372600b566127284fe852aa6463f6a5da1e9834b06914712bfd5b89399ddecf3291782213cabe4a1fdf7aed8aa
diff --git a/dev-libs/matrix-structs/matrix-structs-9999.ebuild b/dev-libs/matrix-structs/matrix-structs-9999.ebuild
deleted file mode 100644
index 28efa9f..0000000
--- a/dev-libs/matrix-structs/matrix-structs-9999.ebuild
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="An implementation of the Double Ratchet cryptographic ratchet in C++"
-HOMEPAGE="https://github.com/mujx/${PN}"
-
-inherit git-r3 eutils cmake-utils
-
-EGIT_REPO_URI="https://github.com/mujx/${PN}.git"
-if [[ ${PV} != "9999" ]]; then
- EGIT_COMMIT="v{$PV}"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE=""
-
-RDEPEND=""
-DEPEND="${RDEPEND}"
diff --git a/dev-libs/mtxclient/Manifest b/dev-libs/mtxclient/Manifest
index 1bcdc4c..5e63adb 100644
--- a/dev-libs/mtxclient/Manifest
+++ b/dev-libs/mtxclient/Manifest
@@ -1 +1,3 @@
-EBUILD mtxclient-9999.ebuild 574 BLAKE2B 4f175b95c78900615ffc8908ac024a86bcae74fdd2bcdce66cd90a5978d0590105eeea17d1a9062b05ed17180cff71b69c12ddededdf3405918d813cf1603138 SHA512 4cea75938c597150eab0b2e0f3110a30d4a3b7bf6b9b88d66817ea65be872328af3b61b172af0d95964e0f51399a8efeff62711de072e1b38058d215755530a6
+DIST mtxclient-0.1.0.tar.gz 472115 BLAKE2B 0770ade9d8d6e83f52433d1f969ae512ab5225c70111ca2b81686acbad7f270fb5698df0978a58edd12d2ae3ba58ad3e3f49521e34bc00b9db997626912944d6 SHA512 0d1c03bc0a8875942147fbde031274fb35a1f4b0c72c15e872a08e756fd63e5d249f9a7fc8f62a54fcbcee2b0efde302a64b8dcf560c94c969ef6e64a74addc0
+EBUILD mtxclient-0.1.0.ebuild 636 BLAKE2B 3c73e8fe819cde91655f458e9a30ef30e79d467ac21b606219499b5069514357c2fce0c407f8130affae3d86db36dd0bba0fc3c675b63072a5eb564a219871d0 SHA512 8b2968400d0cb959f42951803c3cd030e508bcc9418ed45ced33c091a4e1fd2d8830207470ce292a2d2568142c14ef662af98f2e5c643cb36ca7c52dfcb7fee0
+EBUILD mtxclient-9999.ebuild 636 BLAKE2B 3c73e8fe819cde91655f458e9a30ef30e79d467ac21b606219499b5069514357c2fce0c407f8130affae3d86db36dd0bba0fc3c675b63072a5eb564a219871d0 SHA512 8b2968400d0cb959f42951803c3cd030e508bcc9418ed45ced33c091a4e1fd2d8830207470ce292a2d2568142c14ef662af98f2e5c643cb36ca7c52dfcb7fee0
diff --git a/dev-libs/mtxclient/mtxclient-0.1.0.ebuild b/dev-libs/mtxclient/mtxclient-0.1.0.ebuild
new file mode 100644
index 0000000..405c244
--- /dev/null
+++ b/dev-libs/mtxclient/mtxclient-0.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="An implementation of the Double Ratchet cryptographic ratchet in C++"
+HOMEPAGE="https://github.com/mujx/mtxclient"
+
+inherit eutils cmake-utils
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/mujx/${PN}.git"
+else
+ SRC_URI="https://github.com/mujx/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ #KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/spdlog
+ dev-libs/libsodium
+ >=dev-libs/boost-1.66.0
+ dev-libs/olm"
+DEPEND="${RDEPEND}"
diff --git a/dev-libs/mtxclient/mtxclient-9999.ebuild b/dev-libs/mtxclient/mtxclient-9999.ebuild
index a521d55..405c244 100644
--- a/dev-libs/mtxclient/mtxclient-9999.ebuild
+++ b/dev-libs/mtxclient/mtxclient-9999.ebuild
@@ -4,14 +4,18 @@
EAPI=6
DESCRIPTION="An implementation of the Double Ratchet cryptographic ratchet in C++"
-HOMEPAGE="https://github.com/mujx/${PN}"
+HOMEPAGE="https://github.com/mujx/mtxclient"
-inherit git-r3 eutils cmake-utils
+inherit eutils cmake-utils
-EGIT_REPO_URI="https://github.com/mujx/${PN}.git"
-if [[ ${PV} != "9999" ]]; then
- EGIT_COMMIT="v{$PV}"
- KEYWORDS="~amd64 ~x86"
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/mujx/${PN}.git"
+else
+ SRC_URI="https://github.com/mujx/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ #KEYWORDS="~amd64 ~x86"
fi
LICENSE="GPL-3"
@@ -21,6 +25,5 @@ IUSE=""
RDEPEND="dev-libs/spdlog
dev-libs/libsodium
>=dev-libs/boost-1.66.0
- dev-libs/olm
- dev-libs/matrix-structs"
+ dev-libs/olm"
DEPEND="${RDEPEND}"