aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/lcc/lcc-2021.01.11-r1.ebuild45
-rw-r--r--sys-devel/lcc/lcc-2021.01.11.ebuild36
2 files changed, 45 insertions, 36 deletions
diff --git a/sys-devel/lcc/lcc-2021.01.11-r1.ebuild b/sys-devel/lcc/lcc-2021.01.11-r1.ebuild
new file mode 100644
index 000000000..af3369a53
--- /dev/null
+++ b/sys-devel/lcc/lcc-2021.01.11-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+# Would allow installing gentoo on any arch.
+DESCRIPTION="The lcc retargetable ANSI C compiler"
+HOMEPAGE="https://drh.github.io/lcc/"
+SHA='3fd0acc0c3087411c0966d725a56be29038c05a9'
+SRC_URI="https://github.com/drh/lcc/archive/${SHA}.tar.gz"
+
+# Build using CMake, still missing some features.
+PATCHES=( "${FILESDIR}/add_cmake_support.patch" )
+
+LICENSE="lcc"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# What are the dependencies if any?
+#DEPEND=""
+#RDEPEND="${DEPEND}"
+#BDEPEND=""
+S="${WORKDIR}/${PN}-${SHA}"
+
+src_install() {
+ doman "doc/bprint.1"
+ doman "doc/lcc.1"
+ into "/usr/lib/lcc"
+ dobin "${WORKDIR}/${PN}-${SHA}_build/cpp/cpp"
+ dobin "${WORKDIR}/${PN}-${SHA}_build/etc/bprint"
+ dobin "${WORKDIR}/${PN}-${SHA}_build/etc/lcc"
+ dobin "${WORKDIR}/${PN}-${SHA}_build/lburg/lburg"
+ dobin "${WORKDIR}/${PN}-${SHA}_build/src/rcc"
+}
+
+pkg_postinst() {
+ ewarn "If you had installed the previous version of this ebuild (lcc-2021.01.11),"
+ ewarn "there was a file collision that deleted the GNU's /usr/bin/cpp by LCC's own /usr/bin/cpp."
+ ewarn "So make sure to run the following commands :"
+ ewarn "gcc-config -l"
+ ewarn "gcc-config -f the_gcc_config_of_the_previous_command"
+ ewarn "The new package lcc-2021.01.11-r1 doesn't adds LCC to PATH anymore."
+} \ No newline at end of file
diff --git a/sys-devel/lcc/lcc-2021.01.11.ebuild b/sys-devel/lcc/lcc-2021.01.11.ebuild
deleted file mode 100644
index cd525f981..000000000
--- a/sys-devel/lcc/lcc-2021.01.11.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-# Would allow installing gentoo on any arch.
-DESCRIPTION="The lcc retargetable ANSI C compiler"
-HOMEPAGE="https://drh.github.io/lcc/"
-SHA='3fd0acc0c3087411c0966d725a56be29038c05a9'
-SRC_URI="https://github.com/drh/lcc/archive/${SHA}.tar.gz"
-
-# Build using CMake, still missing some features.
-PATCHES=( "${FILESDIR}/add_cmake_support.patch" )
-
-LICENSE="lcc"
-SLOT="0"
-KEYWORDS="~amd64"
-
-# What are the dependencies if any?
-#DEPEND=""
-#RDEPEND="${DEPEND}"
-#BDEPEND=""
-S="${WORKDIR}/${PN}-${SHA}"
-
-src_install() {
- doman "doc/bprint.1"
- doman "doc/lcc.1"
- #into "/usr/lib/lcc"
- dobin "${WORKDIR}/${PN}-${SHA}_build/cpp/cpp"
- dobin "${WORKDIR}/${PN}-${SHA}_build/etc/bprint"
- dobin "${WORKDIR}/${PN}-${SHA}_build/etc/lcc"
- dobin "${WORKDIR}/${PN}-${SHA}_build/lburg/lburg"
- dobin "${WORKDIR}/${PN}-${SHA}_build/src/rcc"
-}