aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNRK <nrk@disroot.org>2023-05-19 22:17:43 +0600
committerNRK <nrk@disroot.org>2023-05-19 22:22:11 +0600
commit582d80cd9950755a48ebebc4e02ce0a235fcdc2a (patch)
tree415f26d7bc62645e805ed2565f9faab9fc61433e /x11-misc/xbanish
parentx11-misc/xbanish: drop v1.7 (diff)
downloadguru-582d80cd9950755a48ebebc4e02ce0a235fcdc2a.tar.gz
guru-582d80cd9950755a48ebebc4e02ce0a235fcdc2a.tar.bz2
guru-582d80cd9950755a48ebebc4e02ce0a235fcdc2a.zip
x11-misc/xbanish: add snapshot
a couple useful bugfixes and feature has been merged since last release, but no tagged release yet. changes compared to v1.8: * upgrade to EAPI 8 * drop libXt from DEPEND: wasn't needed, unnecessary include dropped upstream. * drop src_configure: upstream makefile now respects env LDFLAGS Signed-off-by: NRK <nrk@disroot.org>
Diffstat (limited to 'x11-misc/xbanish')
-rw-r--r--x11-misc/xbanish/Manifest1
-rw-r--r--x11-misc/xbanish/xbanish-1.8_p20230519.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/x11-misc/xbanish/Manifest b/x11-misc/xbanish/Manifest
index dd29d02ca..086b2d129 100644
--- a/x11-misc/xbanish/Manifest
+++ b/x11-misc/xbanish/Manifest
@@ -1 +1,2 @@
DIST xbanish-1.8.tar.gz 7082 BLAKE2B 2b54a93754264723b6c18d089db40aae902a8e406d919ffbc42d01cd4b85675477cef9c586c09cbf3f518a84aff9f33069cc228627d9967ae182fac545b1a6e5 SHA512 d6c3434f38bd0c9aabdc8745cb46ad196df379acae156f2f282aba83f69ecb88164fe752cd868e63ab887ca5758fbfd502d709c811843fe1deafd880e161a972
+DIST xbanish-1.8_p20230519.tar.gz 7357 BLAKE2B 0e39657000fafef6ca2e2020c01b7a4511a9f094fd35deba3c23e61ddc9c0c13aafc9e47c92a073e737a9c1be9a494224fd5081ef89f9637d197b841d3024a06 SHA512 8ab02a78a4e1b86111c0c100044f850185d9365d02f2f09138da2b2b0a7bc3ea3f54491e25fb618b015f3741656f60561cb14a68e93c054f69e8318b444aa1bb
diff --git a/x11-misc/xbanish/xbanish-1.8_p20230519.ebuild b/x11-misc/xbanish/xbanish-1.8_p20230519.ebuild
new file mode 100644
index 000000000..da0ccba5f
--- /dev/null
+++ b/x11-misc/xbanish/xbanish-1.8_p20230519.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Banish the mouse cursor when typing, show it again when the mouse moves"
+HOMEPAGE="https://github.com/jcs/xbanish"
+
+COMMIT="189ce79b1df4eb4995980530ebc3d28715a67488"
+SRC_URI="https://github.com/jcs/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+KEYWORDS="~amd64"
+LICENSE="ISC"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXext
+"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ dobin xbanish
+ doman xbanish.1
+}